Bug 1066890 (webext-port-avira)

[tracking] WebExtensions-Port of Avira-Extensions ("Avira Browser Safety") (also [e10s])

RESOLVED FIXED

Status

()

Toolkit
WebExtensions: Compatibility
P3
normal
RESOLVED FIXED
3 years ago
3 months ago

People

(Reporter: Alice0775 White, Assigned: Markus Hartung)

Tracking

(Blocks: 3 bugs, {addon-compat})

unspecified
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [triaged] [sitewait], URL)

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Toolbar icon display. 
However, no reputation information bar appears at the top of the web page. and no reputation icon [!] display for google search result links.

Steps To Reproduce:
1. Open https://betacenter.avira.com/callout/?callid=D55041325B9B400895F934BF8EA3C0F9
   and follow instruction to install.
(Reporter)

Updated

3 years ago
Summary: [e10s] Avira Browser Safety does not work in e10s → [e10s] Avira Browser Safety beta1.3.2 does not work in e10s
Jason, the Avira Browser Safety add-on does not work with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
Blocks: 905436
tracking-e10s: ? → +
Summary: [e10s] Avira Browser Safety beta1.3.2 does not work in e10s → [e10s] "Avira Browser Safety beta1.3.2" add-on does not work in e10s: no reputation information bar appears at the top of the web page
Keywords: addon-compat
The developer has been contacted through AMO.

Comment 3

3 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> The developer has been contacted through AMO.
Thanks guys, I'll follow up internally and get back to you
(Assignee)

Comment 4

3 years ago
We are currently working on implementing e10s support and will upload an updated version in the next 2 weeks.

Best regards,
Markus
Telemetry reports that your addon is regularly throwing javascript exceptions in DNTContentPolicy.js 369.
Blocks: 1111730
Assignee: :tracy
Link to add-on: http://www.avira.com/en/avira-browser-safety
Contact info for add-on: markus.hartung@avira.com
Bug #: this bug 1066890
Add-on ID: unknown
How well does it work?: 0% - won't even install: browser message say the download is corrupt.
Any obvious performance problems? unknown
SDK-based: yes
Chromium version: yes - https://chrome.google.com/webstore/detail/avira-browser-safety/flliilndjeohchalpbbcdekjklbdgfkk
Flags: needinfo?(jmathies)

Comment 7

2 years ago
This is now installing properly, but I doubt it's working correctly due to all the errors I see when loading pages, for example - 
unsafe CPOW usage remote-browser.xml:164:0
unsafe CPOW usage background.js:10:0
unsafe CPOW usage background.js:6:0
unsafe CPOW usage background.js:10:0
unsafe CPOW usage background.js:6:0
unsafe CPOW usage remote-browser.xml:164:0
TypeError: context.contentDocument is undefined DNTContentPolicy.js:381:7
[Exception... "[JavaScript Error: "context.contentDocument is undefined" {file: "resource://gre/modules/addons/XPIProvider.jsm -> file:///C:/Users/jim/AppData/Roaming/Mozilla/Firefox/Profiles/t8mnte0p.default/extensions/abs@avira.com/bootstrap.js -> file:///C:/Users/jim/AppData/Roaming/Mozilla/Firefox/Profiles/t8mnte0p.default/extensions/abs@avira.com/components/DNTContentPolicy.js?1440757530648" line: 381}]'[JavaScript Error: "context.contentDocument is undefined" {file: "resource://gre/modules/addons/XPIProvider.jsm -> file:///C:/Users/jim/AppData/Roaming/Mozilla/Firefox/Profiles/t8mnte0p.default/extensions/abs@avira.com/bootstrap.js -> file:///C:/Users/jim/AppData/Roaming/Mozilla/Firefox/Profiles/t8mnte0p.default/extensions/abs@avira.com/components/DNTContentPolicy.js?1440757530648" line: 381}]' when calling method: [nsIContentPolicy::shouldLoad]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/modules/RemoteAddonsParent.jsm :: ContentPolicyParent.shouldLoad/result< :: line 153"  data: yes] RemoteAddonsParent.jsm:164:0
NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsILoadContext.associatedWindow] background.js:10:0
unsafe CPOW usage DNTContentPolicy.js:683:0
unsafe CPOW usage DNTContentPolicy.js:685:0
unsafe CPOW usage DNTContentPolicy.js:686:0
unsafe CPOW usage DNTContentPolicy.js:687:0
unsafe CPOW usage DNTContentPolicy.js:683:0
unsafe CPOW usage DNTContentPolicy.js:685:0
unsafe CPOW usage DNTContentPolicy.js:686:0
unsafe CPOW usage DNTContentPolicy.js:687:0
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. www.techmeme.com
TypeError: nwcbe is undefined www.techmeme.com:564:5
unsafe CPOW usage remote-browser.xml:164:0
Flags: needinfo?(jmathies)
(Assignee)

Comment 8

2 years ago
We are planning to switch to switch to an addon sdk based approach to avoid e10s issues.
status-firefox42: --- → affected
QA Contact: Tobias.Besemer
Summary: [e10s] "Avira Browser Safety beta1.3.2" add-on does not work in e10s: no reputation information bar appears at the top of the web page → [e10s] "Avira Browser Safety" add-on does not work in e10s: no reputation information bar appears at the top of the web page
Changed Summary because the newest stable is v1.5.0 and the newest beta (not yet for FF) is v1.6.0 ...
... so it is version independent.

Both version doesn't work ATM with e10s.
Corresponding bug in the Avira Beta Community:
https://betacenter.avira.com/project/feedback/view.html?cap=5D4F1B2CCC8A4B0982135269FB3C67F5&uf=4D092DD2B0214BB89835B4021026B64F&slsid=0C86E71F67E34A2C88DB972D06AC269D
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox43: --- → affected
OS: Windows 7 → Windows
Hardware: x86_64 → All
Version: Trunk → 42 Branch
Assignee: nobody → markus.hartung
Markus, we'd like to work with you towards getting something working with e10s. Also, based on the APIs you're using, Avira might be a good candidate for using our new WebExtensions API [1,2]. How are things going so far?

[1] https://blog.mozilla.org/addons/2015/08/21/the-future-of-developing-firefox-add-ons/
[2] https://wiki.mozilla.org/WebExtensions
Flags: needinfo?(markus.hartung)
(Assignee)

Comment 12

2 years ago
Hi Bill, we have already made some tests with WebExtensions but there were some issues with the webRequest API, I will check what issue it was. In general I would prefer the WebExtension API over the Addon SDK as it would allow us to reduce our browser specific code especially since Edge will have a similar concept.
For me the question is will WebExtensions be supported before e10s becomes default for the release versions of Firefox, if so we would consider directly switching to WebExtensions instead of the Addon SDK.
Flags: needinfo?(markus.hartung)
AFAIK there is no e10s required for WebExtension.

---

Testing out the WebExtensions API
First, you need to set up Firefox:
    download, install, and launch Firefox Nightly (Developer Edition also includes WebExtension support, but Nightly will always be more up-to-date).
    flip the preference that controls whether Firefox allows you to install unsigned add-ons:
        type about:config into the URL bar in Firefox
        in the Search box type xpinstall.signatures.required
        double-click the preference, or right-click and selected "Toggle", to set it to false.

From: https://wiki.mozilla.org/WebExtensions

---

Here is the plan to e10s:

---

The final release schedule for Electrolysis will be determined over the next several months as we test with more users. We would like developers to understand that, although there is a chance that the Electrolysis release schedule will be delayed or modified in the coming months, they should plan to update their add-ons to meet our current release plan as follows:

    August 11th (Firefox 42 merges to Developer Edition). Electrolysis has been enabled by default on Developer Edition (it is already the default on Nightly).
    September 22nd (Firefox 42 merges to Beta). Electrolysis will be available to users as an “opt-in” on the beta channel.
    November 3rd (Firefox 43 merges to Beta). The earliest release Electrolysis will be enabled by default on Beta. When Electrolysis is enabled by default we will begin blocklisting Electrolysis-incompatible add-ons that cause major performance and/or stability problems.
    December 15th (Firefox 43 merges to release). The earliest release Electrolysis will be enabled on the release channel, and our current planned release.
    Six months past enabling Electrolysis on Release. The deprecation of CPOWs and compatibility shims will begin. We will release further scheduling information as appropriate, but developers should be aware that any add-ons that depend on them will stop working within six to twelve months of the general availability of Electrolysis.

From: https://blog.mozilla.org/addons/2015/08/21/the-future-of-developing-firefox-add-ons/
Maybe also interesting for you: https://developer.mozilla.org/en-US/Add-ons/WebExtensions
(Assignee)

Comment 15

2 years ago
My first priority is not to lose compatibility with the release channel, that is not to say that we don't strive to be compatible with other beta, developer or nightly channels.

As part of becoming compatible we would switch either to using the Addon SDK or WebExtensions. But WebExtensions would only be an option if it will be included into the release channel before or at the same time as e10s.

So my question is will WebExtensions be available before e10s on the release channel, or should we go ahead and use the Addon SDK?
Hi Markus,

I be also part of the Avira Beta Community, so I know that e10s support was there requested by some people, too.
I also suggested there, that Avira develop in future on the aurora channel (alpha 2, Developer Edition).
When you will develop in future on aurora, that gives you and the Beta Community the chance, to have a stable version, when the stable version of FF is released.

I don't know much about WebExtension, but as far as I understand it, it will be at least shipped with FF42.0 that will be released November, 3th 2015. (Before e10s is the default setting!)
Here you can find a up to date version list (with roadmap) in German:
https://de.wikipedia.org/wiki/Versionsgeschichte_von_Mozilla_Firefox

We can also ask Bill McCloskey if he can give you more detailed informations about the ship of WebExtension ... and if it is maybe also included in FF41.0 that is released in 5 days ...

As you be with your actual extension not e10s compatible and your thinking is to switch "either to using the Addon SDK or WebExtensions", I would suggest you, to try to keep you existing extension running till November, 3th 2015 (maybe with versions 1.6, 1.7, ...) and work on a re-do on WebExtension (version 2.0?) and try to have this stable till the ship of FF42.0.

Greets, Tobias.
Flags: needinfo?(wmccloskey)
WebExtensions will definitely be on the release channel before e10s. An early version of it is in FF42, but we continue to improve support. I'd recommend you test with the latest Firefox nightly.

I think a good option would be to develop a WebExtension version of Avira. Once it's ready to be tested by users, you can set the minimum version so that it only works with a Firefox release that supports all the WebExtension APIs you need. You can continue shipping the non-WebExtension add-on to users simultaneously. You can also mark the WebExtension version as a beta if it's not ready. Then users can opt into that version.

If you decide to go with a WebExtension, please report any problems you have through bugzilla (there's a separate component, Toolkit :: WebExtensions). We're very eager to help out developers by adding API support and fixing bugs as needed.
Flags: needinfo?(wmccloskey)
Any updates here Markus? It's your decision whether to go with a WebExtension or the add-on SDK.
Flags: needinfo?(markus.hartung)

Comment 19

2 years ago
(In reply to Markus Hartung from comment #12)
> Hi Bill, we have already made some tests with WebExtensions but there were
> some issues with the webRequest API, I will check what issue it was. In
> general I would prefer the WebExtension API over the Addon SDK as it would
> allow us to reduce our browser specific code especially since Edge will have
> a similar concept.
> For me the question is will WebExtensions be supported before e10s becomes
> default for the release versions of Firefox, if so we would consider
> directly switching to WebExtensions instead of the Addon SDK.

Do you know what the issues with the webRequest API are, we'd like to prioritize those bugs. Currently we are tracking the following bugs on webRequest: https://bugzilla.mozilla.org/buglist.cgi?f1=status_whiteboard&list_id=12612671&o1=substring&resolution=---&query_format=advanced&v1=[webRequest]&component=WebExtensions&product=Toolkit
I guess it is OK to publish this here ...

http://abs-firefox.auc.avira.com/

Avira Browser Safety beta for Firefox
Changes with build 1.7.0:
- Updated PUA (Potentially unwanted applications) detection for notifying users that they landed on a page containing PUA
- Replaced the do-not-track feature of Abine with our own in-house developed solution. 

... but not e10s & WebExtension, yet.
status-firefox44: --- → affected
Seems "Avira SafeSearch Plus" is also not e10s compatible ...

http://www.avira.com/en/avira-safesearch-plus

Can someone verify that?

Comment 22

2 years ago
A quick update on what's currently going on with Avira's extensions.

Browser Safety is currently being ported to WebExtensions API. So far we have been experiencing only one issue (https://bugzilla.mozilla.org/show_bug.cgi?id=1214658). In case it's not solved in the way we'd expect, we have a fallback solution, so in the end the issue shouldn't really be a blocker for us.
We keep verifying whether all required APIs are fully functional in WebExtensions. If any further problems are found, bug reports will follow.

SafeSearch extension is also being reworked to be based on the SDK.
Depends on: 1214658
(Assignee)

Comment 23

2 years ago
(In reply to Bill McCloskey (:billm) from comment #18)
> Any updates here Markus? It's your decision whether to go with a
> WebExtension or the add-on SDK.

As Maciej already mentioned we decided to go with WebExtensions, there have some issues which we reported, but mostly we were able to create workarounds by now.
Flags: needinfo?(markus.hartung)
Alias: webext-port-avira

Updated

2 years ago
Depends on: 1224581
(Assignee)

Comment 24

2 years ago
Bill McCloskey, we were expecting to be able to use WebExtensions to avoid any issues with e10s and have successfully done so on Aurora and Nightly, but there still seems to be issues in the current beta channel.
Can we expect that bug fixes will still be applied to the beta channel before release of 43, and is there a final decision if e10s will be enabled in e10s in the 43 release in light of this?

I'm not sure that we could switch to a different approach for becoming e10s compatible and still finish in time.
Flags: needinfo?(wmccloskey)
(In reply to Markus Hartung from comment #24)
> Bill McCloskey, we were expecting to be able to use WebExtensions to avoid
> any issues with e10s and have successfully done so on Aurora and Nightly,
> but there still seems to be issues in the current beta channel.
> Can we expect that bug fixes will still be applied to the beta channel
> before release of 43, and is there a final decision if e10s will be enabled
> in e10s in the 43 release in light of this?

Markus, bug-fixes can be "uplifted" ...
As the release of FF43.0 is on December 15th, I guess this should be still possible ...
... and if not, I guess, that the default activation of e10s will be moved to FF44.0.

Can you be a little bit more specific what kind of problems do you still have in FF43.0b so that the devs can try to uplift the right bug-fixes?


> I'm not sure that we could switch to a different approach for becoming e10s
> compatible and still finish in time.
Flags: needinfo?(markus.hartung)
Markus, AFAIK is the Avira-Extension for free ...

Do you want to give the followers of the bug the chance to test the new one for you ???

You can post here a URL or attach the XPI to the bug ...
(Assignee)

Comment 27

2 years ago
I think it is a good idea, we will prepare a build and make it available.
Flags: needinfo?(markus.hartung)
(In reply to Markus Hartung from comment #27)
> I think it is a good idea, we will prepare a build and make it available.

Great! :-)

Do you saw my comment before with the question?

(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #25)
> (In reply to Markus Hartung from comment #24)
> > Bill McCloskey, we were expecting to be able to use WebExtensions to avoid
> > any issues with e10s and have successfully done so on Aurora and Nightly,
> > but there still seems to be issues in the current beta channel.
> > Can we expect that bug fixes will still be applied to the beta channel
> > before release of 43, and is there a final decision if e10s will be enabled
> > in e10s in the 43 release in light of this?
> 
> Markus, bug-fixes can be "uplifted" ...
> As the release of FF43.0 is on December 15th, I guess this should be still
> possible ...
> ... and if not, I guess, that the default activation of e10s will be moved
> to FF44.0.
> 
> Can you be a little bit more specific what kind of problems do you still
> have in FF43.0b so that the devs can try to uplift the right bug-fixes?
> 
> 
> > I'm not sure that we could switch to a different approach for becoming e10s
> > compatible and still finish in time.
Flags: needinfo?(markus.hartung)
(Assignee)

Comment 29

2 years ago
Yes, my colleague Maciej is compiling the list and will post it.
e10s will not be enabled in 43. The earliest it will be enabled is now Firefox 45. So you should have some time.

Thanks for working on this. Please let me know if there are any bugs we should focus on (either to be fixed or for uplift to aurora or beta). I'll take a look at bug 1224581 today.
Flags: needinfo?(wmccloskey)

Comment 31

2 years ago
(In reply to Bill McCloskey (:billm) from comment #30)
> e10s will not be enabled in 43. The earliest it will be enabled is now
> Firefox 45. So you should have some time.
> 
> Thanks for working on this. Please let me know if there are any bugs we
> should focus on (either to be fixed or for uplift to aurora or beta). I'll
> take a look at bug 1224581 today.

Thanks for the confirmation. What a relief ;)

So, Tobias, Bill, if anyone would like to take a look at what we've done so far, I've attached the xpi which is already functional in FF 44/45 and contains workarounds for the following:
- no access to chrome object for scripts injected via script tag into pages belonging to the extension (https://bugzilla.mozilla.org/show_bug.cgi?id=1214658)
- optional params for chrome.tabs.sendMessage are handled differently (https://bugzilla.mozilla.org/show_bug.cgi?id=1223422)

Although there are still 2 things we can't have workarounds for, hence blocking us:
- https://bugzilla.mozilla.org/show_bug.cgi?id=1224581 (being looked into already - thanks Bill)
- https://bugzilla.mozilla.org/show_bug.cgi?id=1213478 - particularly onHistoryStateUpdated

For testing the xpi there is additional setup required. As part of workaround #1 we've decided to serve the blocking notification page not from within the package, but from an external place. Because of that, you have to extract contents of blocked_page.zip and start a local http server (port 80) inside that folder, as the extension will be redirecting to localhost/blocked.html when blocking occurs.

If any further info is required, feel free to ask.

Comment 32

2 years ago
Created attachment 8690006 [details]
abs-webext.xpi

Comment 33

2 years ago
Created attachment 8690007 [details]
blocked_page.zip
Thanks, will install it.
status-firefox40: affected → ---
status-firefox41: affected → ---
status-firefox42: affected → ---
status-firefox43: affected → ---
status-firefox44: affected → ---
Depends on: 1223422, 1213478
Flags: needinfo?(markus.hartung)
OS: Windows → All
Version: 42 Branch → unspecified
Summary: [e10s] "Avira Browser Safety" add-on does not work in e10s: no reputation information bar appears at the top of the web page → WebExtensions-Port of Avira-Extensions ("Avira Browser Safety") (also [e10s])
OK, I installed it and I be a little bit confused ...
It installed and in the Addon-Manager it says that it was today updated (Screenshot 1), but it seems I still have the old version ...

I also saw some things you can do to improve your UX:
- At the end of the feature listing of point 3 you have a dot - at the others not (Screenshot 1).
- You can add a picture to it (Screenshot 2).
- You can add release notes to the extension (Screenshot 3).
OK, think I have the old one and I don't know how the new one looks like ...)
Created attachment 8690060 [details]
2015-11-20 14_21_04-Add-ons Manager - Nightly (Build 20151119065326).png
Created attachment 8690061 [details]
2015-11-20 14_22_03-Add-ons Manager - Nightly (Build 20151119065326).png
Created attachment 8690062 [details]
2015-11-20 14_23_06-Add-ons Manager - Nightly (Build 20151119065326).png
Maciej, if you want to release your extension with/for FF43.0, you should tell us your problems with the version.

(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #25)
> Can you be a little bit more specific what kind of problems do you still
> have in FF43.0b so that the devs can try to uplift the right bug-fixes?
Flags: needinfo?(maciej.cwiek)

Comment 40

2 years ago
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #35)
> OK, I installed it and I be a little bit confused ...
> It installed and in the Addon-Manager it says that it was today updated
> (Screenshot 1), but it seems I still have the old version ...
> 
> I also saw some things you can do to improve your UX:
> - At the end of the feature listing of point 3 you have a dot - at the
> others not (Screenshot 1).
> - You can add a picture to it (Screenshot 2).
> - You can add release notes to the extension (Screenshot 3).
> OK, think I have the old one and I don't know how the new one looks like ...)

Version number was just not increased in the attached xpi. UX aspects is a different story, but we appreciate for your tips :) I would purely focus on checking the functional part.

(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #39)
> Maciej, if you want to release your extension with/for FF43.0, you should
> tell us your problems with the version.
> 
> (In reply to Tobias B. Besemer [:BesTo] (QA) from comment #25)
> > Can you be a little bit more specific what kind of problems do you still
> > have in FF43.0b so that the devs can try to uplift the right bug-fixes?

With regards to bugs in 43 I think it no longer makes sense to test the extension with that beta, since e10s release has been postponed to 45. Nevertheless we did some quick investigation and here are the results:
- chrome.extension.getURL is broken - ExtensionContent.jsm line #88, wrong parameter is used
- chrome.tabs.query doesn't work with currentWindow = true filter applied
- interpolation in manifest file doesn't work
- sometimes, when sending messages from content to background, response callbacks are not fired
The latter was not fully investigated and therefore not confirmed where the underlying problem is. Although it's not reproducible in FF 44.
Flags: needinfo?(maciej.cwiek)
(In reply to Maciej Ćwiek from comment #40)
> Version number was just not increased in the attached xpi. UX aspects is a
> different story, but we appreciate for your tips :) I would purely focus on
> checking the functional part.

For me it looks like the extension is not updated on my system...
There is still no reputation information bar at the top of the web page, the Avira icon in the toolbar seems to have no functionality and I can't see anything else (like in a Google search), that looks like a feature from the extension. (It looks exactly as the problem with the old extension with e10s.)

AFAIK I should be able to use the extension now with e10s, right?

Test-System:
Win7, 64-bit
FF45.0a1, 64-bit, e10s, English

Btw.: If I have the new extension, you can set the compatibility of the extension up to FF45.0.
(In reply to Maciej Ćwiek from comment #31)
> So, Tobias, Bill, if anyone would like to take a look at what we've done so
> far, I've attached the xpi which is already functional in FF 44/45 and
> contains workarounds for the following:
> - no access to chrome object for scripts injected via script tag into pages
> belonging to the extension
> (https://bugzilla.mozilla.org/show_bug.cgi?id=1214658)

> For testing the xpi there is additional setup required. As part of
> workaround #1 we've decided to serve the blocking notification page not from
> within the package, but from an external place.

Does this mean you can't load e.g. a html-file from a sub-folder of the extension-folder?
(In reply to Maciej Ćwiek from comment #40)
> Nevertheless we did some quick investigation and here are the results:
> - chrome.extension.getURL is broken - ExtensionContent.jsm line #88, wrong
> parameter is used
> - chrome.tabs.query doesn't work with currentWindow = true filter applied
> - interpolation in manifest file doesn't work
> - sometimes, when sending messages from content to background, response
> callbacks are not fired
> The latter was not fully investigated and therefore not confirmed where the
> underlying problem is. Although it's not reproducible in FF 44.

Here is a list of all bugs that belongs to Toolkit\WebExtensions that got fixed in FF44.0:
https://bugzilla.mozilla.org/buglist.cgi?j_top=OR&f1=target_milestone&o3=equals&list_id=12695256&v3=Firefox%2044&o1=equals&resolution=FIXED&o2=anyexact&query_format=advanced&f3=target_milestone&f2=cf_status_firefox44&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&v1=mozilla44&component=WebExtensions&v2=fixed%2Cverified&product=Toolkit

As I'm not a programmer, I can't really figure out, which bugs that are...

Maybe Bill can do that...
(Assignee)

Comment 44

2 years ago
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #42)
> (In reply to Maciej Ćwiek from comment #31)
> > So, Tobias, Bill, if anyone would like to take a look at what we've done so
> > far, I've attached the xpi which is already functional in FF 44/45 and
> > contains workarounds for the following:
> > - no access to chrome object for scripts injected via script tag into pages
> > belonging to the extension
> > (https://bugzilla.mozilla.org/show_bug.cgi?id=1214658)
> 
> > For testing the xpi there is additional setup required. As part of
> > workaround #1 we've decided to serve the blocking notification page not from
> > within the package, but from an external place.
> 
> Does this mean you can't load e.g. a html-file from a sub-folder of the
> extension-folder?

We can load files from sub-folders, but the chrome object does not get injected as described in https://bugzilla.mozilla.org/show_bug.cgi?id=1214658 , so we load it from an outside resource and apply a specific content script to have it available.

Comment 45

2 years ago
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #41)
> (In reply to Maciej Ćwiek from comment #40)
> > Version number was just not increased in the attached xpi. UX aspects is a
> > different story, but we appreciate for your tips :) I would purely focus on
> > checking the functional part.
> 
> For me it looks like the extension is not updated on my system...
> There is still no reputation information bar at the top of the web page, the
> Avira icon in the toolbar seems to have no functionality and I can't see
> anything else (like in a Google search), that looks like a feature from the
> extension. (It looks exactly as the problem with the old extension with
> e10s.)
> 
> AFAIK I should be able to use the extension now with e10s, right?
> 
> Test-System:
> Win7, 64-bit
> FF45.0a1, 64-bit, e10s, English
> 
> Btw.: If I have the new extension, you can set the compatibility of the
> extension up to FF45.0.

Hmm... I'm not sure what could be wrong on your end, but I've just downloaded the attached xpi, fired up latest Nightly and successfully installed the extension through drag-n-drop. After that it started to work as expected. Can you see any errors thrown by ABS when installing it or loading a website?

You're correct, the addon should work in FF 44 and 45 with e10s on and off.

With regards to supported FF version entries in manifest - we have it on our TODO list, so that will be done soon. Although it should not affect testing, right?
(In reply to Maciej Ćwiek from comment #45)
> (In reply to Tobias B. Besemer [:BesTo] (QA) from comment #41)
> Hmm... I'm not sure what could be wrong on your end, [...]

Have you already tried to install the new version over the old one (not WebExtensions)?


> Can you see any errors thrown by ABS when installing it or
> loading a website?

Will try to monitor that.


> With regards to supported FF version entries in manifest - we have it on our
> TODO list, so that will be done soon. Although it should not affect testing,
> right?

Right!
It's just for us geeks to show that Avira is not "only" "state of the art", it's "on the bleeding edge of browser development". ;-) :D
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #43)
> (In reply to Maciej Ćwiek from comment #40)
> > Nevertheless we did some quick investigation and here are the results:
> > - chrome.extension.getURL is broken - ExtensionContent.jsm line #88, wrong
> > parameter is used
> > - chrome.tabs.query doesn't work with currentWindow = true filter applied
> > - interpolation in manifest file doesn't work
> > - sometimes, when sending messages from content to background, response
> > callbacks are not fired
> > The latter was not fully investigated and therefore not confirmed where the
> > underlying problem is. Although it's not reproducible in FF 44.
> 
> Here is a list of all bugs that belongs to Toolkit\WebExtensions that got
> fixed in FF44.0:
> https://bugzilla.mozilla.org/buglist.
> cgi?j_top=OR&f1=target_milestone&o3=equals&list_id=12695256&v3=Firefox%2044&o
> 1=equals&resolution=FIXED&o2=anyexact&query_format=advanced&f3=target_milesto
> ne&f2=cf_status_firefox44&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=
> CLOSED&v1=mozilla44&component=WebExtensions&v2=fixed%2Cverified&product=Toolk
> it
> 
> As I'm not a programmer, I can't really figure out, which bugs that are...
> 
> Maybe Bill can do that...

Bill, can you have a look at this, try to figure out which fixes are missing in FF43.0b that the extension run and request uplifts?
Thx in advance!
Flags: needinfo?(wmccloskey)
Depends on: 1208257
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #46)
> (In reply to Maciej Ćwiek from comment #45)
> > (In reply to Tobias B. Besemer [:BesTo] (QA) from comment #41)
> > Hmm... I'm not sure what could be wrong on your end, [...]
> 
> Have you already tried to install the new version over the old one (not
> WebExtensions)?
> 
> 
> > Can you see any errors thrown by ABS when installing it or
> > loading a website?
> 
> Will try to monitor that.


I get for ~2 sec. the following msgs in the browser console when I try to install the new one over the old one (update/upgrade).
Then the msgs disappear in the browser console again.

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/PopupNotifications.jsm :: PopupNotifications_refreshPanel/< :: line 667"  data: no] PopupNotifications.jsm:671:0
1448452019465	addons.xpi	ERROR	Failed to remove file C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\zypzyju5.default\extensions\trash\abs@avira.com.xpi: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: recursiveRemove :: line 1814"  data: no] Stack trace: recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1814 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1829 < DirInstallLocation_installAddon()@resource://gre/modules/addons/XPIProvider.jsm:7479 < AI_startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5823 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813 Log.jsm:751:0
1448452019466	addons.xpi	WARN	Failed to remove trash directory when installing abs@avira.com: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: recursiveRemove :: line 1814"  data: no] Stack trace: recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1814 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1829 < DirInstallLocation_installAddon()@resource://gre/modules/addons/XPIProvider.jsm:7479 < AI_startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5823 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813
Warning: attempting to write 9449 bytes to preference extensions.xpiState. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file.
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/PopupNotifications.jsm :: PopupNotifications_refreshPanel/< :: line 667"  data: no] PopupNotifications.jsm:671:0
1448452019792	Services.Metrics.Provider.org.mozilla.addons	WARN	Add-on type without field: dictionary
1448452019792	Services.Metrics.Provider.org.mozilla.addons	WARN	Add-on type without field: locale

Bill, can you have - beside comment #47 - a look on this, too?
Component: Extension Compatibility → WebExtensions
Product: Firefox → Toolkit
Summary: WebExtensions-Port of Avira-Extensions ("Avira Browser Safety") (also [e10s]) → [tracking] WebExtensions-Port of Avira-Extensions ("Avira Browser Safety") (also [e10s])
Flags: blocking-webextensions?
Blocks: 1214433
Flags: blocking-webextensions? → blocking-webextensions+
It looks like we would need to backport a lot of stuff to FF43 to make this extension work. It doesn't seem worth it to do that since Avira is blocked on a few bugs that are not yet fixed in nightly.

I was able to install the extension successfully. Tobias, The error console output suggests that there's a permissions error with your profile directory.
Flags: needinfo?(wmccloskey)
(In reply to Bill McCloskey (:billm) from comment #49)
> It looks like we would need to backport a lot of stuff to FF43 to make this
> extension work. It doesn't seem worth it to do that since Avira is blocked
> on a few bugs that are not yet fixed in nightly.

My idea was to get it at least installed on FF43.
So the Avira Beta Community can have a "Development Preview" and test the install...
Think also that there aren't much WebExtensions out there now, so the risk to break something shouldn't be so high...?

(In reply to Markus Hartung from comment #24)
> Bill McCloskey, we were expecting to be able to use WebExtensions to avoid
> any issues with e10s and have successfully done so on Aurora and Nightly,
> but there still seems to be issues in the current beta channel.

(In reply to Maciej Ćwiek from comment #31)
> So, Tobias, Bill, if anyone would like to take a look at what we've done so
> far, I've attached the xpi which is already functional in FF 44/45 and
> contains workarounds for the following:
> - no access to chrome object for scripts injected via script tag into pages
> belonging to the extension
> (https://bugzilla.mozilla.org/show_bug.cgi?id=1214658)
> - optional params for chrome.tabs.sendMessage are handled differently
> (https://bugzilla.mozilla.org/show_bug.cgi?id=1223422)


(In reply to Bill McCloskey (:billm) from comment #49)
> I was able to install the extension successfully. Tobias, The error console
> output suggests that there's a permissions error with your profile directory.

Also I think my errors come from my "upgrade test" ...

(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #48)
> I get for ~2 sec. the following msgs in the browser console when I try to
> install the new one over the old one (update/upgrade).
> Then the msgs disappear in the browser console again.

Even if I would be maybe able to "fix this by hand", it isn't a "solution for the masses".

Also it doesn't explain, why the msgs disappear after ~2 sec. in the console...


Here the msgs again:
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/PopupNotifications.jsm :: PopupNotifications_refreshPanel/< :: line 667"  data: no] PopupNotifications.jsm:671:0

1449013028695	addons.xpi	ERROR	Failed to remove file C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\zypzyju5.default\extensions\trash\abs@avira.com.xpi: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: recursiveRemove :: line 1843"  data: no] Stack trace: recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1843 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1858 < .installAddon()@resource://gre/modules/addons/XPIProvider.jsm:7639 < AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5934 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813 Log.jsm:751:0

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/PopupNotifications.jsm :: PopupNotifications_refreshPanel/< :: line 667"  data: no] PopupNotifications.jsm:671:0


Bill, if you like to, you can make this "upgrade test" for you self by installing first the old version of the extension:

(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #20)
> I guess it is OK to publish this here ...
> 
> http://abs-firefox.auc.avira.com/
> 
> Avira Browser Safety beta for Firefox
> Changes with build 1.7.0:
> - Updated PUA (Potentially unwanted applications) detection for notifying
> users that they landed on a page containing PUA
> - Replaced the do-not-track feature of Abine with our own in-house developed
> solution. 
> 
> ... but not e10s & WebExtension, yet.
Tracy, can you try to reproduce this? You need to install the old version of this extension from http://abs-firefox.auc.avira.com/. Then upgrade to the XPI that's attached to this bug. Tobias is seeing exceptions in the console when he upgrades.
Flags: needinfo?(twalker)
If I could get this installed, I'd be glad to try the upgrade path.  However, the version(beta) you linked to won't install on Mac; browser message says the download is corrupt.  I've never been able to install this add-on. Not sure how Jim got it to install (comment #7).
Flags: needinfo?(twalker)
Did you disable signing verification? You need to set xpinstall.signatures.required to false.
Flags: needinfo?(twalker)
Tracy, you can try the sable version from AMO, too.

https://addons.mozilla.org/en-us/firefox/addon/avira-browser-safety/
I got:
Could not read chrome manifest 'file:///Users/tracy/Desktop/FxNightly.app/Contents/Resources/chrome.manifest'.
1449074888074	addons.xpi	WARN	Problem getting last modified time for /Users/tracy/Library/Application Support/Firefox/Profiles/k2nje964.default-1415640912871/extensions/abs@avira.com: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.lastModifiedTime]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: recursiveLastModifiedTime :: line 1881"  data: no] Stack trace: recursiveLastModifiedTime()@resource://gre/modules/addons/XPIProvider.jsm:1881 < getModTime()@resource://gre/modules/addons/XPIProvider.jsm:2029 < syncWithDB()@resource://gre/modules/addons/XPIProvider.jsm:2091 < AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5944 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813
1449074888075	addons.xpi	WARN	Can't get modified time of /Users/tracy/Library/Application Support/Firefox/Profiles/k2nje964.default-1415640912871/extensions/abs@avira.com: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.lastModifiedTime]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: getModTime :: line 2055"  data: no] Stack trace: getModTime()@resource://gre/modules/addons/XPIProvider.jsm:2055 < syncWithDB()@resource://gre/modules/addons/XPIProvider.jsm:2091 < AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5944 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813
Use of nsIFile in content process is deprecated. Content.js:23:17
migrations don't work currently background.js:20701:10
Unable to parse JSON data for extension storage. ExtensionStorage.jsm:47:0
not well-formed

However, the updated version offered and walked through an introduction and the add-on appears to be working.  It wasn't working in e10s before the update.
Flags: needinfo?(twalker)
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #50)
> (In reply to Bill McCloskey (:billm) from comment #49)
> > I was able to install the extension successfully. Tobias, The error console
> > output suggests that there's a permissions error with your profile directory.
> 
> Also I think my errors come from my "upgrade test" ...
> 
> (In reply to Tobias B. Besemer [:BesTo] (QA) from comment #48)
> > I get for ~2 sec. the following msgs in the browser console when I try to
> > install the new one over the old one (update/upgrade).
> > Then the msgs disappear in the browser console again.
> 
> Even if I would be maybe able to "fix this by hand", it isn't a "solution
> for the masses".
> 
> Also it doesn't explain, why the msgs disappear after ~2 sec. in the
> console...
> 
> 
> Here the msgs again:
> [Exception... "Component returned failure code: 0x80004005
> (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005
> (NS_ERROR_FAILURE)"  location: "JS frame ::
> resource://gre/modules/PopupNotifications.jsm ::
> PopupNotifications_refreshPanel/< :: line 667"  data: no]
> PopupNotifications.jsm:671:0
> 
> 1449013028695	addons.xpi	ERROR	Failed to remove file
> C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\zypzyju5.
> default\extensions\trash\abs@avira.com.xpi: [Exception... "Component
> returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)
> [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" 
> location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm ::
> recursiveRemove :: line 1843"  data: no] Stack trace:
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1843 <
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1858 <
> .installAddon()@resource://gre/modules/addons/XPIProvider.jsm:7639 <
> AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/
> XPIProvider.jsm:5934 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 <
> Handler.prototype.process()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:934 <
> this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:813 Log.jsm:751:0
> 
> [Exception... "Component returned failure code: 0x80004005
> (NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005
> (NS_ERROR_FAILURE)"  location: "JS frame ::
> resource://gre/modules/PopupNotifications.jsm ::
> PopupNotifications_refreshPanel/< :: line 667"  data: no]
> PopupNotifications.jsm:671:0
> 
> 
> Bill, if you like to, you can make this "upgrade test" for you self by
> installing first the old version of the extension:
> 
> (In reply to Tobias B. Besemer [:BesTo] (QA) from comment #20)
> > I guess it is OK to publish this here ...
> > 
> > http://abs-firefox.auc.avira.com/
> > 
> > Avira Browser Safety beta for Firefox
> > Changes with build 1.7.0:
> > - Updated PUA (Potentially unwanted applications) detection for notifying
> > users that they landed on a page containing PUA
> > - Replaced the do-not-track feature of Abine with our own in-house developed
> > solution. 
> > 
> > ... but not e10s & WebExtension, yet.

(In reply to [:tracy] Tracy Walker - QA Mentor from comment #55)
> However, the updated version offered and walked through an introduction and
> the add-on appears to be working.  It wasn't working in e10s before the
> update.

Tracy, would you, or someone else from the QA-Team, be so nicely and test it on Windows?
Would prefer the 64-bit version...
Flags: needinfo?(twalker)
Maciej, Markus, FYI:

(In reply to [:tracy] Tracy Walker - QA Mentor from comment #55)
> I got:
> Could not read chrome manifest
> 'file:///Users/tracy/Desktop/FxNightly.app/Contents/Resources/chrome.
> manifest'.
> 1449074888074	addons.xpi	WARN	Problem getting last modified time for
> /Users/tracy/Library/Application
> Support/Firefox/Profiles/k2nje964.default-1415640912871/extensions/abs@avira.
> com: [Exception... "Component returned failure code: 0x80520006
> (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.lastModifiedTime]"  nsresult:
> "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame ::
> resource://gre/modules/addons/XPIProvider.jsm :: recursiveLastModifiedTime
> :: line 1881"  data: no] Stack trace:
> recursiveLastModifiedTime()@resource://gre/modules/addons/XPIProvider.jsm:
> 1881 < getModTime()@resource://gre/modules/addons/XPIProvider.jsm:2029 <
> syncWithDB()@resource://gre/modules/addons/XPIProvider.jsm:2091 <
> AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/
> XPIProvider.jsm:5944 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 <
> Handler.prototype.process()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:934 <
> this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:813
> 1449074888075	addons.xpi	WARN	Can't get modified time of
> /Users/tracy/Library/Application
> Support/Firefox/Profiles/k2nje964.default-1415640912871/extensions/abs@avira.
> com: [Exception... "Component returned failure code: 0x80520006
> (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.lastModifiedTime]"  nsresult:
> "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame ::
> resource://gre/modules/addons/XPIProvider.jsm :: getModTime :: line 2055" 
> data: no] Stack trace:
> getModTime()@resource://gre/modules/addons/XPIProvider.jsm:2055 <
> syncWithDB()@resource://gre/modules/addons/XPIProvider.jsm:2091 <
> AddonInstall.prototype.startInstall/<()@resource://gre/modules/addons/
> XPIProvider.jsm:5944 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 <
> Handler.prototype.process()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:934 <
> this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:813
> Use of nsIFile in content process is deprecated. Content.js:23:17
> migrations don't work currently background.js:20701:10
> Unable to parse JSON data for extension storage. ExtensionStorage.jsm:47:0
> not well-formed

Is this problem known by Avira and/or can you reproduce it ???
Flags: needinfo?(maciej.cwiek9)
And this one:

(In reply to [:tracy] Tracy Walker - QA Mentor from comment #52)
> If I could get this installed, I'd be glad to try the upgrade path. 
> However, the version(beta) you linked to won't install on Mac; browser
> message says the download is corrupt.  I've never been able to install this
> add-on. Not sure how Jim got it to install (comment #7).
Flags: needinfo?(markus.hartung)
> Tracy, would you, or someone else from the QA-Team, be so nicely and test it
> on Windows?
> Would prefer the 64-bit version...

Works on Win 7 (32-bit version)
Flags: needinfo?(twalker)

Updated

a year ago
Whiteboard: triaged

Updated

a year ago
Whiteboard: triaged → [triaged] [sitewait]
Blocks: 1280062

Updated

11 months ago
Depends on: 1258360
Markus and Maciej, this add-on is on our list of web extensions that are available on the Chrome store which we would like to try to enable for Firefox. We are treating this list as a priority over the next few months. I've read through the bug and I'm not sure where things stand. It sounds like you have/had a version of the Firefox add-on that was written as a web extension which was being tested. Is it worthwhile to continue testing with that extension and trying to get it to work, or should we rather simply target the codebase that is currently available on the Chrome store and try to get that working with Firefox? Our goal is to allow developers to have a single codebase which works for both Chrome and Firefox.
(Assignee)

Comment 61

11 months ago
Hi Bob,
thank you for the support offer, actually things have progressed quite a lot, we are planning to switch our beta channel users running Firefox 47 and above to a web-extensions based build early next week.
All major issues have been solved, unless new ones pop up in beta, and the remaining ones should not be blockers. I will post a link to the beta here as soon as it's ready.
(Assignee)

Comment 62

11 months ago
Also Maciej isn't working on the project anymore so you can clear his need info flag.
Flags: needinfo?(markus.hartung)
Thanks for the update, Markus. I will remove Maciej's flag.
Flags: needinfo?(maciej.cwiek9)

Comment 64

8 months ago
Is bug 1252129 or bug 1190687 required for Avira?
Component: WebExtensions: Untriaged → WebExtensions: Compatibility
Flags: blocking-webextensions+
Priority: -- → P3
(Assignee)

Comment 65

8 months ago
It doesn't seem to affect us atm.

Also https://download.avira.com/package/abs/firefox/abs-webext.xpi is the link to our current web extensisons build.

Updated

8 months ago
No longer depends on: 1213478

Comment 66

3 months ago
Noting that with runtime.onMessageExternal landing there are zero blocking bugs on this now for moving to a WebExtension. Let us know if there's anything else that crops up.
(Assignee)

Comment 67

3 months ago
I think we can close this issue, 77% of users are already updated to the web extensions based version and all new installs are webext builds.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.