Closed Bug 1066974 Opened 8 years ago Closed 8 years ago

The From label, To label and ETC are not exposed correctly to orca.

Categories

(Thunderbird :: Disability Access, defect)

31 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 934874

People

(Reporter: vilmar, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140912222815

Steps to reproduce:

When reading a message using orca and pressing tab/shift+tab to locate the From field, To field and etc, I observed that some labels are not spoken correctly by orca.

This is because it seems that thunderbird is not exposing the labels correctly.
I found the following in the debug file of orca:

OBJECT EVENT: object:state-changed:focused
detail=(1,0,0) app.name='Thunderbird' name='T: Orca List
<orca-list@gnome.org>' role='entry' state='enabled focusable
focused opaque sensitive showing single line visible selectable
text' relations=''





Actual results:

Instead of
 name='T: Orca List <orca-list@gnome.org>'
the object:state-changed:focused
 should contain something like the following:
name='To: Orca List <orca-list@gnome.org>'
Blocks: orca
Component: Untriaged → Disability Access
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934874
You need to log in before you can comment on or make changes to this bug.