Closed Bug 934874 Opened 6 years ago Closed 5 years ago

Thunderbird: Header labels in message reader have last letter of aria-label truncated

Categories

(Thunderbird :: Disability Access, defect)

defect
Not set

Tracking

(thunderbird33 fixed, thunderbird34 fixed, thunderbird_esr3133+ fixed)

VERIFIED FIXED
Thunderbird 34.0
Tracking Status
thunderbird33 --- fixed
thunderbird34 --- fixed
thunderbird_esr31 33+ fixed

People

(Reporter: Jamie, Assigned: Jamie)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

Str:
1. Open a message for reading in Thunderbird.
2. Examine the accessibles for the message headers (from, to, subject, etc.).
Expected: They should have prefixes like "from:", "to:", "subject:", etc. Instead, they have prefixes like "fro:", "t:", "subjec:", etc.

This used to work as expected, but broke a few months ago. I don't know exactly when. It's obviously not a huge problem, but it's certainly very strange.
Moving under Thunderbird product until we figure out who is guilty
Component: Disability Access APIs → Disability Access
Product: Core → Thunderbird
This regression was introduced by this commit:
http://hg.mozilla.org/comm-central/rev/2e455a3aafa8
The labels for the headers used to have a space at the end, so the code which sets aria-label slices off the last character. After this commit, the trailing space is gone, so the slice kills the last letter instead.
Attached patch Patch.Splinter Review
I've updated the tests, but I can't figure out how to get them to actually run on Windows. There doesn't seem to be a rule for mozmill-one anywhere, even though this article suggests it should work from objdir:
https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/Thunderbird_MozMill_Testing#Running_Mozmill_Tests
Comment on attachment 8473439 [details] [diff] [review]
Patch.

Hi mkmelin. I hope you're the right person to ask for review. Sorry if not!
Attachment #8473439 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8473439 [details] [diff] [review]
Patch.

Review of attachment 8473439 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! r=mkmelin

cd /opt/moz-objdir/mail/mozilla
make SOLO_TEST=message-header/test-message-header.js mozmill-one

(Note the /mozilla part atm, not sure if it's permanent or just temporary, the build system is in flux.) Oh, and I had the patch for bug 1055926 applied.
Attachment #8473439 - Flags: review?(mkmelin+mozilla) → review+
Assignee: nobody → jamie
Blocks: 686427
Status: NEW → ASSIGNED
Keywords: access
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Thunderbird: Header labels in message reader have last letter truncated → Thunderbird: Header labels in message reader have last letter of aria-label truncated
(In reply to Magnus Melin from comment #5)
> Looks good to me! r=mkmelin
Thanks! Are you able to check this in for me? (I was going to add checkin-needed, but MDN suggests I ask the reviewer first. :))
With the state of the tree these days, I'll just add checkin-needed
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/5d123ee9af68
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
Do we want to backport this to TB 31? If so, please request approval.
It's not hugely important, but it certainly makes things more polished for assistive technology users. (Imagine if visually, all of the header labels had their last letter truncated.)

What's the backport approval process? Does it follow the guidelines here:
https://wiki.mozilla.org/Release_Management/Uplift_rules
or is there other documentation I should read?
Pretty much. Basically you just go to the attachment 8473439 [details] [diff] [review] details, and set the approval‑comm‑esr31 flag to "?", then fill in the questions in the template that appears. And yes, we should take this I think.
Comment on attachment 8473439 [details] [diff] [review]
Patch.

Review of attachment 8473439 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, lets get this onto what's going to become beta for some more testing
Attachment #8473439 - Flags: approval-comm-esr31?
Attachment #8473439 - Flags: approval-comm-aurora+
I started filling in a request for ESR approval, but I wanted to verify that it works on nightly first. Unfortunately, the latest nightly doesn't include it and nightlies seem to have stalled again...
Verified fixed in Thunderbird 35.0a1 (2014-09-02).
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1066974
I can confirm that it works with orca.
TB version 35.0a1 (2014-09-13)
While I was testing this bug, I noticed that the field that displays the date does not have an associated name. Is it possible create a prefix/name to this field?
May I open an RFE?
Attachment #8473439 - Flags: approval-comm-esr31? → approval-comm-esr31+
You need to log in before you can comment on or make changes to this bug.