[Browser][History] Browser history does not display when app is freshly launched.

VERIFIED FIXED in 2.1 S5 (26sep)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Marty, Assigned: daleharvey)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-Daily-Testing][systemsfe][2.1-flame-test-run-2])

Attachments

(3 attachments)

Posted file logcat-Browser.txt
Description:
Opening the Browser app does not display any previous Browser history.  If the user navigates to any  web pages, opening a new instance of the Browser app will display the history, but if the user terminates all web pages and instances of the Browser app, reopening the app will once again not display any history.

Note: The browser app will not show the default Mozilla and Firefox OS links either.

Repro Steps:
1) Update a Flame device to BuildID: 20140915000203
2) Navigate to one or more web pages (google.com, twitter.com, etc.)
3) Close all browsers and web pages from the Task Manager
4) Reopen the Browser app.
  
Actual:
No Browser history is displayed on a fresh launch of the Browser app.
  
Expected: 
The Browser app displays browser history properly.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20140915000203
Gaia: 944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko: 7546fedad918
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: This issue occurs on both 319MB and 512MB memory.
  
Repro frequency: 7/7
See attached: logcat, screenshot.

---------------------------------------------------------------------

This issue does NOT occur on Flame Master.
Browser history is displayed properly.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140915040203
Gaia: 855be6ade407c26e0596e7306a44deebc3f60933
Gecko: f27ff178807d
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


---------------------------------------------------------------------

This issue does NOT occur on Friday's Flame 2.1.
Browser history is displayed properly.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140912000203
Gaia: 7fe8807b384e1867fa4322f49a1310126fc5a849
Gecko: 1d4b0fc511dc
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


---------------------------------------------------------------------

This issue does NOT occur on Flame 2.0.
Browser history is displayed properly.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140915000202
Gaia: 7edd3b0b9f65c3dde235c732d270e43e055a1254
Gecko: 13e04ab68621
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.1-Daily-Testing]
Whiteboard: [2.1-Daily-Testing] → [2.1-Daily-Testing][systemfe]
[Blocking Requested - why for this release]:
Regression of a core feature with high visibility (every time you launch browser).

Requesting a window.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Whiteboard: [2.1-Daily-Testing][systemfe] → [2.1-Daily-Testing][systemsfe]
blocker justification: core functionality not working
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → dale
Target Milestone: --- → 2.1 S5 (26sep)
Component: Gaia::Browser → Gaia::System::Browser Chrome
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-Daily-Testing][systemsfe] → [2.1-Daily-Testing][systemsfe][2.1-flame-test-run-2]
QA Contact: aalldredge
Aurora regression window:

Last working:
Device: Flame 2.1
BuildID: 20140912081053
Gaia: 59e5c2467b7b8219ed194a0d0a94c6ed59af95be
Gecko: b09d2857b74e
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken:
Device: Flame 2.1
BuildID: 20140912095609
Gaia: d4de4123c678b198692af256254a26507e9c9a08
Gecko: 6f6cc4b975b0
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 59e5c2467b7b8219ed194a0d0a94c6ed59af95be
Gecko: 6f6cc4b975b0

First Broken Gaia Last working Gecko: Issue DOES reproduce
Gaia: d4de4123c678b198692af256254a26507e9c9a08
Gecko: b09d2857b74e

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/59e5c2467b7b8219ed194a0d0a94c6ed59af95be...d4de4123c678b198692af256254a26507e9c9a08

Caused by Bug 1053261
Flags: needinfo?(jmitchell)
Broken by Bug 1053261?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Flags: needinfo?(ktucker)
Ok, one of the shared functions used in the top sites hasnt been upflifted to 2.1 https://bugzilla.mozilla.org/show_bug.cgi?id=990047, will flag that for blocking
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Comment on attachment 8492199 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24223

Looks good, thanks!
Attachment #8492199 - Flags: review?(kgrandon) → review+
Test landed to master here: https://github.com/mozilla-b2g/gaia/commit/7d538e0b930eab9a49e83c27478f6d65efec91ae

We should be able to uplift this to 2.1 with a=testonly if we wanted to.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Issue verified as fixed on Flame 2.1 and Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Browsing history and top sites appear on all browser launches
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.