HTML5 YouTube player stops video with only audio still playing if setting media.mediasource.enabled=true

VERIFIED WORKSFORME

Status

()

defect
--
critical
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({hang, regression, reproducible})

35 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34 unaffected, firefox35 verified)

Details

(Whiteboard: [fixed by Bug 1062657])

(Reporter)

Description

5 years ago
Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/bf5fcc0c4b27
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140915030204


Reproducible: always

Steps To Reproduce:
0. Start Firefox with newly created profile
1. set media.mediasource.enabled=true in about:config
2. Open http://www.youtube.com/html5 and make sure default player is HTML5
3. Open https://www.youtube.com/watch?v=BH0BNbwqNK8&webm=1&html5=1

Actual Results:
Video stops after about 15 seconds.
Sound is continue playing.

Expected Results:
Play back without problem.


NOTE
This is happens regardless of non-e10s and e10s.
(Reporter)

Comment 1

5 years ago
There are 2 Regression/Progression window.
#1 Regression:
  Video and sound compretely stop at 14 seconds.
#2 Progression:
  Video stops after about 15 seconds, However audio is continue playing.


#1 Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/bfef88becbba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140903123624
Bad: Video and sound compretely stop at 14 seconds
https://hg.mozilla.org/mozilla-central/rev/acbdce59da2f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140903133924
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bfef88becbba&tochange=acbdce59da2f


#2 Progression window(m-c)
Bad: Video and sound compretely stop at 14 seconds
https://hg.mozilla.org/mozilla-central/rev/776fa9cf70cd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140903193340
Bad: Video stops after about 15 seconds, However audio is continue playing
https://hg.mozilla.org/mozilla-central/rev/7bfd030e8fc8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140904060022
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=776fa9cf70cd&tochange=7bfd030e8fc8
Keywords: regression
(Reporter)

Updated

5 years ago
Version: Trunk → 35 Branch
(Reporter)

Comment 2

5 years ago
[Tracking Requested - why for this release]:

#1 Regressed by: Bug 1061007
  Video and sound compretely stop at 14 seconds.
#2 Progression by: Bug 1059058
  Video stops after about 15 seconds, Audio is continue playing.


#1 Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ed25465c10f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140902181902
Bad: Video and sound compretely stop at 14 seconds
https://hg.mozilla.org/integration/mozilla-inbound/rev/57db771b7b9d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140902183701
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7ed25465c10f&tochange=57db771b7b9d

Regressed by: Bug 1061007


#2 Progression window(m-i)
Bad: Video and sound compretely stop at 14 seconds
https://hg.mozilla.org/integration/mozilla-inbound/rev/c00ae6dd85ec
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140903233020
Bad: Video stops after about 15 seconds, Audio is continue playing
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a4df73f1ab8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140904003821
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c00ae6dd85ec&tochange=8a4df73f1ab8
Progressed by: 
8a4df73f1ab8	Matthew Gregan — Bug 1059058 - Introduce abstraction to manager mapping between SourceBuffers and SourceBufferDecoders for the MediaSourceReader. r=cajbir
Blocks: 1059058, 1061007
Whiteboard: [Dupe me]
(Reporter)

Updated

5 years ago
Keywords: hang, reproducible
(Reporter)

Updated

5 years ago
Severity: normal → critical
(Reporter)

Updated

5 years ago
See Also: → 1067558
(Reporter)

Updated

5 years ago
See Also: 1067558
Please try the next Nightly build; this should be fixed by the two WebM timecode fixes that landed recently.
(Reporter)

Comment 4

5 years ago
(In reply to Matthew Gregan [:kinetik] from comment #3)
> Please try the next Nightly build; this should be fixed by the two WebM
> timecode fixes that landed recently.

Yes,  It seems to be fixed.

Progression window(m-i)
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a97b7eb9fa00
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140915144733
Good, Fixed video and audio play back
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed5f95178615
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140915150833
Fixed pushlog;
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a97b7eb9fa00&tochange=ed5f95178615
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Depends on: 1062657
Whiteboard: [fixed by Bug 1062657]
You need to log in before you can comment on or make changes to this bug.