[E10S] The HTML5 YouTube player freezes video with only audio still playing

RESOLVED DUPLICATE of bug 1077086

Status

()

RESOLVED DUPLICATE of bug 1077086
5 years ago
5 years ago

People

(Reporter: achwaqkhalid, Assigned: handyman)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm3+)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Build ID: 20140915030204

Steps to reproduce:

- Go to YouTube opt-in for the HTML5 player at (YouTube.com/html5) assuming that E10S is enabled this will take 3 times to load in comparison to a non e10s window (see here: https://bugzilla.mozilla.org/show_bug.cgi?id=1062713)

- Click on a video


Actual results:

- The video will freeze after 3 to 5 seconds of playback with only the audio still playing

NB: MSE is already enabled in About:config


Expected results:

You already know ;)
(Reporter)

Updated

5 years ago
Blocks: 516752
Depends on: 1000686
Are you testing with Firefox 29 or a Nightly build?  MSE isn't expected to work in 29, you need to be testing against Nightly.
(Reporter)

Comment 2

5 years ago
(In reply to Matthew Gregan [:kinetik] from comment #1)
> Are you testing with Firefox 29 or a Nightly build?  MSE isn't expected to
> work in 29, you need to be testing against Nightly.

No! i'm of course on the latest nightly channel 35.0a1
Component: Untriaged → Video/Audio
Product: Firefox → Core
Version: 29 Branch → Trunk

Updated

5 years ago
tracking-e10s: --- → ?

Updated

5 years ago
See Also: → bug 1067785

Updated

5 years ago
See Also: bug 1067785bug 1064847
Assignee: nobody → davidp99
tracking-e10s: ? → m3+
(Assignee)

Comment 3

5 years ago

Comment 4

5 years ago
I can confirm that, especially when you start scrolling down fast with video playing. Problem is that happens with flash as well.
(Reporter)

Comment 5

5 years ago
I don't think the issue depends solely on e10s! With it disabled i still experience this issue even with embedded videos, enabling e10s will just add up
(Assignee)

Comment 6

5 years ago
Turns out this was a duplicate - bug 1077086.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1077086
(Reporter)

Comment 8

5 years ago
1st - I don't know about you guys but i'm still dealing with this issue (The YouTube video will freeze after 3-5 seconds with only audio playing and then resume later

2nd - why would this be marked as duplicate of bug 1077086 ?!! that video plays fine for me, while this bug is about the YouTube player...

NB: 

- i'm running 230 tabs (23 are fully loaded, 4 pinned)

- dom.ipc.processCount is set to 4
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(epinal99-bugzilla)
Flags: needinfo?(davidp99)
Resolution: DUPLICATE → ---
(Assignee)

Comment 9

5 years ago
Hi Achwaq,

The bug you are describing is different than the bug in the initial description.  The initial description doesn't mention video resuming later.  To debug it, I used these steps:

0. Set media.mediasource.enabled
1. Open an e10s window
2. Go to youtube and play a video

The video would play for about 3-5 seconds (different each time) and then freeze.  Usually, the audio would continue but sometimes not.  This was exactly the reported behavior for this bug and it is similar to the behavior described in bug 1077086... and it is gone with that patch (indeed, I just re-verified this).

I have not seen behavior where the video pauses for an extended period (how long?) but eventually resumes.  If you still see this and you believe that it's not a network issue then feel free to file a new bug describing that behavior.  Please be sure to provide a detailed description and complete steps to reproduce it.
Flags: needinfo?(epinal99-bugzilla)
Flags: needinfo?(davidp99)
(Reporter)

Comment 10

5 years ago
Yes David, I confirm that it's not a network problem since the buffering is still occurring (i even restarted my router to get rid off any network problem possibility) and according to a network monitoring tool only firefox is using the network at that moment, i didn't mention that the video will resume later because it's arbitrary (sometimes it resumes, sometimes it doesn't)

the hang period (video freeze) depends on how busy the main parent firefox.exe is (how many tabs are open, how many child process are loaded (dom.ipc.processcount) and for how long the browser was running....) unless i'm wrong i don't think we are experiencing with the same running environment since i have 230+ tabs now and my machine is running 7 days per week + firefox is always running (restart just for updates)

the only workaround that i'm using so far is when opening a YouTube video link i will pause it at 0-1 second until firefox.exe is free enough and then resume the playback (although sometimes this doesn't work)
(Assignee)

Comment 11

5 years ago
I'm reclosing this as a duplicate.  Achwaq, you can file a new bug for the behavior you are seeing.  If you do, please include the information you posted in comment 10 as well as anything else that might be relevant to reproducing the behavior.  In particular, be sure to mention any settings that you might have manually changed.  This can be easily done by posting the Troubleshooting Information (from the Firefox '?' menu).

FYI, things like settings values and somewhat unusual things like "I have many, many tabs open" or "I've been running for many weeks straight" affect our debugging process.  Making these points upfront will help a lot.

For the time being, I'd recommend not changing dom.ipc.processcount from its default value.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077086
I am seeing this too with youtube MP4 content using the MSE/DASH player.

Can reproduce it consistently...

Behaviour is a few video frame appearing still from time to time... audio is good
(Reporter)

Comment 13

5 years ago
Well! funny how disabling Adblock Plus actually will fix all my previously reported e10s issues, the freeze at the beginning of the video is gone now.

but as mentioned in comment 18 by Cresto in bug 1060406 why is this "layers.acceleration.force-enabled" not enabled by default?
You need to log in before you can comment on or make changes to this bug.