Cannot open new tabs [TypeError: redeclaration of variable tab][TypeError: tabmail.registerTabType is not a function]

RESOLVED DUPLICATE of bug 1054357

Status

Thunderbird
Toolbars and Tabs
--
blocker
RESOLVED DUPLICATE of bug 1054357
4 years ago
4 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

({regression})

35 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Using Thunderbird 35.0a1 (20140916030202) it is not possible to open new tabs like Tools > Add-ons or Help > Troubleshooting Information. Console shows:

Error: TypeError: redeclaration of variable iter
Source File: chrome://messenger/content/folderPane.js
Line: 2483, Column: 8
Source Code:
    let iter = fixIterator(folder.messages); 

Error: TypeError: redeclaration of variable notification
Source File: chrome://messenger/content/plugins.js
Line: 697

Error: TypeError: redeclaration of variable tab
Source File: chrome://messenger/content/tabmail.xml
Line: 811, Column: 16
Source Code:
            let tab = JSON.parse(JSON.stringify(tab)); 

Error: TypeError: redeclaration of variable allFolders
Source File: chrome://messenger/content/folderWidgets.xml
Line: 569, Column: 14
Source Code:
          let allFolders = allFolders.filter(function (f) f.canFileMessage

Error: TypeError: tabmail.registerTabType is not a function
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 488

Error: TypeError: tabmail.registerTabType is not a function
Source File: chrome://messenger/content/chat/chat-messenger-overlay.js
Line: 1014
(Reporter)

Comment 1

4 years ago
Created attachment 8490284 [details] [diff] [review]
1068061.diff

fixes the startup errors for me
(Reporter)

Updated

4 years ago
Attachment #8490284 - Flags: review?(mkmelin+mozilla)

Comment 2

4 years ago
Comment on attachment 8490284 [details] [diff] [review]
1068061.diff

Review of attachment 8490284 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, my patch in bug 1068061 looks very similar ;)
Attachment #8490284 - Flags: review?(mkmelin+mozilla)

Comment 3

4 years ago
Meant bug 1067969
Severity: normal → blocker
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1067969
You need to log in before you can comment on or make changes to this bug.