crash: edit message filters

VERIFIED DUPLICATE of bug 106967

Status

MailNews Core
Filters
--
critical
VERIFIED DUPLICATE of bug 106967
16 years ago
9 years ago

People

(Reporter: Quinn Yost (mythdraug), Assigned: Navin Gupta)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
immediate crash after selecting edit -> message filters

Talkback IDs:  TB37202429Z   TB37202392Z

Build:  2001102503  (15:00 build)
2001102503 is the todays first build and this build is crashing near everywhere.

This should be a dupe of bug 106646.
Pleasre reopen if you see a crash with a newer build.


*** This bug has been marked as a duplicate of 106646 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
This is the later build...

Title bar indicates that the id is 2001102503, however
i downloaded it from the 2001-10-25-16-trunk dir.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
CC the nice Stephend to extract TB37202429Z,TB37202392Z (if he has time)

Incident ID 37202392
Stack Signature nsRDFResource::GetDelegate 6820693f
Bug ID
Trigger Time 2001-10-25 20:10:30
Email Address mythdraug@pobox.com
URL visited slashdot.org
User Comments view -> message filters
Build ID 2001102516
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
nsRDFResource::GetDelegate
[d:\builds\seamonkey\mozilla\rdf\util\src\nsRDFResource.cpp, line 206]
nsMsgFilterDataSource::GetTargets
[d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgFilterDataSource.cpp,
line 130]
CompositeAssertionEnumeratorImpl::GetEnumerator
[d:\builds\seamonkey\mozilla\rdf\base\src\nsCompositeDataSource.cpp, line 574]
CompositeEnumeratorImpl::HasMoreElements
[d:\builds\seamonkey\mozilla\rdf\base\src\nsCompositeDataSource.cpp, line 240]
nsRDFConMemberTestNode::FilterInstantiations
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsRDFConMemberTestNode.cpp,
line 390]
TestNode::Propogate
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsRuleNetwork.cpp, line 1045]
TestNode::Propogate
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsRuleNetwork.cpp, line 1060]
RootNode::Propogate
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsRuleNetwork.cpp, line 765]
nsXULContentBuilder::CreateContainerContents
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsXULContentBuilder.cpp,
line 1270]
nsXULContentBuilder::CreateTemplateAndContainerContents
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsXULContentBuilder.cpp,
line 1195]
nsXULContentBuilder::CreateContents
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsXULContentBuilder.cpp,
line 1764]
nsXULElement::EnsureContentsGenerated
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3589]
nsXULElement::ChildCount
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 2214]
nsXULElement::GetChildNodes
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 816]
nsBindingManager::GetContentListFor
[d:\builds\seamonkey\mozilla\content\xbl\src\nsBindingManager.cpp, line 1026]
nsXBLBinding::GenerateAnonymousContent
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLBinding.cpp, line 735]
nsXBLService::LoadBindings
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp, line 735]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6983]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6948]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11532]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5630]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7041]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6948]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11532]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5630]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7041]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6948]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11532]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5630]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7041]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6948]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11532]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5630]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7041]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6948]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 11532]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3357]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8440]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1214]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2654]
nsXULDocument::StartLayout
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 4342]
nsXULDocument::ResumeWalk
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5885]
nsXULDocument::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6100]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 139]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 614]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 177]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1297]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1610]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1628]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
marking new based on the stack trace
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, regression
Summary: crash: edit message filters → crash: edit message filters
*** Bug 106894 has been marked as a duplicate of this bug. ***
i mark this as a dupe of bug 106967 because there are already many devlopers CC
on that bug

*** This bug has been marked as a duplicate of 106967 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.