Music app functional issues - Shuffle/Repeat Song

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: bhargavg1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-, feature-b2g:2.2?)

Details

(Whiteboard: [caf priority: p2][CR 726448][2.2 backlog])

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1067841 +++

We are observing few issues in Music app. Wants to confirm whether these are issue or FFOS implementation design.
 
Issue#2: "Shuffle" and "repeat single song" both can be enabled at same time
Description: At a time either "Shuffle" or "repeat single song"  should be available.
(Reporter)

Updated

4 years ago
Depends on: 1068865
(Reporter)

Updated

4 years ago
Summary: Music app functional issues → Music app functional issues - Shuffle/Repeat Song
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
QA Wanted to see if we can reproduce this on Flame KK 2.1
Keywords: qawanted

Comment 3

4 years ago
Does this break anything? I know it seems a little confusing (shuffling is a no-op if you only have one song), but if it doesn't break anything, I don't think it should be a blocker, and I'm not even convinced we should fix it at all. I'll explain why.

I imagine that most people who like shuffle keep it on most of the time. However, I doubt most people have "repeat single song" on most of the time, since if you did that, why would you even have more than one song in your music collection? My guess is that people who like shuffle will want that to be on all the time, and they might occasionally want to turn on "repeat single song". Once they get tired of that song, they'll turn off "repeat single song" and would expect the music app to return to playing a shuffled list of songs. Therefore, the user should be able to turn on "repeat single song" even when "shuffle" is on, and doing so shouldn't turn off shuffle.

(Note that I say this as someone who never shuffles in the music app because I primarily listen to full albums.)
(Reporter)

Updated

4 years ago
Flags: needinfo?(poojas)
NI to the owner of Audio/Video to weigh in on if this is a bug or not - 

just some added info - we have a handful of personal devices here (Android smartphone, i-phone) that has this same behavior.
Flags: needinfo?(edchen)
Keywords: qawanted

Comment 5

4 years ago
Minus from blocking release. It is not a pleasant feature to have both enabled, something that we will incorporate with the music refresh initiative in 2.2.
blocking-b2g: 2.1? → -
Whiteboard: [2.2 backlog]

Comment 6

4 years ago
HI Jim,
Thanks for explaining its usecase :)
Its not breaking any thing. Just wanted to be sure whether is it intentional.
Flags: needinfo?(poojas)

Updated

4 years ago
Whiteboard: [2.2 backlog] → [CR 726448][2.2 backlog]

Updated

4 years ago
Whiteboard: [CR 726448][2.2 backlog] → [caf priority: p2][CR 726448][2.2 backlog]

Comment 7

4 years ago
As I known, base on comment 3 that I agree this. This is not a bug, because repeat is high priority then shuffle.
Flags: needinfo?(edchen)

Updated

4 years ago
feature-b2g: --- → 2.2?

Updated

4 years ago
Blocks: 1063044
No longer blocks: 1025317

Updated

4 years ago
Blocks: 1025317

Updated

4 years ago
No longer blocks: 1025317

Comment 8

4 years ago
This is intentional (to comment #6) and for repeat purposes (agree with comment #7). Suggest we mark this WONTFIX for these reasons.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Blocks: 1142220

Updated

3 years ago
No longer blocks: 1142220
You need to log in before you can comment on or make changes to this bug.