Closed Bug 10690 Opened 21 years ago Closed 21 years ago

Selecting multiple messages in Messenger is really slow

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3, blocker)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: scottputterman)

References

Details

(Whiteboard: [Perf][DOGFOOD][BLOCKER] Mailnews needs for dogfood)

Open up the Messenger 3 pane.
Open a 1000 message folder.
Select the 1st message and then shift-click the 10 message.
Watch it take a really long time to select all 10 messages.
Whiteboard: [Perf]
Status: NEW → ASSIGNED
My fault. I have a fix in my tree ready to go.
Status: ASSIGNED → NEW
Duh. Wrong bug. This _is_ yours hyatt :-)
Blocks: 11091
Whiteboard: [Perf] → [Perf][DOGFOOD] Mailnews needs for dogfood
This can wait until M10, but we really need this to be useable.  Selecting
multiple messages is painfully slow.
Moving to M10.
Blocks: 12176
No longer blocks: 11091
Severity: normal → blocker
Whiteboard: [Perf][DOGFOOD] Mailnews needs for dogfood → [Perf][DOGFOOD][BLOCKER] Mailnews needs for dogfood
Severity -> blocker for mail/news M10
Assignee: hyatt → putterman
Status: ASSIGNED → NEW
I have implemented new selection APIs for the tree widget that will dramatically
increase the selection speed.  Passing this bug back to putterman, so that he
can change the JS and stuff in the mailnews files to use the new API.

Scott, see my recent newsgroup post to XPFE regarding the selection API.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I checked in the changes for this.  As of this comment, you can't use
shift-select, but there's another bug on that.
<Will verify this after M9 is out the door>
Depends on: 15094
Because Shift+select is disabled and a new bug has been logged for that, I will
mark this one dependent on the 15094 being fixed.
No longer blocks: 12176
QA Contact: lchiang → suresh
suresh - can you time this and verify?
marking this as verified. using today's build on windows it takes < 2 seconds to 
select 10 msgs. 
Status: RESOLVED → VERIFIED
*** Bug 100327 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.