Closed Bug 106998 Opened 19 years ago Closed 16 years ago

msn.com - detects NS7 but not Mozilla - Differing table layouts on msn.com

Categories

(Tech Evangelism Graveyard :: English US, defect, P3)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: exotrip, Unassigned)

References

()

Details

(Keywords: top100, Whiteboard: [XBROWER-CSS])

Attachments

(3 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Win32; en-US; 0.9.5) Netscape6/6.5
BuildID:    2001101603

 Ok, I am uploading a copy of msn.com, without the XHTML doctype and namspace,
so Mozilla will not try to render Microsoft's **** code strictly. 
 There is a difference in how MSIE and Mozilla render the page still. In the
page there is an MSNBC section, CNBC section, Shopping section, and Specials
section. In MSIE, the sections are rendered side-by-side

1 2
3 4

In Mozilla, they are rendered on top of each other

1
2
3
4

The question is: Which browser is rendering it right? Is this a Mozilla bug or
an MSIE bug?


Reproducible: Always
Steps to Reproduce:
1. Load file
2. Read it
3. Laugh

Actual Results:  n/a

Expected Results:  n/a
*** Bug 107105 has been marked as a duplicate of this bug. ***
Summary: Differing table layouts → Differing table layouts on msn.com
Opera renders it similar to Mozilla --
MS pumps out a different version depending on which browser you use.

This is most likely not a bug.
They are using CSS class ids comprised of digits only, for example class="800",
which is invalid. Reassigning to Evangelism.
Assignee: attinasi → bclary
Component: Layout → English: US
Keywords: testcase
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified
Keywords: testcase
Priority: -- → P1
Summary: Differing table layouts on msn.com → msn.com - Differing table layouts on msn.com
Whiteboard: [XBROWER-CSS]
Keywords: top100
Blocks: MS
Whiteboard: [XBROWER-CSS] → [XBROWER-CSS][aok]
Keywords: evang500
Whiteboard: [XBROWER-CSS][aok] → [XBROWER-CSS]
pretty minor issue methinks. -> p3
Priority: P1 → P3
only problem left I can see is the topright corner
MSN (http://www.msn.com/) has drastically changed its layout since this
bug was filed.  The new layout looks nearly identical in Mozilla 1.1 and
IE 5.5.

However, when IE is resized smaller than 800x600, it redoes much of the
layout to accommodate the smaller window.  Mozilla fails to do so.

(I'm rummaging through the Microsoft.com tracker bug 114158 due to
recent changes in the behavior of 141279 and bug 145177.  To filter
messages related to this activity, search for "tepplesmsn200209".)
Some minor css diffrences on :hover, can't find anything else. wfm?
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: zach → english-us
Update on this bug since Comment #9 & Comment #10 which were in 2002:

I noticed this rendering bug with the latest nightly builds of Firebird
(Gecko/20030714). It still does not render Top Headlines, Money, Shopping &
Entertainment sections side-by-side. It also does not highlight and underline links.
 
Interestingly, Netscape 7.1 (Gecko/20030624), based on Mozilla 1.4, does render
all the page correctly indicating Comment #3 might be right.

We should really try getting this fixed as MSN is such a frequently used site.
OS -> ALL
OS: Windows 2000 → All
http://www.msn.com/contactus.ashx

This is a server side detection issue. Changing the UA to NS7.1 fixes the
layout. I contacted them at the form above.
Status: NEW → ASSIGNED
Target Milestone: --- → Aug
no action at all.
Status: ASSIGNED → NEW
Summary: msn.com - Differing table layouts on msn.com → msn.com - detects NS7 but not Mozilla - Differing table layouts on msn.com
Target Milestone: Aug → ---
Mozilla 1.7 with a Mozilla 1.7 ua looks the same as Mozilla 1.7 with a NS7.1 ua.
-> Fixed.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.