Add mp4 support in 10.6 and 10.7 on Aurora

RESOLVED FIXED in Firefox 34

Status

()

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

34 Branch
mozilla35
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 unaffected, firefox33 unaffected, firefox34+ fixed, firefox35 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

5 years ago
If we enable VideoToolbox in 10.6 or 10.7, no video appears.

VideoToolbox by default output BGRA32 type buffer.
(Assignee)

Comment 1

5 years ago
Set output format
Attachment #8492734 - Flags: review?(giles)
(Assignee)

Comment 2

5 years ago
This patch is only required if we don't want to backport all the changes related to using IOSurface (bug 1059066 and bug 1064847).

If we are going to, this can be closed as WON'T FIX
(Assignee)

Comment 3

5 years ago
Note that "FullRangeVideo", a.k.a PC Levels format isn't supported in 10.6 and 10.7, only in 10.8 and later.
Hence why I set the format to kCVPixelFormatType_420YpCbCr8BiPlanarVideoRange rather than kCVPixelFormatType_420YpCbCr8BiPlanarFullRange
Comment on attachment 8492734 [details] [diff] [review]
Set output format for VideoToolbox decoder

Review of attachment 8492734 [details] [diff] [review]:
-----------------------------------------------------------------

I'm confused. Does comment 2 mean this patch is intended for Aurora only? If so please state that explicitly. By default patches are assumed to apply to m-c.

Please state _why_ a change in being made in the commit message body.
Attachment #8492734 - Flags: review?(giles) → review-
The patch is intended for Aurora only and it is simply the last part of https://bug1059066.bugzilla.mozilla.org/attachment.cgi?id=8485498

The intention is to backport as little as possible to get 10.6 and 10.7 working with software decoders in 34.
(Assignee)

Updated

5 years ago
Summary: Apple VideoToolbox decoder showing no images in 10.6 or 10.7 → Add mp4 support in 10.6 and 10.7
(Assignee)

Updated

5 years ago
Attachment #8492734 - Attachment is obsolete: true
(Assignee)

Comment 6

5 years ago
Patch for aurora
Attachment #8494193 - Flags: review?(giles)
(Assignee)

Comment 7

5 years ago
Update mochi test from bug 1067697
Attachment #8494269 - Flags: review?(giles)
(Assignee)

Updated

5 years ago
Attachment #8494193 - Attachment is obsolete: true
Attachment #8494193 - Flags: review?(giles)
Comment on attachment 8494269 [details] [diff] [review]
1070703_Enable_mp4_in_106_107.patch

Review of attachment 8494269 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the roll-up patch.
Attachment #8494269 - Flags: review?(giles) → review+
Summary: Add mp4 support in 10.6 and 10.7 → Add mp4 support in 10.6 and 10.7 on Aurora
Comment on attachment 8494269 [details] [diff] [review]
1070703_Enable_mp4_in_106_107.patch

Approval Request Comment
[Feature/regressing bug #]: 941296

[User impact if declined]: 

HTML <video> playback of mp4 files won't be available to users on MacOS X 10.6 and 10.7, complicating deployment for web developers.

[Describe test coverage new/current, TBPL]:

This is a backport of similar code in m-c. Support on 10.6 is tested by mochitests on tbpl.

[Risks and why]: 

We believe risk is low. This is a new feature in 34, so there's no possibility of regression. The code changes to enable this on older versions of MacOS are straightforward: explicitly requesting what is the default output format on 10.8+, and checking additional paths when loading platform frameworks.

[String/UUID change made/needed]: None
Attachment #8494269 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 10

5 years ago
It requires the bump stack size patch to prevent occasional crashes in 10.6
Depends on: 1062596
status-firefox32: --- → unaffected
status-firefox33: --- → unaffected
status-firefox34: --- → affected
status-firefox35: --- → fixed
tracking-firefox34: --- → +
Comment on attachment 8494269 [details] [diff] [review]
1070703_Enable_mp4_in_106_107.patch

I like my Web platform consistent. Thank you for the simplified patch for uplift. Aurora+
Attachment #8494269 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox34: affected → fixed
Target Milestone: --- → mozilla35
(Assignee)

Comment 14

4 years ago
shouldn't this bug be closed as 34 has the code in ...
Flags: needinfo?(ryanvm)
I think so too. I suspect it wasn't closed because the sheriff scripts close bugs based on m-c merge, and that isn't part of this bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Flags: needinfo?(ryanvm)

Updated

4 years ago
Blocks: 1037731
You need to log in before you can comment on or make changes to this bug.