Closed Bug 1070753 Opened 6 years ago Closed 5 years ago

Standalone Client's title is still "Loop"

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox35 fixed)

RESOLVED FIXED
mozilla35
Iteration:
35.3
Tracking Status
firefox35 --- fixed

People

(Reporter: standard8, Assigned: jaws)

References

Details

User Story

The title of the standalone link-clicker UI is still just "Loop".  Should change to "Firefox Hello - <status>

Attachments

(1 file)

The title of the standalone link-clicker UI is still just "Loop".

We should either change it to "Firefox WebRTC" (or product name), or do we want some combination of, for example "In call - Firefox WebRTC", with the "In call" part updating appropriately.

Darrin, any thoughts here?
Flags: needinfo?(dhenein)
I would reverse the order, so it reads "<product name> - <status>"... as for what product name we are using when/where, i defer to Arcadio.
Flags: needinfo?(dhenein) → needinfo?(alainez)
Blocks: 1076709
Arcadio - just checking that on Link clicker we want to say "Firefox Hello - <status>" versus <Hello - <status>".... so that folks receiving the link and clicking on it see our brand and product name??

Your call - just adapt user story if just product name is better.
User Story: (updated)
No longer blocks: 1076709
Blocks: 1077093
Duplicate of this bug: 1077096
Adding NI to Arcadio for confirmation.
Just talked to Arcadio who confirmed we can use the "Firefox Hello" name.
This bug is then to replace "Loop" by "Firefox Hello - <status>".
Clearing NI request per comment 5.
Flags: needinfo?(alainez)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 1
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
What are we going to put for the <status>? I assume it is things like {"Start Conversation", "In Conversation", "Conversation Ended"}, but we don't have all of those strings yet.

The closest we have is "Start conversation?", (missing), and "Your conversation has ended."

Can we go with just putting the product name and no <status> for now? So just "Firefox Hello"?
Flags: needinfo?(rtestard)
Attached patch PatchSplinter Review
This patch changes the title of the page to Firefox Hello but leaves off the <status> based on my above comment. I'd rather that we land this now and then we can determine if a follow-up is necessary to add the <status> bits.

I removed the title from about:looppanel since no reasonable person will be loading about:looppanel directly.
Attachment #8502765 - Flags: review?(dmose)
r+ conditional on making the change in the .jsx and then regenerating the js file from that.  A unit test here is probably not worth the effort at this moment.
Flags: needinfo?(rtestard)
Attachment #8502765 - Flags: review?(dmose) → review+
Flags: needinfo?(rtestard)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #7)
> What are we going to put for the <status>? I assume it is things like
> {"Start Conversation", "In Conversation", "Conversation Ended"}, but we
> don't have all of those strings yet.
> 
> The closest we have is "Start conversation?", (missing), and "Your
> conversation has ended."
> 
> Can we go with just putting the product name and no <status> for now? So
> just "Firefox Hello"?

Yes agreed. I'll create a separate bug for the status once we have the link clicker UI finalized with all call states (we don't have call failed currently)
Flags: needinfo?(rtestard)
Blocks: 1081029
Bug 1081029 now created to track call status implementation in the title.
No longer blocks: 1081029
https://hg.mozilla.org/mozilla-central/rev/39efd3ba7468
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla35
Flags: in-qa-testsuite-
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.