Closed Bug 1071069 Opened 5 years ago Closed 5 years ago

Thunderbird PFS removal - TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::test_unknown_plugin_notification_inline | test-plugin-unknown.js::test_unknown_plugin_notification_bar

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 35.0

People

(Reporter: philip.chee, Assigned: mkmelin)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(2 files, 1 obsolete file)

Using profile dir: /builds/slave/test/build/mozmill/mozmillprofile
TEST-START | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | setupModule
TEST-PASS | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::setupModule
TEST-START | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test_unknown_plugin_notification_inline
Step Pass: {"function": "controller.click()"}
JavaScript error: chrome://messenger/content/plugins.js, line 261: TypeError: installStatus is null
Test Failure: Timed out waiting for plugin status div to appear
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::test_unknown_plugin_notification_inline
TEST-START | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test_unknown_plugin_notification_bar
Step Pass: {"function": "controller.click()"}
JavaScript error: chrome://messenger/content/plugins.js, line 261: TypeError: installStatus is null
Test Failure: Timeout waiting for the content tab to open
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::test_unknown_plugin_notification_bar
From bug 899347 - https://hg.mozilla.org/mozilla-central/rev/c07c6f96d613

installStatus is null - http://mxr.mozilla.org/comm-central/source/mail/base/content/plugins.js#261
Component: Testing Infrastructure → Mail Window Front End
Keywords: regression
Hrm - that patch should only affect things under browser/... I don't see how it could have affected mailnews code.
Indeed. I should have looked more closely :/
Blocks: 836415
No longer depends on: 836415
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Summary: TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::test_unknown_plugin_notification_inline | test-plugin-unknown.js::test_unknown_plugin_notification_bar → Thunderbird PFS removal - TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/content-tabs/test-plugin-unknown.js | test-plugin-unknown.js::test_unknown_plugin_notification_inline | test-plugin-unknown.js::test_unknown_plugin_notification_bar
Since PFS was removed, we should just remove this code and test, as it does nothing useful anymore.
Attachment #8500110 - Flags: review?(standard8)
Attachment #8500110 - Flags: review?(standard8) → review+
I pushed this to help green up and clarify tree status:

https://hg.mozilla.org/comm-central/rev/ef1a562c5d12
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 35.0
Attached patch comment fixes followup, v1 (obsolete) — Splinter Review
Two followups to the comment changes.
Attachment #8500158 - Flags: review?(mkmelin+mozilla)
Attachment #8500158 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
Whiteboard: [push comment fixes followup v2 to comm-central]
https://hg.mozilla.org/comm-central/rev/c49e5cc3a391
Keywords: checkin-needed
Whiteboard: [push comment fixes followup v2 to comm-central]
You need to log in before you can comment on or make changes to this bug.