[Perf][Usage app][Cost Contorl] Performance regression for Cost Control App

RESOLVED DUPLICATE of bug 1072621

Status

Firefox OS
Gaia::Cost Control
RESOLVED DUPLICATE of bug 1072621
4 years ago
4 years ago

People

(Reporter: shinglyu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8495000 [details]
Datazilla Report

#Summary: Performance regression found in the Cost Control App since Sep 20. 

Datazilla Report: http://mzl.la/1DwXSU3

# Environment
  * Firefox OS 2.1
  * Flame 319mb

See also the "Depends on" bugs for possible cause of this issue.
(Reporter)

Comment 1

4 years ago
More details:

# Steps
  * See Datazilla: http://mzl.la/1DwXSU3
  
  * Last good build:
    Gaia Revision: 689c4ad4d8c3e4aa
    Gecko Revision: 2c6e3261c47b
  
  * First bad build:
    Gaia Revision: 05f7d41f53339f9b
    Gecko Revision: 2c6e3261c47b

# Expected
  Startup time remains steady.

# Actual
  Startup time jumps from 2530ms to 2776ms.

# Reproduction Frequency
(Reporter)

Comment 2

4 years ago
My initial guess is that this is related to Bug 1068454.  After the Cost Control App opens, the UI loads in the following order: 

Bottom half: No data used message -> "Mobile usage" and "Wi-Fi usage" text -> figure in the upper half -> No data used message is replaced with a list of per-app usage.

I guess the b2gperf tools wait until the per-app usage list, but if no mobile data were used, the UI is considered loaded when the no data used message is present. 

But I dont' know why this happens a few days after the Gaia reversion 728132e3 landed. I looked into 689c4ad4 and 05f7d41f but found no clue.
Would this bug be a duplicate of bug 1072621?
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072621
You need to log in before you can comment on or make changes to this bug.