Closed Bug 1072992 Opened 5 years ago Closed 5 years ago

[10.10] Buttons on Software Update window use white text on light background

Categories

(Toolkit :: Themes, defect)

x86
macOS
defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
mozilla35
Iteration:
35.3
Tracking Status
firefox34 --- verified
firefox35 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Splitting from bug 1068702.
Screenshots:

attachment 8492756 [details]
attachment 8492756 [details]
See Also: → 1068702
Points: --- → 2
Flags: qe-verify+
Flags: in-testsuite-
Flags: in-qa-testsuite-
Flags: firefox-backlog+
Keywords: regression
(In reply to :Gijs Kruitbosch from comment #1)
> Screenshots:
> 
> attachment 8492756 [details]
> attachment 8492756 [details]

attachment 8494787 [details] is the second one
Screenshots should be for focused (white text) and un-focused (black text) window.
BTW, I'm talking about default theme, no other themes were installed.
Simple test: 

Services.ww.openWindow(null, "chrome://mozapps/content/update/updates.xul", "", "chrome,centerscreen,dialog=no,resizable=no,titlebar,toolbar=no", null)

(stolen from http://mxr.mozilla.org/mozilla-central/source/browser/base/content/aboutDialog.js#301 )

The issue is caused by the -moz-appearance: toolbarbutton (which means the default button no longer gets its blue highlight), so hardcoding it seems like the best idea here...
Attachment #8497509 - Flags: review?(jaws)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Ideally, I think we'll want to uplift both this and bug 1044595 (and its other dep) to 34, so that we don't look like ... when Yosemite is released...

Taking this for 35.3 as well.
Iteration: --- → 35.3
Flags: needinfo?(mmucci)
Assigned for IT 35.3
Flags: needinfo?(mmucci)
I was worried about the add-on update dialog having the same issue, but it seems that should be OK:

http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/content/update.xul only loads update.css (note lack of 's') which is here: http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/osx/mozapps/extensions/update.css and doesn't do anything controversial, AFAICT.
Comment on attachment 8497509 [details] [diff] [review]
fix update button text color on OS X Yosemite,

It seems to me that instead of #000 you should use -moz-DialogText in conjunction with -moz-appearance: toolbarbutton (just like toolbarbutton.css).

I also wonder why -moz-appearance: toolbarbutton is used at all here...
Attachment #8497509 - Flags: review?(jaws) → review-
(In reply to Dão Gottwald [:dao] from comment #8)
> I also wonder why -moz-appearance: toolbarbutton is used at all here...

Ditto, but because I'm aiming for uplift and I don't really want to restyle the entire thing in this bug, I'd rather just fix the text color. I'm happy to file a followup bug, assuming that sounds good to you.
(In reply to :Gijs Kruitbosch from comment #9)
> (In reply to Dão Gottwald [:dao] from comment #8)
> > I also wonder why -moz-appearance: toolbarbutton is used at all here...
> 
> Ditto, but because I'm aiming for uplift and I don't really want to restyle
> the entire thing in this bug, I'd rather just fix the text color. I'm happy
> to file a followup bug, assuming that sounds good to you.

yes
As noted on IRC, OS X doesn't seem to use -moz-dialogtext for toolbarbutton...
Attachment #8497580 - Flags: review?(dao)
Attachment #8497509 - Attachment is obsolete: true
... so maybe this makes more sense?
Attachment #8497582 - Flags: review?(dao)
Depends on: 1074946
Comment on attachment 8497582 [details] [diff] [review]
fix update button text color on OS X Yosemite to use ButtonText,

Should be good enough for now, but we should get rid of this one-off customized button styling.
Attachment #8497582 - Flags: review?(dao) → review+
Attachment #8497580 - Flags: review?(dao)
https://hg.mozilla.org/mozilla-central/rev/407a8fb5579d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
QA Contact: catalin.varga
The fix for this was included in the roll-up patch landed in bug 1044595.
Verified as fixed using the following environment:

FF 35
Build Id: 20141002030202
OS: Mac Os X 10.10
Verified as fixed using:

FF34
Build Id: 20141009004002
OS: Mac Os X 10.10
Status: RESOLVED → VERIFIED
Please disregard the last 2 comments it was meant for a different bug.
Status: VERIFIED → RESOLVED
Closed: 5 years ago5 years ago
Verified as fixed using:

FF 34
Build Id: 20141012004001
OS: Mac Os X 10.10
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.