Closed Bug 10731 Opened 21 years ago Closed 20 years ago

DNS: [Arch]sched - async dns mac (gordon, 2d)

Categories

(Core :: Networking, defect, P1)

PowerPC
Mac System 8.6
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: chofmann, Assigned: gordon)

References

Details

Blocks: 10730
Summary: sched - async dns mac (gordon, 2d) → sched - async dns mac (gordon, 2d)
Target Milestone: M10
Status: NEW → ASSIGNED
Blocks: 12836
*** Bug 2132 has been marked as a duplicate of this bug. ***
OS: Windows 95 → Mac System 8.6
Priority: P3 → P1
Hardware: PC → Macintosh
Target Milestone: M10 → M11
m11
Blocks: 16950
*** Bug 15762 has been marked as a duplicate of this bug. ***
Summary: sched - async dns mac (gordon, 2d) → [Arch]sched - async dns mac (gordon, 2d)
Added Arch keyword to title so that pointy head folks like me can see that this
is fundamental architectural work that we want landed asap.  I know it already
had that high priority... but this just makes it obvious from the summary. :-)
Blocks: 17432
I have this working in my tree, and Warren and Patrick have code reviewed the

changes.  I'm trying to set up a meeting this afternoon with the NSPR to resolve

outstanding issues they have with the mechanism I needed to add for

synchronization between Mac interrupts and NSPR threads.
Blocks: 17907
Target Milestone: M11 → M12
While DNS lookups are now async on the Mac, I'm still working on making requests
cancelable.  This work won't be completed until m12.
Blocks: 18471
if there is work avaiable to checkin for m12 let me know, else m13.
Target Milestone: M12 → M13
Blocks: 21564
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Blocks: 22176
Target Milestone: M13 → M15
Async dns is checked in, but I'm still waiting to finish dns caching and
canceling of requests. I'm moving this to M15, because I'll be working on the
memory and disk cache for beta.
Blocks: 24206
I'd say async dns is implemented for mac and windows at this point (note: unix 
isn't done yet). I'll open a separate bug for dns caching and request 
cancelation.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
marking verified
Status: RESOLVED → VERIFIED
QA Contact: paulmac → tever
No longer blocks: 17432
No longer blocks: 17907
No longer blocks: 18471
No longer blocks: 21564
No longer blocks: 22176
No longer blocks: 24206
Summary: [Arch]sched - async dns mac (gordon, 2d) → DNS: [Arch]sched - async dns mac (gordon, 2d)
You need to log in before you can comment on or make changes to this bug.