Closed Bug 1074542 Opened 6 years ago Closed 5 years ago

Music sort order should be Arabic and not English.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1209135

People

(Reporter: swilkes, Assigned: nefzaoui)

References

Details

(Whiteboard: [2.1-Arabic-RTL-bug-bash])

Attachments

(1 file)

The Music sort order is not based on Arabic, but is the English sort order. The UX spec and UX patterns should inform or reflect decisions we make here. 

The ICU (International Component for Unicode) has functionality that devs will be able to leverage here.
Blocks: 1090488
Do we have a spec of what is expected for this?

It is way beyond RTL/BiDi and reach into the whole internationalization problems.

Thank you kindly.
Flags: needinfo?(swilkes)
Given last week's announcements, we'll not worry about this right now. We did get some helpful suggestions from the Arabic community while in PDX, however, that I'll add to the bidi pattern later.
Flags: needinfo?(swilkes)
ux-b2g: 2.2 → ---
Taking as I'm currently working on this + I have an idea about what needs to be accomplished here following a PDX meeting with Stephany.
Assignee: nobody → nefzaoui
RTL triage: P3 -- this bug is not prioritized for inclusion in the 2.2 release.
Priority: -- → P3
Flags: in-moztrap+
Whiteboard: [2.1-Arabic-RTL-bug-bash] → [2.1-Arabic-RTL-bug-bash], MGSEI-RTL-3F
QA Whiteboard: MGSEI-RTL-3F
Whiteboard: [2.1-Arabic-RTL-bug-bash], MGSEI-RTL-3F → [2.1-Arabic-RTL-bug-bash]
This issue cannot be reproduced on FlameKK2.2, FlameKK2.5, AriesKK2.5, please see attachment AriesKK_V2.5.png.
Rate:0/5
Device: AriesKK 2.5
Build ID               20150818005621
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6ae3e9ff53b2bae8d95a90c9f25368fd81fa357e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.003312
Firmware Date          Tue Aug 18 00:33:21 UTC 2015
Bootloader             s1

Device:FlameKK v2.2 build
Build ID               20150818032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c29970d16372
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.065127
Firmware Date          Tue Aug 18 06:51:38 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:FlameKK v2.5 build
Build ID               20150818150207
Gaia Revision          507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gaia Date              2015-08-18 10:50:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c272af993c23e803f6ea7798a812b0c8abfad4d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Marking dupe to the bug where I'm fixing this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209135
You need to log in before you can comment on or make changes to this bug.