Closed Bug 1074580 Opened 7 years ago Closed 7 years ago

[SHB] SHB does not hide when calling mozRequestFullscreen in fullscreen_layout app

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: mikehenrty, Assigned: mikehenrty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

[Blocking Requested - why for this release]:

Blocks a blocker, bug 1073611.
blocking-b2g: --- → 2.1?
Broken feature.
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → mhenretty
Note to reviewer, when the SHB does display in fullscreen_layout mode the background will be transparent. This is bug 1074569, and will be fixed there.
Comment on attachment 8497248 [details] [review]
[Gaia PR] Hide fullscreen SHB in layout mode

see bug 1074569
Attachment #8497248 - Flags: review?(etienne) → review+
master: https://github.com/mozilla-b2g/gaia/commit/3c1722ac04fe7418205e5b0e7a5cdcda3a3a809e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8497248 [details] [review]
[Gaia PR] Hide fullscreen SHB in layout mode

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
bug 1064595

[User impact] if declined:
Unable to meet Video/Gallery app requirements for Tako.

[Testing completed]:
On device testing only. We currently don't have the ability to write an integration test for this until we have an app which uses the fullscreen_layout feature (bug 1055198).

[Risk to taking this patch] (and alternatives if risky):
CSS-only change, low risk.

[String changes made]: none.
Attachment #8497248 - Flags: approval-gaia-v2.1?
Attachment #8497248 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.