Closed Bug 1074669 Opened 7 years ago Closed 7 years ago

The cursor will skip to front of attachment when you want to type some characters in text field.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.0M affected)

RESOLVED DUPLICATE of bug 1052424
Tracking Status
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.0M --- affected

People

(Reporter: jocheng, Unassigned)

References

Details

Attachments

(1 obsolete file)

The cursor will skip to front of attachment when you want to type some characters in text field.(5/5)

[Initial condition]
1. SIM information:
   SIMA:CMCC 3G
   SIMB:CU 2G
2. Default SIM settings:SIMA.
3. Data connection:OFF.
4. Issue happen time: 2014-9-18 10:10AM

[step]
1. Receive a MMS that has a video or picture attached.
2. Long tap the MMS and select "Forward".
3. Type in the text field to add a message to the body.

[Expected Result]
The cursor should stay behind the attachment or the cursor should at the front of attachment after select "Forward".

[Error]
The cursor will skip to front of attachment.
Duplicate of this bug: 1069136
The behavior is also the same on 1.4, so I doubt if this is per design. 
Ni? Jenny to gain some UX input.
Flags: needinfo?(jelee)
Please note that this issue should be fixed after patch in bug 1052424 applied.
See Also: → 1052424
Just dupe if the issue is fixed with bug 1052424 patch.
Hello, note that when forwarding message, cursor should first focus on recipient field. When tap on composer, cursor should appear at the end of composer and at the start of a new line (attachment would be above the cursor), thanks!
Flags: needinfo?(jelee)
Attached patch WIP (obsolete) — Splinter Review
Initial createRoom and AddCallback implimentation.
Assignee: nobody → pkerr
Status: NEW → ASSIGNED
Comment on attachment 8505883 [details] [diff] [review]
WIP

wrong bug number.
Attachment #8505883 - Attachment is obsolete: true
Assignee: pkerr → nobody
Status: ASSIGNED → NEW
Hey Josh,

can you check latest master and tell us if the behavior is correct now?
Flags: needinfo?(jocheng)
Dear Peipei,
qawanted for verifying this bug is fixed in master 2.2. Thanks!
Flags: needinfo?(jocheng) → needinfo?(pcheng)
Blocks: Woodduck
Keywords: qawanted
I confirmed on latest 2.2 build. 
When forwarding a sms/mms, the cursor will be placed in the recipient field by default. When tap on composer, cursor in sms will be placed after the current message, cursor in MMS will be placed after the attachment.

Test build
-------------------------------------------------------------------------------
Gaia-Rev        abef62c0623e5504a97b4fd411e879a67b285b52
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/cc7fc5918561
Build-ID        20141016160202
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Flags: needinfo?(pcheng)
Josh, if this is matching your expectations, can you please dupe this bug to bug 1052424 ?
Flags: needinfo?(jocheng)
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jocheng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1052424
(In reply to Julien Wajsberg [:julienw] from comment #12)
> Josh, if this is matching your expectations, can you please dupe this bug to
> bug 1052424 ?

HI Julien, Done! Thanks!
Depends on: 1102789
No longer depends on: 1102789
You need to log in before you can comment on or make changes to this bug.