If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Contacts]MS freeze when import contacts from memory card to phone.

VERIFIED FIXED in Firefox OS v2.0M

Status

Firefox OS
Gaia::Contacts
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: GaryChen, Assigned: lchang)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(8 attachments)

+++ This bug was initially created as a clone of Bug #1102087 +++

ALPS01830974
DEFECT DESCRIPTION:
 MS freeze.(It is invalid when press "Cancel".)
 
  REPRODUCING PROCEDURES:
 >MS have some Vcard(Vcard is very big that contain 3500 contacts).
 
 1.Enter Contacts->Click "Setting" icon->Import contacts->Memory card
 2.After imported about 1500 contacts, the system freeze without prompting anything.And the cancle button has no use when click it.
 3.Import the same vcard in an Android phone,it can be importd successfully.
  
 EXPECTED BEHAVIOUR:
 Shouldn't freeze and the Vcard should be imported normally.
 
This is a generic issue need contacts functional members' help for finding out solution.
Duplicate of this bug: 1102087
Asking for QA wanted to check this problem.
Keywords: qawanted
Hi GaryChen,
   Could you please provide the following information to help QA track down this issue?

1. What device was used?
2. What build was used?
3. Did the bug happen more than once?

Thank you,
QA
Flags: needinfo?(gchen)
With the information I have from comment 0, I tested with the Flame device with the following results.

Tested with Shallow Flash on 319mb using Engineering builds.

This bug does NOT repro on Flame kk build: Flame 2.2 KK, Flame 2.1 KK, Flame 2.0 KK

Actual Result: 2268 Contacts are importing from memory card correctly and there is no system freeze.

Repro Rate: 0/6

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141124051443
Gaia: 3b4c64b5a05d106568dae3f88d38bdbb3d5bc29e
Gecko: b8240bb9ae4f
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141123213611
Gaia: f93f2b92c7410815b785f6d8b286593d703a65d9
Gecko: 1de2c2a21068
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141124070841
Gaia: 2e3f4de97dfd776dc545ebd167eceb419ac2007b
Gecko: 3e842983c83c
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Leaving the QAWanted tag until we find out more information about the affected environment.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Removing the NI? for Gary as the original bug has the info needed.

However I'm going to leave QAWanted tag for other testers as I cannot reproduce this issue.
Flags: needinfo?(gchen)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
I did some more digging and I checked the same Flame 2.0 build Norry checked on the cloned bug, using the 188 base with the 2.0 build and then checked the 188-1 base with the 2.0 build and still could not reproduce. So I don't really know what the difference is here.

Environmental Variables:
Device: Flame 2.0
BuildID: 20141119000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
Unable to repro on Flame 2.2, 2.1 and 2.0 engineering builds with shallow flash and 319 MB mem.
Actual result: When attempting to import over 2000 contacts from the SD card, the user sees the "Reading from memory card..." message before the app has a memory error and closes.

Leavig QAWanted tag for someone else to attempt.

Flame 2.2
BuildID: 20141125035634
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141124205132
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0
BuildID: 20141125070131
Gaia: 99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko: 109bf3dc61cf
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Actually it seems that Chris's results mirror Norry's results from the cloned bug. She Verified the results on the flame as not successfully importing and finally crashing to home screen. Chris's results are the exact same.

In fact I also went back and tried to test this again with a Flame set to 319mb and 512mb and both times got the freeze for about 5-10 seconds and then the app closes out to the homescreen. I'm not sure why I was able to get it to work yesterday but I can say that I constantly get the bug now.

So I'll ask Chris to get a log to attach to the bug to help this bug along.

Keeping QAWanted to get the log for the issue.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Created attachment 8528695 [details]
Log of contact import attempt

Comment 10

3 years ago
This issue can be fixed this week?

Comment 11

3 years ago
dear mozilla:
   Has this bug fixed ? Adn when we can get the patch or release?
   Our deadline is 2014-12-03,so it is very emergency。

Updated

3 years ago
blocking-b2g: --- → 2.0M?

Updated

3 years ago
Blocks: 1080481

Updated

3 years ago
Flags: needinfo?(gchen)
Log has been uploaded in comment 9.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
status-b2g-v2.0: affected → ---
status-b2g-v2.0: --- → affected
Flags: needinfo?(gchen)
(Assignee)

Comment 13

3 years ago
Created attachment 8529497 [details]
vcard v2.1 contains DQUOTE character

This bug is not about the amount of vCards. It's caused by DQUOTE (") character in the vCard format. The attachment is a simple vCard file which can be used to reproduce this bug more easily.

In bug 888153, we addressed an issue about parsing DQUOTE in vCard 4.0 format [1]. According to vCard spec, however, the DQUOTE character should be accepted as a normal character by vCard format v3.0 and its earlier version.

I'm working out a patch for this so take it first.

[1] https://github.com/mozilla-b2g/gaia/blob/v2.0m/shared/js/contacts/import/utilities/vcard_parser.js#L767-L771
Assignee: nobody → lchang
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
See Also: → bug 888153
(Assignee)

Comment 14

3 years ago
Created attachment 8529532 [details] [review]
Pull request to v2.0m

This is a WIP patch. Could you please apply it and see if it works or not? Thanks.
Flags: needinfo?(xingming.yin.hz)
(Assignee)

Comment 15

3 years ago
Created attachment 8529550 [details] [review]
Pull request to master
Please ask :sergi for review on vcard patches.

Thanks!

Updated

3 years ago
Flags: needinfo?(lchang)

Updated

3 years ago
blocking-b2g: 2.0M? → 2.0M+
status-b2g-v2.0M: --- → affected
(Assignee)

Comment 17

3 years ago
Comment on attachment 8529550 [details] [review]
Pull request to master

Hi Sergi,

Per comment 16, could you please help to review it? Thanks a lot.
Flags: needinfo?(lchang)
Attachment #8529550 - Flags: review?(sergi.mansilla)

Comment 18

3 years ago
Created attachment 8530691 [details]
00028.rar

I has tested the lastest code of 
https://github.com/mozilla-b2g/gaia/blob/v2.0m/shared/js/contacts/import/utilities/vcard_parser.js#L767-L771 using this vcard,but it still freeze when importing
Flags: needinfo?(xingming.yin.hz)
(Assignee)

Comment 19

3 years ago
Hi Xingming,

Did you apply the patch in comment 14 [1]? Could you confirm should the code look like this [2]?


[1] https://github.com/luke-chang/gaia/commit/e02cd61ad9ca1c6c4e195feba659bfc8dcf237d4.patch
[2] https://github.com/luke-chang/gaia/blob/e02cd61ad9ca1c6c4e195feba659bfc8dcf237d4/shared/js/contacts/import/utilities/vcard_parser.js#L768-L772
Flags: needinfo?(xingming.yin.hz)

Comment 20

3 years ago
(In reply to Luke Chang [:lchang] from comment #19)
> Hi Xingming,
> 
> Did you apply the patch in comment 14 [1]? Could you confirm should the code
> look like this [2]?
> 
> 
> [1]
> https://github.com/luke-chang/gaia/commit/
> e02cd61ad9ca1c6c4e195feba659bfc8dcf237d4.patch
> [2]
> https://github.com/luke-chang/gaia/blob/
> e02cd61ad9ca1c6c4e195feba659bfc8dcf237d4/shared/js/contacts/import/utilities/
> vcard_parser.js#L768-L772

I think it is ok now.
Flags: needinfo?(xingming.yin.hz)

Comment 21

3 years ago
Hi Kai-Zhen,
Could you help to land the patch per https://bugzilla.mozilla.org/show_bug.cgi?id=1102789#c14?
Thanks!
Flags: needinfo?(kli)
OK. I'll merge into v2.0m when the patch is r+.
I'll have a review ready for this today.

Updated

3 years ago
Blocks: 1074669

Updated

3 years ago
Blocks: 1107999
No longer blocks: 1074669

Comment 24

3 years ago
Hi Sergi,
Can you help to review the patch? Thank you!
Flags: needinfo?(sergi.mansilla)

Updated

3 years ago
Priority: -- → P2
Comment on attachment 8529550 [details] [review]
Pull request to master

Looks good to me. r+

Sorry about the delay!
Flags: needinfo?(sergi.mansilla)
Attachment #8529550 - Flags: review?(sergi.mansilla) → review+
(Assignee)

Comment 26

3 years ago
Hi Sergi, Really thanks for your review.
(Assignee)

Comment 27

3 years ago
Gaia-try passed: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=35a874dfced3

landed on master: https://github.com/mozilla-b2g/gaia/commit/99be66baf4146835bed70e8105c2b8934af5cb7d
landed on v2.0m: https://github.com/mozilla-b2g/gaia/commit/ef37eb354bbde5837211b22dfdc0eed9623ade0e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.0M: affected → fixed
status-b2g-v2.2: affected → fixed
Flags: needinfo?(kli)
Resolution: --- → FIXED
(Assignee)

Comment 28

3 years ago
Created attachment 8538446 [details] [review]
Pull request to v2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): broken function
[User impact] if declined: contacts app will freeze if users try to import vCards with particular format.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: N/A
Attachment #8538446 - Flags: approval-gaia-v2.1?
can QA please verify the issue on master before branch landings?
Keywords: verifyme

Comment 30

3 years ago
Created attachment 8539003 [details]
verify_video.MP4

The problem is verified not happen in latest build of Woodduck 2.0M
See attachment: verify_video.MP4

Woodduck build:
Gaia-Rev        ef37eb354bbde5837211b22dfdc0eed9623ade0e
Gecko-Rev       f179c7d4387b0fa6205ae6eee3d8eca15a5f9a8a
Build-ID        20141219050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1418936731
FW-Date         Fri Dec 19 05:05:54 CST 2014

Updated

3 years ago
status-b2g-v2.0M: fixed → verified

Updated

3 years ago
Flags: needinfo?(lulu.tian)

Updated

3 years ago
status-b2g-v2.2: fixed → verified
Flags: needinfo?(lulu.tian)

Comment 31

3 years ago
The problem is verified not happen in latest build of Flame 2.2
Flame 2.2 build:
Gaia-Rev        ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7b33ee7fd162
Build-ID        20141221040207
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141221.072549
FW-Date         Sun Dec 21 07:26:00 EST 2014
Bootloader      L1TC00011880

Updated

3 years ago
Attachment #8538446 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/17c7ad2e4919a994f0844239b483116090412dee
status-b2g-v2.0: affected → wontfix
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.2 S2 (19dec)

Updated

3 years ago
See Also: → bug 1115329

Comment 33

3 years ago
Created attachment 8545695 [details]
verify_v2.1.MP4

The problem is verified not happen in latest build of Flame 2.1
See attachment:verify_v2.1.MP4

Flame 2.1 build:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150107001244
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150107.035133
FW-Date         Wed Jan  7 03:51:45 EST 2015
Bootloader      L1TC000118D0

Updated

3 years ago
status-b2g-v2.1: fixed → verified

Updated

3 years ago
Status: RESOLVED → VERIFIED

Updated

3 years ago
Duplicate of this bug: 1090777

Comment 35

3 years ago
This bug had been verified successfully, clear the Keywords verifyme.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.