Closed Bug 1074720 Opened 5 years ago Closed 5 years ago

Display partner logo depending on the locale on FTU

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
3

Tracking

(firefox35 verified, firefox36 verified)

VERIFIED FIXED
mozilla36
Iteration:
36.3
Tracking Status
firefox35 --- verified
firefox36 --- verified
Blocking Flags:
backlog Fx35+

People

(Reporter: RT, Assigned: jaws)

References

Details

User Story

As a Firefox user, I want to see a meaningful brand displayed on FTU.

Requirement details:
* Ship all 4 partner logo images in Firefox - Images to be provided
* At run time select which image to show based on the localized version of Firefox installed
* Display image per https://bugzilla.mozilla.org/attachment.cgi?id=8517349 above the ToU and privacy notice links (displayed when the panel opens until the user receives his first call) on FTU only

Details of images per selected locale:
* GB English - O2 logo
* Germany German  - O2 logo
* Brazil Portuguese - Vivo logo
* Spain and Spanish Latin America - Movistar logo
* Any other locale - Telefonica logo

Attachments

(4 files, 6 obsolete files)

No description provided.
Blocks: 1062640
No longer blocks: 1071017
Whiteboard: [rooms]
Hi RT, Chad had said that they were getting the artifacts for logos to earlier this week.  Did you get anything?
Flags: needinfo?(rtestard)
No, pinging TEF daily about it....
Flags: needinfo?(rtestard)
User Story: (updated)
Attached image Vivo logo (obsolete) —
Attached image Movistar logo (obsolete) —
Attached image O2 logo (obsolete) —
3 local OB logos attached, still awaiting Telefonica logo.
These logos need to be in Fx35 (partner requirement).
Priority: -- → P1
Attached image TEL logo_pos.png (obsolete) —
A couple of details to sort out for how we handle these logos in mozilla-central:

Since these are logos that ship in-product but are owned (copyright/trademark) by a 3rd party under what we can assume are non-free terms, the actual images will presumably need to land somewhere in mozilla-central that doesn't imply they're free for use by anyone under MPL2. Probably under /other-licenses/? [Firefox's own restricted-use logo previously lived there, but moved to browser/branding/ when we clarified it was MPL plus a LICENSE file there to node trademark limits.]

I'm also assuming the code to show these logos in Firefox should be #ifdef MOZILLA_OFFICIAL, so that only Mozilla's own official builds (Nightly/Aurora/Beta/Release) will show the branding? Specifically, other people building the browser from this code (eg Palemoon, Debian IceCat, or just developers producing their own builds) should not see the partner branding? I assume (again!) that the partners don't care about this case, but it's an important technicality to handle this properly as a free-software project.

CC Gerv who can weigh in here!
Flags: needinfo?(gerv)
Attached image Screenshot of the UI using these logos (obsolete) —
Via https://people.mozilla.org/~dhenein/loop/rooms/, for the context of where these logos will be used.
(Verified that bug 1079430 is landing the "Powered by" string that goes along with these logos)
What's the proposed added value to having these logos part of our product? I'm sure this is mighty interesting for our partners, as this will be their cheapest branding campaign yet, but I'm afraid to damage our brand with a tie-in this close with commercial entities like this.

Also the wording of 'Powered by' seems a bit pretentious to me - is Loop made possible due to O2, Vivo, Movistar and Telefonica awesomeness? As a user, what do mobile phone companies have to do with Firefox Desktop?

The more I think about this, the less sense it makes to me...
Flags: qe-verify?
Flags: firefox-backlog+
Flags: needinfo?(cweiner)
Depends on: 1082664
backlog: --- → Fx35+
We have logos trademarked by people other than us in the tree marked as being under free copyright licenses - e.g. search engine logos. Trademarks should be protected by trademark, not copyright. So the best solution here is to agree with the partners that it's OK to ship web-resolution versions of their logos under a free copyright license, with an appropriate acknowledgement of trademark ownership somewhere if they want one.

I realise, of course, that this might or might not be tricky to arrange. But currently, we don't ship proprietary stuff in Firefox, and it's important it stays that way.

Gerv
Flags: needinfo?(gerv)
Hi Geoff, can you please help us there and engage with Telefonica in case we are not covered yet?
Flags: needinfo?(gpiper)
Marking as confidential as it seems we're getting into contract details.
Please unmark if that's not appropriate.
Group: mozilla-employee-confidential
Adding Mika and Susan to this Bug.
There is a lot going on here I would like to understand in connection with the current Amendment (Mobile Offering) and these branding questions which I believe we were receiving an 18 month window to not do such branding in the mobile offering. Susan to confirm.

As to the agreement, branding usage of logos requires TEF/TB approval...but before we go there let's sort out the above.

As to the other Legal items, we would have a license to use them and making them available in FxOS (once we sort out the above) is not an issue. happy to speak live about this more as needed.
Flags: needinfo?(gpiper)
Geoff, this is about the desktop offering. Branding in the desktop client UI on FTU.
Ok then my third comment applies. I believe there is a layer of TB approval that is needed. Otherwise, we have the license to use it per the Agreement (See Exhibit G).  I believe Mika will assist with any needed added details.
Folks, sorry I was late to the conversation.  Just want to be sure we have this cleared up.  We have an agreement with TokBox/TEF (for desktop) that has branding and the license to use their brands in the product.  There should be no blocker here.  As soon as the mobile Amendment is executed, we'll be good there as well, with some timing caveats.

Romain, please confirm that TEF has approved our design on the FTU for desktop.  I know we had sent it, but just need to "check the box" that this is complete.
Flags: needinfo?(rtestard)
We need to be clear here on copyright vs. trademark. The issue here is not about getting a (trademark) license to use their brands in our product. I'm sure we have that in the existing agreements. That's not the problem. The issue is getting a digital file containing a copy of their logo under a (copyright) license which makes that individual file containing the logo "free software", so it can be part of Firefox.

One way we could achieve this would be by creating our own version of their logo from scratch which looked visually identical. Of course, they may prefer us to use their official version, which would be understandabe. But if that's what they want, they need to release those bits (ones and zeroes) to us under an appropriate _copyright_ license.

Does that make sense?

Gerv
(In reply to Joanne Nagel from comment #19)
> Folks, sorry I was late to the conversation.  Just want to be sure we have
> this cleared up.  We have an agreement with TokBox/TEF (for desktop) that
> has branding and the license to use their brands in the product.  There
> should be no blocker here.  As soon as the mobile Amendment is executed,
> we'll be good there as well, with some timing caveats.
> 
> Romain, please confirm that TEF has approved our design on the FTU for
> desktop.  I know we had sent it, but just need to "check the box" that this
> is complete.
I received the final mocks yesterday from Darrin as it took TEF time to provide the logo assets.
I have now sent it to Oli for validation although they had already approved the Telefonica one so I don't expect any issues there(you are copied on the e-mail).

Regrading the copyright issue, can you please take it back to TEF to validate what has to be done?
We need to understand if it is a blocker for having branding delivered in Fx35.
Flags: needinfo?(rtestard) → needinfo?(jnagel)
To be clear, there are 3 components which are displayed on FTU:
* "Get started" button opening the tour in a new tab (bug 1083466)
    - This will disappear the next time the user opens the panel
* The links to ToS and privacy notice (bug 1084362)
    - This will disappear after the first time someone joins a room created by the user (this is because there are 2 links and given that the panel closes as you click a link, we need to give an opportunity to the user to open both links)
* The Telefonica logo (bug 1074720)
    - This will disappear the next time the user opens the panel
User Story: (updated)
Summary: Display partner logo with ToU and privacy policy links depending on the locale → Display partner logo depending on the locale on FTU
Gerv,

How is displaying the logo as Romain indicates in comment 22, different than Firefox displaying our partner's logo's in the search drop-down?  All of those are distributed by Mozilla.  Absolutely do not create our own version of their logo, our partners have provided these under our agreements.
Flags: needinfo?(jnagel)
(In reply to Joanne Nagel from comment #23)
> How is displaying the logo as Romain indicates in comment 22, different than
> Firefox displaying our partner's logo's in the search drop-down? 

It's not; if we don't have free-software copies of those logos, that's a bug.

> All of
> those are distributed by Mozilla.  Absolutely do not create our own version
> of their logo, our partners have provided these under our agreements.

That suggestion was another way of illustrating my point; I agree we need to get each company to OK the use of a copy of their logo under the MPL. Note that the MPL does not grant trademark rights, so there's no concern there.

Gerv
This is a simple issue in my view. We have the trademark license as well as the use of any underlying copyrights covered by Section 9.2 in the agreement for use in our RTC Product (we don't need to over-complicate the issue here of the underlying copyright in a trademarked logo of our partner and their subs when being used in our MPL-ed software, our agreements handle this and that would be a silly argument for the partner or a sub to pursue against us especially given the license language and goal of the relationship). 

Our agreement requires approval from TokBox as to placement of branding (e.g., logos). So, let's clear / get approval for the intended use, placement, position, size etc all with TokBox...which we should always do as required then we are clear to move forward.
If Geoff thinks we have the rights to distribute logo files under the MPL already in the contract, great :-) No issue. We should put the files wherever in the tree is most convenient, not in "other-licenses".

Gerv
Target Milestone: mozilla35 → ---
Whiteboard: [rooms] → [rooms][blocked until copyright/trademark issue is cleared]
Whiteboard: [rooms][blocked until copyright/trademark issue is cleared] → [rooms][blocked until copyright/trademark issue is cleared, see comment #25]
Hi Romain,

Did Oli give his buy off on the mock-ups?  That is all Geoff said we needed to implement.
Flags: needinfo?(rtestard)
Yes, the updated mock is now on bug 1082664 with only minor changes.
We're good to implement.
Flags: needinfo?(rtestard)
RT -- I've cleared the whiteboard flags saying we were "blocked until copy/tradmark issue is cleared."  I assume from your comment 28 that all of Geoff's concerns (listed in Comment 25) are resolved?  

In particular from Comment 25: "Our agreement requires approval from TokBox as to placement of branding (e.g., logos). So, let's clear / get approval for the intended use, placement, position, size etc all with TokBox...which we should always do as required then we are clear to move forward."

Sorry to ask a second time; I just want to make sure we have this done before we put the logos in the code.  I ask someone to sure that we're good with our partner from legal perspective.
Whiteboard: [rooms][blocked until copyright/trademark issue is cleared, see comment #25]
Flags: needinfo?(rtestard)
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #29)
> RT -- I've cleared the whiteboard flags saying we were "blocked until
> copy/tradmark issue is cleared."  I assume from your comment 28 that all of
> Geoff's concerns (listed in Comment 25) are resolved?  
> 
> In particular from Comment 25: "Our agreement requires approval from TokBox
> as to placement of branding (e.g., logos). So, let's clear / get approval
> for the intended use, placement, position, size etc all with TokBox...which
> we should always do as required then we are clear to move forward."
> 
> Sorry to ask a second time; I just want to make sure we have this done
> before we put the logos in the code.  I ask someone to sure that we're good
> with our partner from legal perspective.

I forwarded Geoff and you the e-mail where Oli signed the design off.
Geoff can you please confirm that this approval is enough to cover us?
Flags: needinfo?(rtestard) → needinfo?(gpiper)
Yes. No need for additional checks from legal when requisite approval per the agreement is obtained from the partner. Please proceed.
Flags: needinfo?(gpiper)
per Romains comments in trello: Please note that Oli requested a slightly amended mock-up with different fonts and picture offset, awaiting his reply on latest design sent to him.
Via email on Oct 27th Oli approved based on changes Darrin provided.  Now we need to attach the amended UX and internal approval for reversing the positions of TOS and branding.  

Oli: "All signed off.  Please proceed with the proposal below.  Many thanks."

Darrin can you attach the amended screen shot to this bug that needs internal approvals?  it was in the email but didn't scale up well for folks to implement the bugs from or approve.

Chad, Arcadio, Mika?  Do any of you have any objections to the amendments or should we move forward with the design? 

Darrin's modifications that Oli's approved:
"There is actually only one font used, which is Lucida Grande. This is the default font on OSX. Each platform (Windows, OSX, Linux) will appear slightly differently depending on the system font (even OSX will vary, as Yosemite released yesterday and includes Helvetica Neue as the default system font).


I’ve reversed the TOS and branding, but will need internal sign off on this as well. We never received any brand guidelines, but the O2 logo was centre-aligned with the text (though appears higher due to the subscript 2). I’ve moved it down to mitigate this illusion."
Flags: needinfo?(udevi)
Flags: needinfo?(dhenein)
Flags: needinfo?(alainez)
Flags: needinfo?(dhenein)
removing need info's - branding placement was approved https://bug1074720.bugzilla.mozilla.org/attachment.cgi?id=8517349&t=Lq85Fr5Z35 and the assets are attached.
Flags: needinfo?(udevi)
Flags: needinfo?(cweiner)
Flags: needinfo?(alainez)
Hi Guys,

Looking at the assets, the logos vary in size and are different from what we'll need.  since it's unlikely to get SVG assets from the various companies - could we get help resizing to the size needed for the UX?  JAWS mentioned high DPI and low DPI images as well.
Flags: needinfo?(sfranks)
Flags: needinfo?(philipp)
Flags: needinfo?(dhenein)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 36.3
Points: --- → 3
Flags: qe-verify? → qe-verify+
Attached file Sized Partner Logos
Sized logos attached.
Flags: needinfo?(sfranks)
Flags: needinfo?(philipp)
Flags: needinfo?(dhenein)
User Story: (updated)
Attached patch Patch (obsolete) — Splinter Review
Attachment #8502341 - Attachment is obsolete: true
Attachment #8502342 - Attachment is obsolete: true
Attachment #8502343 - Attachment is obsolete: true
Attachment #8502429 - Attachment is obsolete: true
Attachment #8503426 - Attachment is obsolete: true
Attachment #8522452 - Flags: review?(dmose)
Attachment #8522452 - Flags: review?(dmose) → review?(mdeboer)
Attachment #8522452 - Flags: review?(nperriault)
Comment on attachment 8522452 [details] [diff] [review]
Patch

Review of attachment 8522452 [details] [diff] [review]:
-----------------------------------------------------------------

When I apply & check the patch visually, I see that when rooms are enabled (which has just been flipped ON as the the default) that the margins are off. Can you check that out? Thanks!

::: browser/components/loop/content/js/panel.jsx
@@ +165,5 @@
>      },
>  
>      render: function() {
>        if (this.state.seenToS == "unseen") {
> +        // XXX need to get proper locale here.

What's the proper way then? Should we add a MozLoopAPI method for this? If there's a bug on file for this, please mention that in the comment, otherwise you might want to file one.

@@ +186,5 @@
> +        return <div>
> +                <p id="powered-by">
> +                  {__("powered_by_beforeLogo")}
> +                  <img id="powered-by-logo" className={locale} />
> +                  {__("powered_by_afterLogo")}

nit: please change this to `mozL10n.get("...")`. We're trying to migrate away from `__("...")`

::: browser/components/loop/content/shared/css/panel.css
@@ +493,5 @@
> +  width: 92px;
> +  height: 20px;
> +}
> +
> +@media (resolution: 2dppx) {

No min-resolution?
Attachment #8522452 - Flags: review?(nperriault)
Attachment #8522452 - Flags: review?(mdeboer)
Attachment #8522452 - Flags: review-
Attached patch Patch v1.1Splinter Review
(In reply to Mike de Boer [:mikedeboer] from comment #39)
> When I apply & check the patch visually, I see that when rooms are enabled
> (which has just been flipped ON as the the default) that the margins are
> off. Can you check that out? Thanks!

This was not broken by my patch. I filed bug 1100565 for this.
 
> ::: browser/components/loop/content/js/panel.jsx
> @@ +165,5 @@
> >      },
> >  
> >      render: function() {
> >        if (this.state.seenToS == "unseen") {
> > +        // XXX need to get proper locale here.
> 
> What's the proper way then? Should we add a MozLoopAPI method for this? If
> there's a bug on file for this, please mention that in the comment,
> otherwise you might want to file one.

Sorry, this was an outdated ToDo for myself. It was using the proper method, I just forgot to remove this comment before uploading.
Attachment #8522452 - Attachment is obsolete: true
Attachment #8524137 - Flags: review?(mdeboer)
Comment on attachment 8524137 [details] [diff] [review]
Patch v1.1

Review of attachment 8524137 [details] [diff] [review]:
-----------------------------------------------------------------

Ship it!

::: browser/components/loop/content/js/panel.jsx
@@ +188,5 @@
>              </a>
>            ),
>          });
> +        return <div>
> +                <p id="powered-by">

nit: please fix the indentation here when you land this.
Attachment #8524137 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/c040e198d145
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla36
Tested on Windows 8.1 with today's Nightly.

Expected Results:
> GB English - O2 logo
> Germany German  - O2 logo
> Brazil Portuguese - Vivo logo
> Spain and Spanish Latin America - Movistar logo
> Any other locale - Telefonica logo

Actual Results:
> Firefox 36.0a1 2014-11-19 de: Telefonic
> Firefox 36.0a1 2014-11-19 en-GB: O2
> Firefox 36.0a1 2014-11-19 es-CL: Movistar
> Firefox 36.0a1 2014-11-19 es-ES: Movistar
> Firefox 36.0a1 2014-11-19 ja: Telefonica
> Firefox 36.0a1 2014-11-19 pl: Telefonica
> Firefox 36.0a1 2014-11-19 pt-BR: Vivo
> Firefox 36.0a1 2014-11-19 ru: Telefonica
> Firefox 36.0a1 2014-11-19 zh-TW: Telefonica

Aside from German, it seems like every locale is working as expected.
Comment on attachment 8524137 [details] [diff] [review]
Patch v1.1

Approval Request Comment

requirement for Loop for Aurora/35
On m-c

[String/UUID change made/needed]: none
Attachment #8524137 - Flags: approval-mozilla-aurora?
Well, I don't think we're done here, as German isn't working yet ('de' instead of 'de-DE').
I think Anthony simply forgot to reopen as such.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8524137 [details] [diff] [review]
Patch v1.1

Looks like this might need a follow-up fix for German, a=me if you want to just make that change and then land.
Attachment #8524137 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attached patch PatchSplinter Review
It should have worked for German/German, but not for the general German because there are other countries like Lithuania that speak German but aren't Germany.

I've added "de" as a supported locale for this, but didn't expand it to all "de-*" locales due to the aforementioned question.

Romain, should the O2 logo be shown for _all_ German locales? Or just the one for Germany and the broader "de" general build?
Flags: needinfo?(rtestard)
Attachment #8526580 - Flags: review?(mdeboer)
https://hg.mozilla.org/releases/mozilla-aurora/rev/9d8d0c858698
Note: without the german fix; we'll need to land that on Aurora as well per lucas's comment
Comment on attachment 8526580 [details] [diff] [review]
Patch

Review of attachment 8526580 [details] [diff] [review]:
-----------------------------------------------------------------

_
           /(|
          (  :
         __\  \  _____
       (____)  `|
      (____)|   |
       (____).__|
        (___)__.|_____
Attachment #8526580 - Flags: review?(mdeboer) → review+
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #48)
> Created attachment 8526580 [details] [diff] [review]
> Patch
> 
> It should have worked for German/German, but not for the general German
> because there are other countries like Lithuania that speak German but
> aren't Germany.
> 
> I've added "de" as a supported locale for this, but didn't expand it to all
> "de-*" locales due to the aforementioned question.

Not sure what locales you're referring to. We only have one German locale and that's "de". I see no de-* locales on ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #51)
> (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #48)
> > Created attachment 8526580 [details] [diff] [review]
> > Patch
> > 
> > It should have worked for German/German, but not for the general German
> > because there are other countries like Lithuania that speak German but
> > aren't Germany.
> > 
> > I've added "de" as a supported locale for this, but didn't expand it to all
> > "de-*" locales due to the aforementioned question.
> 
> Not sure what locales you're referring to. We only have one German locale
> and that's "de". I see no de-* locales on
> ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n

I was looking at the list of locales through "Preferences > Content > Languages > Select a language to add..." but your link is the more correct version. I'll remove the .de-DE selector then, if we only need to worry about encountering a 'de' locale.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #48)
> Created attachment 8526580 [details] [diff] [review]
> Patch
> 
> It should have worked for German/German, but not for the general German
> because there are other countries like Lithuania that speak German but
> aren't Germany.
> 
> I've added "de" as a supported locale for this, but didn't expand it to all
> "de-*" locales due to the aforementioned question.
> 
> Romain, should the O2 logo be shown for _all_ German locales? Or just the
> one for Germany and the broader "de" general build?

We need it for Germany only - "de" locale.
Flags: needinfo?(rtestard)
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 8526580 [details] [diff] [review]
Patch

Approval Request Comment
[Risks and why]: Loop rooms code to update German 'de' localization for partner logos
[String/UUID change made/needed]: none
Attachment #8526580 - Flags: approval-mozilla-aurora?
Attachment #8526580 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
All looks good on Nightly. Aurora is okay except for the German locale which shows Telefonica instead of O2 (same as Nightly used to). I guess there's follow-up work to do?
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #58)
> I guess there's
> follow-up work to do?

The patch to fix O2 needs to be uplifted to Aurora (see comment #57 and the subsequent approval-mozilla-aurora+).
Status: RESOLVED → VERIFIED
I've just verified this fixed now on today's Aurora.
Depends on: 1120912
Depends on: 1120922
Can we open this bug up now?
Flags: needinfo?(sescalante)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #62)
> Can we open this bug up now?

I suspect that question is more in RT's domain.
Flags: needinfo?(sescalante) → needinfo?(rtestard)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #62)
> Can we open this bug up now?

Not sure I understand why this bug should be re-opened, can you please clarify?
Flags: needinfo?(rtestard)
(In reply to Romain Testard [:RT] from comment #64)
> (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #62)
> > Can we open this bug up now?
> 
> Not sure I understand why this bug should be re-opened, can you please
> clarify?

Romain, what Jared means if we can lift the Moz-employee only restriction from this bug, so that it'll be publicly visible.
Flags: needinfo?(rtestard)
Oh OK understood now:)
OK now done.
Group: mozilla-employee-confidential
Flags: needinfo?(rtestard)
You need to log in before you can comment on or make changes to this bug.