clicking <label> for <select> should focus (and drop down?) <select>

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: rods (gone))

Tracking

({html4, testcase})

Trunk
Future
x86
Windows 98
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HTML4-17.9.1])

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
The attached WebCT calendar form includes a label for each form element.  
Clicking the labels for the <select> drop-downs doesn't do anything.  It should 
focus the drop-down and probably also drop down the menu.
(Reporter)

Comment 1

16 years ago
Created attachment 55798 [details]
webct page
(Reporter)

Comment 2

16 years ago
Created attachment 55801 [details]
testcase
Keywords: testcase
(Assignee)

Comment 3

16 years ago
I think this is a dup or I know there is a bug about this same thing for a 
different control
Status: NEW → ASSIGNED
Summary: clicking <label> for <select> should focus (and drop down?) <select> → [DUP]clicking <label> for <select> should focus (and drop down?) <select>
Target Milestone: --- → Future
(Assignee)

Comment 4

16 years ago
*** Bug 106344 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
This is similar to bug 28657 "Clicking on <LABEL> doesn't put focus in INPUT
field" which is assigned to saari. rods probably these should be resolved
together. Setting blocker to bug 7954.
Blocks: 7954
Keywords: html4
Summary: [DUP]clicking <label> for <select> should focus (and drop down?) <select> → clicking <label> for <select> should focus (and drop down?) <select>
Whiteboard: [HTML4-17.9.1]

Comment 6

15 years ago
This seems to work OK in mozilla 1.1 beta. Assignee would you mind marking as FIXED?

Comment 7

15 years ago
In both test cases, the focus is transferred from the label to its corresponding
select. So that part WFM. But the activation of the drop-down list does not
happen, the list of options does not drop down, pop up. I believe this should be
the expected behavior of select in case they get the focus from its
corresponding label.
Just my 2 cents.

Mozilla 1.2alpha build 2002091004
When I tab into the <select>, it doesn't automatically drop down... I fail to
see how focusing it via a label is any different. imo what we are doing right
now is correct.

Comment 9

14 years ago
Ok then, I agree that the list does not need to drop-down if the focus is
transfered to the select. So, I assume this bugfile can be resolved as FIXED.
FIXED would mean we know what fixed it.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.