Closed Bug 1076706 Opened 8 years ago Closed 8 years ago

[Smart Screen][Home] Implement card listing and launching function

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S8 (7Nov)

People

(Reporter: rexboy, Assigned: dwi2)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
jj.evelyn
: review+
rexboy
: review+
Details | Review
This bug implements the following:
- Initialize a card list come from picked decks and apps.
- Build backend storage for cards, orders, and considering if it's structure is suitable for folders that would be implemented later.
- Display these card onto UI.
Assignee: nobody → tzhuang
Considering using datastore as backend storage.
Depends on: 1076702
Proposal process of loading card list when smart-home app launch:

1 - launch smart-home app 
2 - check if we have card entry list stored in datastore

2.1 - if not, smart-home app is first-time launch -> 3.1
2.2 - if yes, smart-home app is not first-time launch -> 3.2

3.1 - read init.json to get default card entry list -> 4
3.2 - read card entry list from datastore

4 - store card entry into datastore
Target Milestone: --- → 2.1 S7 (24Oct)
Blocks: CardUI
Attached file pull request
Hi Rex, Evelyn,

Please help to review the patch.

This patch does only the storage of card list and are able to launch app. But user still cannot launch app from UI because there need more effort on integration of UI and app launching functionality. I'll file another bug to do that.
Attachment #8510852 - Flags: review?(rexboy)
Attachment #8510852 - Flags: review?(ehung)
Summary: [Stingray][Home] Implement card listing and launching function → [Smart Screen][Home] Implement card listing and launching function
Blocks: 1089464
Comment on attachment 8510852 [details] [review]
pull request

It's almost OK for me but small changes needed.
See my comments on Github.
Attachment #8510852 - Flags: review?(rexboy) → feedback+
Whiteboard: [ft:conndevices]
Comment on attachment 8510852 [details] [review]
pull request

Hi Rex,

I've addressed your comments. Also I add unit tests for the case you mentioned in  https://github.com/dwi2/gaia/commit/308ce2c66e429e1d9b4beb89700b9a28a79cd8fe#commitcomment-8311209
to make sure they are all right.

Please help to review it again, thanks
Attachment #8510852 - Flags: review?(rexboy)
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
Comment on attachment 8510852 [details] [review]
pull request

Looks good to me.

Thanks for your work!
Attachment #8510852 - Flags: review?(rexboy)
Attachment #8510852 - Flags: review+
Attachment #8510852 - Flags: feedback+
Comment on attachment 8510852 [details] [review]
pull request

r+ with nits addressed. Thanks!
Attachment #8510852 - Flags: review?(ehung) → review+
Thanks,

All comments are addressed.
Waiting for Gaia-Try result
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=204b3a5c56cb
Gaia try seems ok. 
Landed on master: https://github.com/mozilla-b2g/gaia/commit/83b2877f6a61505646cb33871d42b8dc4643f573
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1067787
You need to log in before you can comment on or make changes to this bug.