[Contacts] Number of contacts not shown during first run import

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: mancas, Mentored)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [good-first-bug])

Attachments

(3 attachments)

Created attachment 8499124 [details]
Screenshot of issue on Master branch

Flame, while running:

Gaia   191d805f4911628d37a8a90a1e23a6013995138f
SourceStamp 5d6ec4dddf14
BuildID 20141002093155
Version 35.0a1
base: v184

STR:
1. Import a vcf file during first run
2. Receive the attached screenshot

Expected: I would see the number of contact like I do when I do it from the contacts app
Actual: No count is shown
(Reporter)

Updated

4 years ago
Summary: [Contacts] Number of contacts not shown during import during first run → [Contacts] Number of contacts not shown during first run import
QA wanted for a branch check.
Keywords: qawanted
Tempted to move it to FTU app, as this is shared code between contacts and ftu.

I've just seen this working ok in the contacts side.
Mentor: francisco
Whiteboard: [good-first-bug]
Tested with Shallow Flash on 319mb

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: No contact numbers appear when importing through FTU.

Repro Rate: 2/2

Environmental Variables:
Device: Flame Master KK
BuildID: 20141002101320
Gaia: d711d1e469eeeecf25a02b2407a542a598918b2c
Gecko: b85c260821ab
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Contact numbers are appearing correctly in the FTU when importing contacts.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141003001634
Gaia: 1cb6775fe67d7f71098d9c8b2fefb08bfe44ec87
Gecko: ebe8760a5f65
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141002193135
Gaia: fa797854bfe708129ed54a158ad4336df1015c39
Gecko: 9b7fd1f78a15
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Duplicate of this bug: 1081730
Transporting Reg Window and blocking status from the Dupe bug in prior comment 
"Nominating this 2.2? since this is a regression and the text is unreadable. Not a good first time experience for the end user."
blocking-b2g: --- → 2.2?
Keywords: regressionwindow-wanted
QA Contact: croesch → aalldredge
----------------------------------------------------
B2G-Inbound Regression Window (Shallow Flash)
----------------------------------------------------

Last Working:
Device: Flame 2.2
BuildID: 20141001052925
Gaia: e26cae049d81a4fb35da9964eda12921da0346bb
Gecko: 5fa7a7f2b4ae
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2 Master
BuildID: 20141001054223
Gaia: 6d003545241a400f83cdc4df797ed0e949e5b856
Gecko: cdc2bda1a15c
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e26cae049d81a4fb35da9964eda12921da0346bb
Gecko: cdc2bda1a15c

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 6d003545241a400f83cdc4df797ed0e949e5b856
Gecko: 5fa7a7f2b4ae

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/e26cae049d81a4fb35da9964eda12921da0346bb...6d003545241a400f83cdc4df797ed0e949e5b856

Caused by Bug 1069306
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Possibly broken by Bug 1069306 - can you take a look Manuel?
Blocks: 1069306
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(b.mcb)
QA Contact: aalldredge
triage: identifiable regression
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Assignee: nobody → b.mcb
Flags: needinfo?(b.mcb)
(Assignee)

Comment 9

4 years ago
Created attachment 8507703 [details]
import-contacts.png
Attachment #8507703 - Flags: ui-review?(echang)
(Assignee)

Comment 10

4 years ago
Created attachment 8507705 [details] [review]
Number of contacts is showing properly
Attachment #8507705 - Flags: review?(fernando.campo)
Comment on attachment 8507705 [details] [review]
Number of contacts is showing properly

tested on device, working nicely, thanks Manuel
Attachment #8507705 - Flags: review?(fernando.campo) → review+
And agreeing with Francisco on comment 2, moving it to FTE, even if it's shared, it affects only this app, and it was caused by previous changes on it.
Component: Gaia::Contacts → Gaia::First Time Experience
Attachment #8507703 - Flags: ui-review?(echang) → ui-review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/8e1fe3c5931caf3133c5567a0bf44ba7fcbd6298
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S7 (24Oct)
status-b2g-v2.2: affected → fixed
This issue is verified fixed on Flame 2.2

Result: While in FTE, importing contacts from SIM and SD card displays the total number being imported

Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.