No video display. sound only

RESOLVED FIXED in Firefox 35

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: alice0775, Assigned: kinetik)

Tracking

({regression})

35 Branch
mozilla35
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34 unaffected, firefox35+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
[Tracking Requested - why for this release]:

Steps To Reproduce:
1. Open https://people.mozilla.org/~rgiles/2013/demo.webm


Actual Results:
No video display.  sound only

Expected Results:
Video and sound should play

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6122db43cad3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140930200924
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5997c0f393ba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140930203524
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6122db43cad3&tochange=5997c0f393ba

Regressed by: Bug 1074004
(Assignee)

Comment 1

5 years ago
There is video, it's just really small.  The other issue is the video, upon loading, immediately jumps to the end.
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
Oops:

    r = io->io.seek(-(io->bufsz - io->offset), NESTEGG_SEE_CUR, io->io.userdata);

bufsz is size_t, offset is int, first argument to seek is int64_t.  The result of (io->bufsz - io->offset) is size_t and negating that obviously has an undesirable effect.  Simple fix is to convert to int64_t before negating.
(Assignee)

Comment 3

5 years ago
...which the newly added libnestegg testsuite didn't catch because it passes the seek offset directly to fseek, which takes a long, resulting in the correct value being used. :-(

I altered the testsuite to catch this, but none of the existing tests hit the bug, so I've added a truncated copy of demo.webm to expose it.

Fix and new test pushed:
https://github.com/kinetiknz/nestegg/commit/a4a990cffe2ce80edc1d045c1958000dd607fe83
(Assignee)

Comment 4

5 years ago
Attachment #8499296 - Flags: review?(giles)
Attachment #8499296 - Flags: review?(giles) → review+
(Assignee)

Updated

5 years ago
Blocks: 1078118
https://hg.mozilla.org/mozilla-central/rev/c78b949b21da
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35

Updated

5 years ago
Duplicate of this bug: 1067558
Duplicate of this bug: 1067558

Comment 9

5 years ago
I still have problem with that video

Steps To Reproduce:
1. Open https://people.mozilla.org/~rgiles/2013/demo.webm
2. Move slider, back or forward
3. Move cursor out of the video's canvas
4. Video will be visible only when cursor is on video

What helps is you can RMB click on video and left click out of menu. Video will be back.

Comment 10

5 years ago
(In reply to fatrat from comment #9)
> I still have problem with that video
> 
> Steps To Reproduce:
> 1. Open https://people.mozilla.org/~rgiles/2013/demo.webm
> 2. Move slider, back or forward
> 3. Move cursor out of the video's canvas
> 4. Video will be visible only when cursor is on video
> 
> What helps is you can RMB click on video and left click out of menu. Video
> will be back.

I forgot to say, I have latest nighlty 36.0a1 (2014-10-24)
(Reporter)

Comment 11

5 years ago
(In reply to fatrat from comment #10)
> (In reply to fatrat from comment #9)
> > I still have problem with that video
> > 
> > Steps To Reproduce:
> > 1. Open https://people.mozilla.org/~rgiles/2013/demo.webm
> > 2. Move slider, back or forward
> > 3. Move cursor out of the video's canvas
> > 4. Video will be visible only when cursor is on video
> > 
> > What helps is you can RMB click on video and left click out of menu. Video
> > will be back.
> 
> I forgot to say, I have latest nighlty 36.0a1 (2014-10-24)

Could you file a new bug.
(Reporter)

Updated

5 years ago
Flags: needinfo?(gu83)

Comment 12

5 years ago
What other info do you need?
OS is windows 8.1x64, system is up to date
Video card GTX560Ti with 335.23 driver
2 monitor screens, happens on both.
What is strange is that black square is larger than the video itself. Like something is covering the video.
Firefox has E10s enabled.
Flags: needinfo?(gu83)

Comment 13

5 years ago
(In reply to Alice0775 White from comment #11)
> (In reply to fatrat from comment #10)
> > (In reply to fatrat from comment #9)
> > > I still have problem with that video
> > > 
> > > Steps To Reproduce:
> > > 1. Open https://people.mozilla.org/~rgiles/2013/demo.webm
> > > 2. Move slider, back or forward
> > > 3. Move cursor out of the video's canvas
> > > 4. Video will be visible only when cursor is on video
> > > 
> > > What helps is you can RMB click on video and left click out of menu. Video
> > > will be back.
> > 
> > I forgot to say, I have latest nighlty 36.0a1 (2014-10-24)
> 
> Could you file a new bug.
I'm not sure if what happens is a new bug. Or is it?
I could be wrong tho.
(Reporter)

Comment 14

5 years ago
Just file a new bug.
And please describe
* Steps to reproduce
* screenshot what you see
* which versions are affected
* Graphic section of about:support.
Flags: needinfo?(gu83)

Comment 15

5 years ago
I couldn't replicate it on my laptop and on my friend's pc. And now it doesn't occur even on my computer after last 2 updates. So no need for new file bug. It kind of self fixed...
Flags: needinfo?(gu83)
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.