Closed Bug 1077198 Opened 8 years ago Closed 8 years ago

Update Shumway to version 0.9.2970

Categories

(Firefox Graveyard :: Shumway, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 35

People

(Reporter: yury, Assigned: yury)

References

Details

Attachments

(1 file)

Changes:

#1658 Adds a player option to trace mouse events and the targets they are disp...
#1659 Media
#1664 Fontsizeandcodefix
#1665 Fixes image loading
#1667 Adds better font heuristic for detecting font2 scaling
#1666 Timeline fixes
#1679 Rename All The Things from AS2Something to AVM1Something
#1661 Rent
#1687 Stub out TextField.setSelection.
#1688 Misc
#1692 Removes stream.ensure() usage
#1689 Zoom
#1695 join two segments if they connects with their start point
#1698 Bug 988624 - Lazily load ShumwayStreamConverter.jsm
#1697 Fix hit testing for shapes that contain style change records
#1699 Properly handles AS2 registerClass when symbol is exported twice
#1696 Change mouse wheel to behave same way as PDF.js.
#1694 Bug 1064110 - Add support for stroke scale modes
#1702 Misc fixes to fix Flocons... again
#1703 Fixing ace7504064ec35d5 regression (for Chrome)
#1700 Misc
#1701 Bug 1063050 - Don't use DataView in DataBuffers.
#1705 Backout of 82d2161
#1704 Don't implement Flash's stroking model as a polyfill.
#1706 Bug 1062782 - Switch Matrix implementations to use Float64Array (or Float32Array, if that works)
#1707 [Bug 1066566] Fix inspector's "Open File" functionality
#1708 Hack to wait for Chrome to load fonts
#1715 Warn about dropped tags in defineSymbol parsing
#1714 Bug 1067190 - Handle singular gradient transform matrices in the GFX backend
#1716 Bug 1063786 - Support nested symbol definitions in the SWF parser. r=tobytailor
#1718 Performance Fixes
#1717 Matrix
#1719 Add acid tests to ref tests.
#1722 Slightly improved debug messages for ignored SWF tags
#1723 Improvement to the FF extension's context menu
#1724 Replacing sandbox eval
#1711 Bug 1067130 - Overhaul mouse target finding, hit testing, and getObjectsUnderPoint
#1728 Bug 1067130 -Part 2: Add reftest for getObjectsUnderPoint. r=tobytailor
#1725 Fixes canvas resizing in the easel
#1731 Bitmap data
#1727 Adds a perf testing framework.
#1732 Properly handles START_SOUND tags
#1733 Bitmap data
#1736 Bitmap data
#1713 Improve support for AVM1 SWF loading
#1737 Implements priority time queue in trace tests
#1721 Use custom closure compiler for extension builds
#1720 Fix image loading events
#1738 Disabling intermittent failure tests
#1739 Make sure an object is of type MovieClip when calling _enqueueFrameScrip...
#1741 Replaces python test.py with node.js version
#1743 Bug 1071422 - Change all of Event's and important subclasses' methods to native implementations
#1744 Change reftest server's port to 8080
#1745 Bug 1067130 - Part 3: Re-instate stas test for getObjectsUnderPoint
#1747 Cleans up Makefile
#1746 Additional test.js improvements: no e10s prompts, cleanup and userAgent.
#1748 Fixes ZeroClipboard
#1749 Enable logging brief function compilation timings in the AVM2 compiler
#1752 Hacking of the ZeroClipboard to not use navigator.plugins
#1753 AVM1 MovieClipLoader fixes
#1754 Event loop order fixes
#1755 More AVM1 MovieClipLoader fixes
#1756 Native-ify various Array methods
#1757 Remove AS3 implementation of Array constructor
#1758 Trampolining optimizations
#1751 Loader
#1740 Bitmap data
#1760 Disable some tests due to failures
#1759 Substantially improve compatibility of describeTypeJSON implementation
#1761 Small vector optimizations
#1763 Misc
#1765 Fixes fakeworker postsyncmessage
#1766 Implements wmode=transparent parameter
#1726 Fire AVM1 initialize, construct and load events
Attachment #8499262 - Flags: review?(till)
Comment on attachment 8499262 [details] [diff] [review]
Update Shumway to version 0.9.2970

Review of attachment 8499262 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great!

::: browser/extensions/shumway/content/ShumwayStreamConverter.jsm
@@ +536,5 @@
>      return this.window.parent.wrappedJSObject.location + '';
>    }
>  };
>  
> +function monitorUserInput(actions) {

It'd be nice if we could integrate this into the user input handling we do anyway. Not a blocker for landing this, though. Perhaps file a bug for it?

@@ +764,5 @@
>        case 'undefined':
>          return '<undefined/>';
>        }
>      };
> +    wrappedWindow.__flash__eval = function (expr) {

So much nicer!

::: browser/extensions/shumway/content/ShumwayUtils.jsm
@@ +129,5 @@
>  
>      // Remove the contract/component.
>      converterFactory.unregister();
>      overlayConverterFactory.unregister();
> +    Cu.unload('resource://shumway/ShumwayStreamConverter.jsm');

nice
Attachment #8499262 - Flags: review?(till) → review+
https://hg.mozilla.org/mozilla-central/rev/60e90dd7f64f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Blocks: 988624
Blocks: 1097185
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.