Closed Bug 1078904 Opened 5 years ago Closed 5 years ago

[System] Landscape, activity sharing menu buttons truncated by swb

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rnicoletti, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image sharing landscape
In landscape orientation the system activity sharing menu buttons are truncated by the software home button.

STR:

1) Using latest master branch, pply the patch from bug 1055198
2) Install video app

On devices with a hardware home button:
3) 'adb shell setprop ro.moz.has_home_button 0'
4) stop and start b2g

5) Open video app, select video using 'select' button
6) Share video with 'share' button
7) Rotate screen to landscape orientation
Blocks: 1055198
[Blocking Requested - why for this release]: Broken feature.
Blocks: 1077579
blocking-b2g: --- → 2.1?
Note, this seems to be a fullscreen_layout specific problem.
Alberto, can you take a look here? If you are swamped please coordinate with Guillaume on this.
Flags: needinfo?(apastor)
Broken feature
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(apastor)
Whiteboard: [systemsfe]
Assignee: nobody → apastor
Target Milestone: --- → 2.1 S6 (10oct)
Note: this needs to be uplifted after bug 1079525 and bug 1074123, otherwise we will have a merge conflict.
Comment on attachment 8502645 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25006

Thanks for adding the test! Left some comments on github.
Attachment #8502645 - Flags: review?(mhenretty)
Attachment #8502645 - Flags: review?(etienne)
Comment on attachment 8502645 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25006

I couldn't imagine reviewing a patch like this without integration tests now :) Funny how quickly that went. Hope we'll get landscape support soon.

Anyway, r=me with the small comment addressed
Attachment #8502645 - Flags: review?(etienne) → review+
master: https://github.com/mozilla-b2g/gaia/commit/f81d4c5099ebfeed5450b1db9267a01ddabcfa81
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8502645 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25006

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): SHB + fullscreen_layout feature
[User impact] if declined: SHB will overlay the inline activities menu in landscape mode.
[Testing completed]: Added tests for the portrait mode. Unfortunately we can't test landscape yet.
[Risk to taking this patch] (and alternatives if risky): CSS only and tested. Low risk
[String changes made]: -
Attachment #8502645 - Flags: approval-gaia-v2.1?
Keywords: verifyme
Attachment #8502645 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Apparently we cannot test in landscape mode. Should we in-testsuite- this one or is there anything we can do to make it possible?
Flags: needinfo?(kgrandon)
Flags: in-testsuite?
(In reply to Alberto Pastor [:albertopq] from comment #11)
> Apparently we cannot test in landscape mode. Should we in-testsuite- this
> one or is there anything we can do to make it possible?

Hi Alberto. Thanks for investigating. It appears that we have bug 1080309 filed for landscape support. For now, let's mark the dependency and as testsuite-. We can triage testsuite- bugs once we have integration tests done for all of the 2.1+ blockers, and can revisit once support is added. Ideally we want to keep the testsuite- bugs to a minimum though.
Depends on: 1080309
Flags: needinfo?(kgrandon)
Flags: in-testsuite?
Flags: in-testsuite-
Needs a branch patch for v2.1 uplift.
Flags: needinfo?(apastor)
Verified the issue is fixed on 2.2 Master and 2.1 Flame builds

Flame 2.2 KK (319mb Full Flash)
Device: Flame 2.2 Master
BuildID: 20141022040201
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
Device: Flame 2.1 KK (319mb Full Flash)
BuildID: 20141022001201
Gaia: 3d9cc667f4e929861a9a77c41096bbf5a9c1bde0
Gecko: 928b18f7d8ff
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
Addition to comment 15, the bug is fixed, SHB is no longer overlapping the sharing menu buttons in landscape view
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.