Closed Bug 1079525 Opened 5 years ago Closed 5 years ago

[SHB] Power button menu does not cover lockscreen when software home button is enabled

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: AdamA, Assigned: kgrandon)

References

Details

(Whiteboard: [shb-enabled][systemsfe])

Attachments

(3 files)

Attached file logcat
Description:
(Expand upon the Summary - but not a copy of the Summary!)

Prerequisite:
Software home button enabled

Repro Steps:
1) Update a Flame device to BuildID: 20141007040205
2) Lock the phone
3) Hold down the power button while on the lockscreen
4) Observe power button menu
  
Actual:
Power button menu does not cover lockscreen
  
Expected: 
It is expected that the power button menu covers the lock screen
  
Environmental Variables:
Device: Flame 2.2 Master (Full Flash)
BuildID: 20141007040205
Gaia: 83de447d9ae9a59459d7a445f9348a254c661850
Gecko: 9ee9e193fc48
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Repro frequency: 100%
Link to failed test case:
See attached: screenshot, logcat
Probably caused by bug 1064595.
Blocks: 1064595
Broken feature.
blocking-b2g: --- → 2.1+
Whiteboard: [shb-enabled] → [shb-enabled][systemsfe]
Blocks: 1077579
This issue also occurs on 2.1 Flame.

Environmental Variables:
Device: Flame 2.1 (Full Flash)
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
Power button menu does not cover lockscreen
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Taking, and will ensure we have a test for this.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S6 (10oct)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Attached file Github pull request
Mike - are you able to review this?
Attachment #8501366 - Flags: review?(mhenretty)
Comment on attachment 8501366 [details] [review]
Github pull request

Looks good, thanks!
Attachment #8501366 - Flags: review?(mhenretty) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/6af201a1e358e7da4c38e6dd7c8cd57de2ef52fd
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8501366 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): I believe this was caused by SHB feature work.
[User impact] if declined: Bad experience when on the lockscreen and pressing the power button for a SHB device.
[Testing completed]: Manual and integration testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, only a 2-line CSS patch - it's mostly testing.
[String changes made]: None.
Attachment #8501366 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8501366 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Will check on tomorrows nightly build to see if I can verify this bug, so I can then verify bug 1036339
This issue no longer occurs. Marking this as verified fixed on today's Flame 2.1, and Flame 2.2


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Actual Result for verification of comment 12: The power button will cover the full length of the lock screen with software home button enabled as intended.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Integration test added in bug 1077579.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.