[Usage][Cost Control] About 1s regression in showing data usage chart

VERIFIED FIXED in 2.1 S6 (10oct)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: salva, Assigned: salva)

Tracking

unspecified
2.1 S6 (10oct)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(3 attachments)

[Blocking Requested - why for this release]:

Bug 1033549 introduces a lot of data process for per-app data usage which delay chart rendering about 1000ms.

Notice solution for bug 1064491 could solve this issue as well.
triage: significant perf regression.
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → salva
Attaching some videos to prove how the patch for bug 1064491 solves the problem.
Notice how the chart is completely rendered almost immediately after launching the application.
Now notice how the render of chart lines, dots and Y-axis labels are delayed until the application breakdown is completed.
Attachment #8502115 - Attachment description: Usage application in 2.1 → Usage application before bug 1064491 patch in 2.1
Now the chart is rendered earlier before app breakdown.
Solved by bug 1064491 patch.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Marking as fixed in 2.1, as bug bug 1064491 was already uplifted
Verified the issue is fixed on Flame 2.2 and 2.1

The widget is rending earlier than the "Usage" app, however the bug 1080473 still reproduces with incorrect info.

Device: Flame 2.1
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

"Flame 2.2" 

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
You need to log in before you can comment on or make changes to this bug.