Closed Bug 1080020 Opened 8 years ago Closed 8 years ago

[SMS}[Gallery] - Fail to view image while composing message

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1079546
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: pdahiya, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Open SMS app
2. Attach image from gallery to the message
3. Click on attached image and select view

Not able to view image and user is returned back to option menu with View, Remove image and Replace image options.

Error seen in log:
Content JS ERROR: error with open activity ActivityCanceled 
10-08 14:24:07.463 E/Messages( 6628):     at Attachment.prototype.view/activity.onerror (app://sms.gaiamobile.org/js/attachment.js:79:8)
Mmm so maybe for _this_ particular issue we'd need the workaround in bug 1059233 after all... Do you know if you tried with my latest revert of the patch in that bug?
(In reply to Julien Wajsberg [:julienw] (PTO until 7th October, ask :steveck or :azasypkin for SMS stuff) from comment #1)
> Mmm so maybe for _this_ particular issue we'd need the workaround in bug
> 1059233 after all... Do you know if you tried with my latest revert of the
> patch in that bug?

I tried after flashing my device with the reverted patch (latest gaia master) and still sees the view error.
Punam, just to be extra sure, do you see the view error also before I reverted the patch?
(In reply to Julien Wajsberg [:julienw] (PTO until 7th October, ask :steveck or :azasypkin for SMS stuff) from comment #3)
> Punam, just to be extra sure, do you see the view error also before I
> reverted the patch?

That's right I saw this error in today's nightly before you reverted the patch as well. I tried view activity with bluetooth - that is transfer an image by bluetooth and then open it and it works from bluetooth app.
Julien: could the SMS app be sending a memory backed blob to the gallery app? If so, we're doing a slice() on it and dying with the same issue in 1063658.

I'm assuming that your images are actually coming out of an IndexedDB, so they should be file-backed. I've seen a lot of bugs being labelled as regressions caused by bug 994190. I wonder if this could be related.
Flags: needinfo?(felash)
I suppose we should try to reproduce this bug in a nightly build from before 9/29 when 994190 landed again.
Tested with nighly build mozilla-central-flame-kk-eng from 9/28 and gallery successfully loads attached image 09.png without crashing
BuildId:20140928040208

Gallery crash is seen on trying mozilla-central-flame-kk-eng nightly build (BuildId:20140930040206) from 9/30 after bug994190 fix was landed
(In reply to Punam Dahiya from comment #7)
> Tested with nighly build mozilla-central-flame-kk-eng from 9/28 and gallery
> successfully loads attached image 09.png without crashing
> BuildId:20140928040208
> 
> Gallery crash is seen on trying mozilla-central-flame-kk-eng nightly build
> (BuildId:20140930040206) from 9/30 after bug994190 fix was landed

Sorry updated the wrong bug, this comment is for bug 1080090
Here's the regression range for bug 1080020, I am able to view attached image in nighly build (20140928040208) mozilla-central-flame-kk-eng from 9/28 and seeing the view image bug surface in BuildId:20140930040206 from 9/30. This looks like a regression from bug 994190
(In reply to David Flanagan [:djf] from comment #5)
> Julien: could the SMS app be sending a memory backed blob to the gallery
> app? If so, we're doing a slice() on it and dying with the same issue in
> 1063658.
> 
> I'm assuming that your images are actually coming out of an IndexedDB, so
> they should be file-backed. I've seen a lot of bugs being labelled as
> regressions caused by bug 994190. I wonder if this could be related.

Not in this particular case: we just resized it in-memory. But that bug is still probably the issue according to Punam.
Flags: needinfo?(felash)
Duplicate of this bug: 1077667
Migrating smoke test things to here as this has a substantial amount of work on it already.

[Blocking Requested - why for this release]:
Functional Regression of a core feature that fails smoketests.


QAWanted for branch checks to verify this doesn't affect 2.1.
blocking-b2g: --- → 2.2?
QA Contact: pcheng
Issue is NOT reproducible on Flame 2.1 and Flame 2.0.

Observed behavior: Tapping on an attached MMS image and selecting 'View' successfully views the attached image.

Device: Flame (shallow flash)
BuildID: 20141008192207
Gaia: 7e2ef41d3ac98757acaf490b5413fb42061ad3e6
Gecko: 75ebb70f8b38
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame (shallow flash)
BuildID: 20141008192303
Gaia: c1f60895e5bcc6a951f3667c2a1e1bd39d393420
Gecko: 4540201b5da0
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140926154139
Gaia: e30d373eb5ed0514bce08a3b3d80d71b05a4dc32
Gecko: 627e848b2bf3
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140926162338
Gaia: e30d373eb5ed0514bce08a3b3d80d71b05a4dc32
Gecko: 8892214038df
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=627e848b2bf3&tochange=8892214038df

Caused by Bug 994190.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Regression window verifies Punam's comment 9 (Nice job!) 


Broken by Bug 994190 - can you take a look Ben?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(bent.mozilla)
I find it quite strange that you find it doesn't happen on v2.1 and v2.0, given bug 1063658 is not uplifted there yet... NI me to check on my own v2.0 device.
Flags: needinfo?(felash)
This seems to actually work in v2.0. I'm baffled.
Flags: needinfo?(felash)
I know what didn't work in v2.0 before bug 1063658 landed: same STR except we crop the picture to a picture that has a small size.
I'm still seeing this issue occur in the new 2.1 build today: 20141010000201
*************************************************************

ISSUE REPROES in Flame v2.1
Results: Not able to view image and user is returned back to option menu with View, Remove image and Replace image options.

Environmental Variables:
----------------------------------------------
Device: Flame 2.1
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Moving nomination down to 2.1 then.

Pi Wei can you reproduce today with shallow flash? Were you able to reproduce on v2.2 with shallow flash?
blocking-b2g: 2.2? → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(pcheng)
(In reply to Peter Bylenga [:PBylenga] from comment #20)
> [Blocking Requested - why for this release]:
> Moving nomination down to 2.1 then.
> 
> Pi Wei can you reproduce today with shallow flash? Were you able to
> reproduce on v2.2 with shallow flash?

I'm unable to reproduce this bug on 2.1 with shallow flash yesterday and with full flash today. Repro rate: 0/5.

I did see the issue reproduce on 2.2 yesterday with shallow flash. The issue is 100% reproducible on builds that reproduce the bug.

Tested on:
Device: Flame 2.1 (full flash)
BuildID: 20141010064105
Gaia: 883cb6c30f770a8a3aea59e66331d764b5d61307
Gecko: 11656eb0032d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(pcheng)
Keywords: smoketest
Keywords: smoketest
I am able to successfully choose an image in messages and attach it into a MMS message just fine.  So no repro here.  given the churn in hard to reproduce, will be un-nominating this until we can get consistent reproduction.

wfm on: 
Gaia-Rev        bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/72c13d8631ff
Build-ID        20141010000201
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141010.033933
FW-Date         Fri Oct 10 03:39:44 EDT 2014
Bootloader      L1TC00011840
blocking-b2g: 2.1? → -
Keywords: smoketest
Tony, the issue will likely only happen if the image is small enough so that it's not resized inside the SMS app.
Flags: needinfo?(tchung)
(In reply to Julien Wajsberg [:julienw] from comment #23)
> Tony, the issue will likely only happen if the image is small enough so that
> it's not resized inside the SMS app.

hey julien, can you attach the test image to this bug?  that way those of us trying to reproduce can at least give it another try.   because i tried retesting again on today's 2.1 full flash build, with a small image thats only 110x62 sized jpg, and its not resizing, yet still seems to view as expected.

see screencast: http://youtu.be/AfguPoGJLmw
Flags: needinfo?(tchung)
Better ask Pi Wei or Punam (I haven't really tried myself yet).
Flags: needinfo?(pdahiya)
Flags: needinfo?(pcheng)
Oliver and I tested this issue again on 2.1 and confirmed that the issue is NOT reproducible on 2.1.

I imitated all the environments on comment 19 with images he used and we cannot reproduce the issue on 2.1.

Tested on:
Device: Flame 2.1 (319MB, full flash)
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

----------

Comment 23 suggests a smaller sized image would trigger the issue which is not true in this case, and opposite to that - on 2.2 with a smaller sized image the issue would NOT repro.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(pcheng)
Putting triage tag back.
QA Whiteboard: [QAnalyst-Triage+]
If this is reproducible on 2.2 we need a video and the file used to reproduce the issue attached.
Flags: needinfo?(pcheng)
(In reply to Peter Bylenga [:PBylenga] from comment #28)
> If this is reproducible on 2.2 we need a video and the file used to
> reproduce the issue attached.

Image used to reproduce the bug attached.

Video URL:

http://youtu.be/VsatovsWe_Q

Tested on:
Device: Flame 2.2 Master (full flash)
BuildID: 20141011132225
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(pcheng)
blocking-b2g: - → 2.2?
(In reply to Tony Chung [:tchung] from comment #24)
> (In reply to Julien Wajsberg [:julienw] from comment #23)
> > Tony, the issue will likely only happen if the image is small enough so that
> > it's not resized inside the SMS app.
> 
> hey julien, can you attach the test image to this bug?  that way those of us
> trying to reproduce can at least give it another try.   because i tried
> retesting again on today's 2.1 full flash build, with a small image thats
> only 110x62 sized jpg, and its not resizing, yet still seems to view as
> expected.
> 
> see screencast: http://youtu.be/AfguPoGJLmw

This issue can be reproduced in 2.2 with any image taken with Flame camera and using steps in #comment0. I cannot reproduce this issue in 2.1.
Flags: needinfo?(pdahiya)
I think bug 1082226 is another symptom.
Blocks: 1080169
Can you please test again now that bug 1079546 has landed?
Flags: needinfo?(bent.mozilla)
QA-Wanted to recheck on the latest 2.2
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
QA Contact: pcheng
This issue is no longer reproducible on latest Flame central. I was able to 'View' the image attached while composing an MMS.

Repro rate: 0/10. Tried with 10 different images taken from Flame, including the image attached at comment 29.

Device: Flame 2.2 Master (shallow flash, 319MB mem)
BuildID: 20141017073248
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 51892b39597a
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Sweet, thanks. Fixed by bug 1079546.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Thanks a lot Ben !
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1079546
Hi David, this feature apparently broke even though TBPL remained completely green. Can you find resources to get integration tests added for this so that we don't break you again?
Flags: needinfo?(dscravaglieri)
Is it fixed with bug 1079546 ?
Flags: needinfo?(dscravaglieri) → needinfo?(bent.mozilla)
This case should be handled in bug 1080122
Yep, bug 1080122 should handle tests here.
Flags: needinfo?(bent.mozilla)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.