[Call Log] Call log is not updated when user delete contact

RESOLVED DUPLICATE of bug 976990

Status

Firefox OS
Gaia::Dialer
--
major
RESOLVED DUPLICATE of bug 976990
4 years ago
3 years ago

People

(Reporter: promise09th, Assigned: thills)

Tracking

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [LibGLA,TD96263,WW,B][planned-sprint c=3][partner-blocker])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
1. Title : Call log is not updated when user delete contact
2. Precondition : Call logs exist
3. Tester's Action : 
 1) Enter call log
 2) Long-press 2nd call log list (when you use 1st call log list, issue is not reproduced)
 3) Select add contact
 4) Save contact
 5) Home
 6) Enter contact
 7) Delete contact
 8) Back to Home and enter call log
4. Detailed Symptom : Call log is not updated
5. Expected : Call log is updated normally
6. Reproducibility: Y
1) Frequency Rate : 80%
7. Mozilla Flame : Reproduce (v2.0)
8. Gaia revision : 9725d188
(Reporter)

Updated

4 years ago
Whiteboard: [LibGLA,TD96263,WW,B]
(Reporter)

Comment 1

4 years ago
Created attachment 8505433 [details]
Bug_1083124.3gp
Confirmed on master using the STR from comment 0.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Per comment 0 and 2.
status-b2g-v2.0: --- → affected
status-b2g-v2.2: --- → affected
Gabriele, could this be related to bug 1081463?
Flags: needinfo?(gsvelto)
Hi Anthony, not sure of Gabriele is occupied...

Could you please kindly help look into or find someone on this issue?

This issue is reproducible on 2.1 and master as well. It's a generic bug.

Thank you very much !!
status-b2g-v2.1: --- → affected
Flags: needinfo?(anthony)
I'll let Gabriele take care of this.
Flags: needinfo?(anthony)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> Gabriele, could this be related to bug 1081463?

I'm not sure. I've still got a couple of major issues on my plate but I'll try to have a look. Worst case we'll triage and assign this on Thursday.

To the reporter, if this is important remember to flag it as 2.0? so that it will be triaged appropriately.
Flags: needinfo?(gsvelto) → needinfo?(promise09th)
(Reporter)

Comment 8

4 years ago
Dear Gabriele Svelto

Our QE team find this issue. So, I think this is important issue and should fix it

Thank you
Flags: needinfo?(promise09th)
[Blocking Requested - why for this release]:

Set it to 2.0? For triage.
blocking-b2g: --- → 2.0?
Assignee: nobody → drs.bugzilla
Target Milestone: --- → 2.1 S7 (24Oct)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> Gabriele, could this be related to bug 1081463?

No, I strongly believe that these are completely unrelated. Though I don't have any evidence yet.

I also don't think this is a regression, though I'm less sure about that. I don't think we ever handled this correctly.

qawanted for checks on v1.4.
Keywords: qawanted
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #10)
> qawanted for checks on v1.4.

Issue is reproducible on Flame v165 base image (v1.4).

Following STR at comment 0, the deleted contact still displays a name in call log. But if I kill the Dialer/Phone app via card view and relaunch then call log is correctly updated to show only the phone number. This behavior is the same as on v188 base image (v2.0).
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
Flags: needinfo?(jmercado)
Keywords: qawanted
Flags: needinfo?(jmercado) → needinfo?(ktucker)
(In reply to Pi Wei Cheng [:piwei] from comment #11)
> (In reply to Doug Sherk (:drs) (use needinfo?) from comment #10)
> > qawanted for checks on v1.4.
> 
> Issue is reproducible on Flame v165 base image (v1.4).
> 
> Following STR at comment 0, the deleted contact still displays a name in
> call log. But if I kill the Dialer/Phone app via card view and relaunch then
> call log is correctly updated to show only the phone number. This behavior
> is the same as on v188 base image (v2.0).

Thanks. In this case, I'm pretty confident in saying that this isn't a regression. I think we just never handled this correctly.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [LibGLA,TD96263,WW,B] → [LibGLA,TD96263,WW,B][planned-sprint c=]
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
Whiteboard: [LibGLA,TD96263,WW,B][planned-sprint c=] → [LibGLA,TD96263,WW,B][planned-sprint c=][partner-blocker]
Whiteboard: [LibGLA,TD96263,WW,B][planned-sprint c=][partner-blocker] → [LibGLA,TD96263,WW,B][planned-sprint c=3][partner-blocker]
Assignee: drs.bugzilla → thills

Updated

4 years ago
Blocks: 1054172
status-b2g-v2.0M: --- → affected
[Blocking Requested - why for this release]:
Per comment 12, this bug happened from 1.4, and still exits on 2.0, 2.1 and 2.2.
nominate the bug to 2.1? 
Thank you very much!!
blocking-b2g: 2.0? → 2.1?
Flags: needinfo?(bbajaj)
Triage: It doesn't really make sense to block 2.1 if 2.0 still have this issue (and if we shipped 1.4 with it). This is a bad bug that need to be fixed in the next releases.
blocking-b2g: 2.1? → backlog
Sounds like bug 976990.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976990
(In reply to Anthony Ricaud (:rik) from comment #15)
> Sounds like bug 976990.
> 
> *** This bug has been marked as a duplicate of bug 976990 ***

Agree we do not need to block here, but this should be prioritize to fix. I'll track the other bug so the dialer team and fix it in 2.2
Flags: needinfo?(bbajaj)
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.