Ship engineer builds with right dev/stage builds

VERIFIED FIXED

Status

Firefox OS
Gaia
--
blocker
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: krupa, Assigned: clouserw)

Tracking

({qablocker})

unspecified
All
Gonk (Firefox OS)
qablocker
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

User Story

Impacts:
- contributing (non-employee) devs and testers
- mozilla employee devs and testers
- qa leads and managers
- automation test engineers

Takes 45-60 minutes a day to set up my daily build in order to continue my testing.

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Engineering builds ship with marketplace dev/stage apps installed by default.

However, these apps are really really old and updating them doesn't work. These apps cannot be deleted which means we are pretty much being forced to use user builds. This also blocks our automation efforts using marionette.

We need to uplift the right dev/stage versions to all gaia eng versions (2.2 to 1.1)

verified on:
Platform version: 36.0a1
Build Identifier: 2014105040201
Git commit info: 2014-10-14 16:11:51 5f1f0960

what needs to happen?
We need to have eng builds shipping with the latest builds from
dev: https://marketplace.firefox.com/app/dev
stage: https://marketplace.firefox.com/app/marketplace-6

This needs to be uplifted to older versions of gaia since the marketplace team tests on 1.1, 1.3, 1.4, 2.0 and 2.1

I'm marking this a blocker since it is blocking our QA.
(Assignee)

Comment 1

4 years ago
Why are your dev and stage links on production?  The dev and stage apps are automatically updated on the dev and stage sites...

https://marketplace-dev.allizom.org/app/marketplace
https://marketplace.allizom.org/app/marketplace
(Reporter)

Comment 2

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #1)
> Why are your dev and stage links on production?  The dev and stage apps are
> automatically updated on the dev and stage sites...
> 
> https://marketplace-dev.allizom.org/app/marketplace
> https://marketplace.allizom.org/app/marketplace

https://bugzilla.mozilla.org/show_bug.cgi?id=1059546 means that on gaia versions older than 2.2 will require the pref change. That is why I linked to the prod versions. Being iframed, it is not a big deal.
See Also: → bug 1079266
Keywords: qablocker
(Reporter)

Comment 3

4 years ago
When this patch lands we need a way to uplift it to older versions of gaia eng builds. Any ideas on how to update the dev_apps cleanly on older versions of gaia? Thanks!
Flags: needinfo?(poirot.alex)
Flags: needinfo?(poirot.alex) → needinfo?(ricky060709)
(Assignee)

Comment 4

4 years ago
Final URLs:

https://marketplace.firefox.com/app/mkt-dev/
https://marketplace.firefox.com/app/mkt-stage/

And here is a pull request putting them in Gaia's master:

https://github.com/mozilla-b2g/gaia/pull/25231

I'd like to see if the tests pass, but I think it also needs review from someone who either knows manifests or can actually build gaia and test it.  I changed the origins and installOrigins and I'm not sure if that's how they should look in the metadata file.
(Assignee)

Comment 5

4 years ago
Oh, the PR also makes the packages removable
I pinged Fabrice in IRC about getting a patch uplifted to ancient branches like 1.3 and 1.4; he suggested simply landing the patch & requesting uplift.

So, I'll try to apply this patch on master, as a starting point, and we'll figure out who the right reviewer should be.

For future reference, Wil, the process for attaching a github gaia pull request to bugzilla is documented at http://globau.wordpress.com/2013/10/21/github-pull-requests-and-bugzilla/
Created attachment 8506308 [details] [review]
Github PR 25231 by :clouserw
Flashing onto device, I see:

> System JS : ERROR resource://gre/modules/commonjs/toolkit/loader.js -> file:///Users/jhirsch/codez/github/mozilla-b2g-gaia/build/webapp-manifests.js:194 - Error: We got 2 manifest errors while building:
> * External webapp `marketplace-dev.allizom.org` can not have origin in metadata because is packaged
> * External webapp `marketplace.allizom.org` can not have origin in metadata because is packaged

I also see a ton of broken tests due to the same error: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=1e13b06793f9

Maybe tweak the manifest a bit and try flashing on device locally, then resubmit when it seems to be working.
Flags: needinfo?(clouserw)
Flags: needinfo?(ricky060709)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8506308 [details] [review]
Github PR 25231 by :clouserw

Looking for r?fabrice.  Latest patch is green across the board except it has two timeouts on Gij: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=d9f3c2dd0933

Not sure if there is more I can do?
Flags: needinfo?(clouserw)
Attachment #8506308 - Flags: review?(fabrice)
Blocks: 1020536
Tony

Who in Gaia needs to look at this so we can land? We're looking to eliminate this 40-60 minutes of downtime every day for testers and devs in our ecosystem. I know some folks can flash and configure new bugs super fast (30 min), but many of our contributing devs and testers do not have the same prowess and skill. 

This will greatly help them.
Who can help us land / move forward?
Lots of testing right now in Firefox Accounts, Marketplace and Apps with our Tier 1 partners.
feature-b2g: --- → 2.2?
User Story: (updated)
Flags: needinfo?(tchung)
I'm assuming you're asking who will approve uplifting?  if so:
- trunk (2.2 now), doesnt require any approval.  just land on m-c
- (2.0 and 2.1), request blocking 2.0? and set flag: status-b2g-v2.1:=? and status-b2g-v2.0=?.   ask for approval
- (1.4 and behind), i'm not sure.  you'll have to loop in all the different TAMs on eahch release because they manage all the partner expectations since it's their branch.  But given these are already production releases, why do you need even want these stage and dev apps to go into production?
Flags: needinfo?(tchung)
krupa - 
can you address Tony's second question?
my assumption is that because 70% of our users are still on 1.1 we are still actively testing there.
Flags: needinfo?(kraj)
(Reporter)

Comment 13

4 years ago
Tony,

Since marketplace is an iframed app right now, whatever changes we push every week goes to all of our existing users. This means that it is paramount that we don't break functionality on older versions of gaia given that most of our real world users are on 1.1 or 1.3. This will still be true when we move to a fully packaged app since marketplace can update itself.

Having 1.1, 1.3 and 1.4 engineer builds with dev, stage installed would be awesome. However, I'd at least like to get them shipping on 2.0+ builds asap.
(Assignee)

Comment 14

4 years ago
The patch above is for master.  I'm asking fabrice for approval because the tests are flaky (Gij failed 66% of the time above).  He's familiar with the situation so he'll know what to do if it lands and breaks tests again even though I don't think it will.

For older versions we'll need to make new patches for each version, which we can do, but I wanted to get this landed on master first.
Attachment #8506308 - Flags: review?(fabrice) → review+
https://github.com/mozilla-b2g/gaia/commit/3536e6038212f9c5dc08a763ed6555494f24e38b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I hate to be the bearer of bad news, but I just flashed to the latest m-c engineering build on my Flame and I am still having the issue where, when I start Marketplace-dev it just remains on the splash screen (with the shopping bag and loading dots) forever. The same thing happens with Marketplace-stage, ftr, but Marketplace-prod works fine.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

4 years ago
Flags: needinfo?(kraj)
(Assignee)

Comment 17

4 years ago
Is there more for me to do in this bug, Krupa?
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 18

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #17)
> Is there more for me to do in this bug, Krupa?

Clouser, we need to get your patch uplifted to older versions of gaia. I will check why the patch isn't working on central tomorrow.
Flags: needinfo?(krupa.mozbugs)
(Assignee)

Comment 19

4 years ago
Ok, happy to do that tomorrow.  Would you let me know which versions you want?  Thanks.  Or ... let's figure out the problem on central first and then I'll make patches.
Assignee: nobody → clouserw
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1079266
(Assignee)

Comment 21

4 years ago
Krupa: let me know if there is more for me to do here
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 22

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #21)
> Krupa: let me know if there is more for me to do here


Clouser, we still need to get your patch uplifted to older versions of gaia.
Flags: needinfo?(krupa.mozbugs)
Component: Gaia::Build → Gaia
(Reporter)

Comment 23

4 years ago
To clarify, we want the package currently on master to be also on 2.1, 2.0, and 1.4. Thanks!
(Assignee)

Comment 24

4 years ago
Created attachment 8524828 [details] [review]
Add to 1.4
Attachment #8524828 - Flags: review?(fabrice)
(Assignee)

Comment 25

4 years ago
Created attachment 8524829 [details] [review]
Add to 2.0
Attachment #8524829 - Flags: review?(fabrice)
(Assignee)

Comment 26

4 years ago
Created attachment 8524830 [details] [review]
Add to 2.1
Attachment #8524830 - Flags: review?(fabrice)
(Assignee)

Comment 27

4 years ago
2.0 had one failed test but subsequent re-tests show it passing so that patch seems good.  The other two have more failures than I've seen.  Judging from the lack of output, maybe the testing is disabled and they simply are failing to start?  We are talking about older versions so that would be reasonable.
Attachment #8524828 - Flags: review?(fabrice) → review+
Attachment #8524829 - Flags: review?(fabrice) → review+
Attachment #8524830 - Flags: review?(fabrice)
Attachment #8524830 - Flags: review+
Attachment #8524830 - Flags: approval-gaia-v2.1+
Attachment #8524829 - Flags: approval-gaia-v2.0+
Attachment #8524828 - Flags: approval-gaia-v1.4+
Setting the tracking flags so this gets out of the needs-uplift list. Please correct this if I misread the status here.
status-b2g-v1.4: --- → fixed
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
(Reporter)

Comment 30

3 years ago
2.0 now has the latest marketplace builds. Thanks everyone!
Status: RESOLVED → VERIFIED
Blocks: 1109048

Comment 31

3 years ago
Looks like 2.2 includes this as well.
feature-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.