fennec tab casting is broken in beta

RESOLVED FIXED in Firefox 34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: blassey, Assigned: blassey)

Tracking

unspecified
mozilla36
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34+ fixed, firefox35+ fixed, firefox36+ fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Splitting out tab mirroring work from bug 1054959
Summary: Add the abbility to mirror tabs from desktop to a second screen → Add the ability to mirror tabs from desktop to a second screen
Posted patch mirror.patch (obsolete) — Splinter Review
this works, needs clean up though. A UX design as well.
Assignee: nobody → blassey.bugs
Darrin, this patch is currently adding a "Mirror tab" item to the tools menu. It then pops up a select box. I'd like to propose doing what we did in bug 1054959 and just list the available devices in a sub menu.
Flags: needinfo?(dhenein)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> It then pops up a select box. I'd like to propose doing what we did in
> bug 1054959 and just list the available devices in a sub menu.

This sounds like a reasonable interaction, and conforms to what we decided to do elsewhere. Sounds like the right decision to me :)
Flags: needinfo?(dhenein)
The browser constraint gets scrubbed out in GetUserMedia() if it isn't called from a privileged context. So, this will only add the browser video source if the browser type is specified in constraints and GuM is called from chrome code.
Attachment #8509073 - Flags: review?(rjesup)
Comment on attachment 8509073 [details] [diff] [review]
browser_source_type.patch

This patch along with the patches for bug 1053426, bug 1080012, and bug 1080701
is required to fix tab mirror from fennec to chromecast. I have tested all four patches applied beta and verified that they fix the feature.
Attachment #8509073 - Flags: review?(rjesup) → review+
Comment on attachment 8509073 [details] [diff] [review]
browser_source_type.patch

Approval Request Comment
[Feature/regressing bug #]: no regression
[User impact if declined]: tab streaming to roku broken on beta for fennec
[Describe test coverage new/current, TBPL]: none
[Risks and why]: low risk
[String/UUID change made/needed]: none

Unrelated to this bug, the Fennec tab streaming feature works fine in aurora and nightly because mHasTabVideoSource is true due to Fennec having UI for selecting a tab to stream for content. That UI is restricted to Nightly and Aurora, so when that feature moved up to Beta it mysteriously didn't work. This will fix that.
Attachment #8509073 - Flags: approval-mozilla-beta?
Attachment #8509073 - Flags: approval-mozilla-aurora?
Adding leave-open because I just pushed the platform patch to fx-team, but we still need the frontend patch as well.
Keywords: leave-open
Hrm, the fact that we're still not done with string changes is concerning.

The string surely can use a comment on what "Mirror" means. Like, it's not some RTL thing, for example.
Keywords: late-l10n
Tracking while we wait to approve for l10n and m-c landing.
Comment on attachment 8509073 [details] [diff] [review]
browser_source_type.patch

Approving for Aurora while there's still time for l10n.  I was under the impression this feature is targeted at 35 so leaving the beta approval until there's confirmation of the intent here.
Attachment #8509073 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
We're not planning to uplift the desktop front-end patch, as far as I know.

It's confusing that two separate patches were put in the same bug. The "browser_source_type" patch has no l10n impact and wants to be uplifted for Fennec, apparently.
Keywords: late-l10n
Comment on attachment 8509069 [details] [diff] [review]
mirror.patch

Can you just move this patch to another bug, actually, given this bug's tracking flags and such?
Attachment #8509069 - Attachment is obsolete: true
Attachment #8509069 - Flags: review?(gavin.sharp)
Component: General → WebRTC
Product: Firefox → Core
Summary: Add the ability to mirror tabs from desktop to a second screen → tab casting is broken in beta
Target Milestone: Firefox 36 → ---
Summary: tab casting is broken in beta → fennec tab casting is broken in beta
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8509073 [details] [diff] [review]
browser_source_type.patch

Beta+
Attachment #8509073 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.