Closed Bug 1088126 Opened 8 years ago Closed 8 years ago

[e10s] Context Menu displays all possible Menu Entries after dragging tab out of window

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Iteration:
39.1 - 9 Mar
Tracking Status
e10s m6+ ---

People

(Reporter: martin, Assigned: mossop)

References

Details

Attachments

(1 file)

Story:
Clean Profile
Start Session, open multiple tabs (I used www.heise.de and its children)
Drag one Tab from the primary window.
New Window gets created
Context Menu of new tab in new window shows all possible menu items.

Expected behavior:
Show applicable context menus

Reproducible: Always on this build ID

BuildID
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141022030202 CSet: 88adcf8fef83

Follow Up to bug 1012784 
May be related bug 1060070

Attachments:
Firefox Contextmenu Bug before dragging to new window (correct).png
Correct Attachment Name: Firefox Contextmenu Bug before & after dragging tab to new window.png
tracking-e10s: --- → ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 818307
Sorry wrong bug should have been bug 1012784
Blocks: 1012784
No longer blocks: 818307
No longer blocks: 1012784
Depends on: 1012784
Neil, is this fixed by bug 1060529?
Flags: needinfo?(enndeakin)
No, this is due to the error:

JavaScript error: resource://gre/modules/BrowserUtils.jsm, line 95: TypeError: elt.syncHandler is null

Presumably, that field isn't being copied over when switching to a window.
Flags: needinfo?(enndeakin)
Duplicate of this bug: 1097208
Flags: firefox-backlog+
Blocks: 1134375
Going to fix this with a patch in bug 1087966
Assignee: nobody → dtownsend
Depends on: 1087966
Fixed by bug 1087966
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Iteration: --- → 39.1 - 9 Mar
Flags: qe-verify?
This will be verified in bug 1087966.
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.