Closed Bug 1097208 Opened 8 years ago Closed 8 years ago

After dragging an e10s tab out of its original window, the right click menu has too many items

Categories

(Firefox :: Untriaged, defect)

36 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1088126

People

(Reporter: mwc, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141107030202

Steps to reproduce:

Launch a new Firefox Nightly instance.  I'm on 36.0a1 (2014-11-07).  e10s is enabled since yesterday, and I never saw this issue until today, so I suspect e10s is involved.  Desktop recording attached.

Navigate to a site (mozilla.org in my example video).

Open a new tab and navigate to a site in the new tab (mozilla.org in my example video).

Right click and note the number of items in the right-click menu (9 for me, but this can change with installed extensions).

Click on the new tab's tab handle and drag it out of the window (this moves the tab into a new Firefox window).

Right click in the new window.


Actual results:

The right click menu in the new window has way more entries than the one in the original window.  I haven't counted, but it's at least 50.  It looks like every possible context-sensitive right-click menu item is there (Save Audio Snapshot, for example).


Expected results:

The right click menu in both windows should be the same.
I just noticed that the new window also doesn't have the URL bar populated with "mozilla.org".  It's blank.  I'm happy to open a separate BZ for that if desired.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088126
You need to log in before you can comment on or make changes to this bug.