Thunderbird does not recognize additional email from address book as known email address

NEW
Unassigned

Status

4 years ago
2 hours ago

People

(Reporter: jan_janousek, Unassigned, NeedInfo)

Tracking

({regression})

31 Branch
x86
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB30])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8510863 [details]
contact-and-message.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

1. Have a contact with the Additional Email set (see the contact.png image from the contact-and-message.zip attachment).
2. Receive an e-mail from this Additional Email.


Actual results:

The From field (within the message pane) shows a white star with the "Add to Address Book" alternate text (see the message.png image from the contact-and-message.zip attachment) - Thunderbird does not recognize the From e-mail address (Additional Email) as known.


Expected results:

The From field (within the message pane) should show a yellow star with the "Edit Contact" alternate text - Thunderbird should recognize the From e-mail address (Additional Email) as known.

Comment 1

4 years ago
Confirmed, I see this too. Aceman, any ideas?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(acelists)

Comment 2

4 years ago
I only notice this if the "additional email" was added during that session of Thunderbird. Restarting Thunderbird mostly fixes things, but the thread pane's version of that email's display name isn't updated to use the address book entry.

Comment 3

4 years ago
I'm shocked this hasn't been reported before.  Is this a regression?


(In reply to Jim Porter (:squib) from comment #2)
> I only notice this if the "additional email" was added during that session
> of Thunderbird. Restarting Thunderbird mostly fixes things, but the thread
> pane's version of that email's display name isn't updated to use the address
> book entry.

This sound familiar to me. But I'm not seeing it this way.

Comment 4

3 years ago
This also breaks contact photos in Thunderbird conversations. If I set a contact photo, but I get an email from the "additional email" address, then the contact photo is shown as not set.

Comment 5

2 years ago
this affects Linux as well.

this issue survives restarts for me.

in addition to other symptoms reported, this results in not respecting of the "Always prefer display name over message header" preference. this is actually the biggest reason I noticed this, and a total pain -- I have a contact who has their "From:" name set incorrectly for one of their accounts in their e-mail client, so e-mails coming from this contact often show as coming from someone else :-/

it occurs to me that this may also result in the "Prefers to receive messages formatted as:" not being respected as well, although I have not confirmed that as an additional symptom.

Comment 7

2 years ago
I'd suspect a comm-central regression. https://hg.mozilla.org/comm-central/pushloghtml?startdate=2014-02-27+08%3A05%3A00&enddate=2014-02-28+09%3A05%3A00 would point to bug 129393.
Keywords: regression
Whiteboard: [regression:TB30]

Comment 8

a year ago
I have the same issue, noticed it only after installing contact photos.
Restarting doesn't seem to fix it. Really annoying!
Paul

Comment 9

2 hours ago
> Actual results:
> The From field […] shows a white star
> Thunderbird does not recognize the From e-mail address (Additional Email) as known.

I'll note this here, as I suspect it is the same bug ?

Filters with [email@address - is in my address book] only search within the primary addresses, i.e. they don't treat "additional email" as being in the AB.
You need to log in before you can comment on or make changes to this bug.