Closed Bug 1089188 Opened 5 years ago Closed 5 years ago

Printing on Windows 10 prints blank pages between tech preview 9860 and 9926

Categories

(Core :: Printing: Output, defect)

35 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Iteration:
35.2

People

(Reporter: pt.gildersleve, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.4; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141025004002

Steps to reproduce:

Tried other browsers to check if printer was at fault, then tried Firefox again


Actual results:

Printers worked with other browsers, but still produced blank pages with firefox


Expected results:

printed pages
Severity: normal → critical
Iteration: --- → 35.2
OS: Windows NT → Windows 10
I tested myself with Aurora, no issue to print with PDF Creator.

Does the print preview work?
Could you test with a clean profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Severity: critical → normal
Flags: needinfo?(pt.gildersleve)
preview works but still print blank pages, I have tried a blank profile with no change, I can print from opera and ie but not firefox
Flags: needinfo?(pt.gildersleve)
Could you try to reset the variables print.print_printer & print_printer  in about:config, please.
In addition, could you lower the values of the margins in the Firefox print setup.
Component: Untriaged → Printing: Output
Product: Firefox → Core
These were the first things I tried with no joy
Have you tried nightly and/or release? Have you tried other printers, or is it just generally broken?
Flags: needinfo?(pt.gildersleve)
Summary: printing blank pages → Printing blank pages on Windows 10
does not like epson or samsung (both on network) no joy with standard release or nightly, both using clean installs
Flags: needinfo?(pt.gildersleve)
It sounds like (network?) printing on Windows 10 is just dead in the water.

Blair, didn't you have windows 10 set up? Do you have a tree-destroying-machine, err, I mean printer - and does it work? :-)
Flags: needinfo?(bmcbride)
other browsers and normal documents from word etc, work fine with my tree kllers
(In reply to :Gijs Kruitbosch from comment #7)
> It sounds like (network?) printing on Windows 10 is just dead in the water.
> 
> Blair, didn't you have windows 10 set up? Do you have a
> tree-destroying-machine, err, I mean printer - and does it work? :-)

Yes and yes and yes (and its even a network printer). However, I dismantled my office today and I'm at a conference tomorrow. So I'll look into this next week.
I can support everything P.T.G. has indicated.  Printing on a networked Xerox ColorQube is failing, but ONLY on Mozilla apps.  Here's my original post on the forums:

Doing the Win10 Beta (WAY better than the Win8 fiasco), and things were going well until a mandatory update ~14-20 days ago. Since then, I am able to successfully print in every application except FFox & TBird. The printer goes, pulls the correct number of pages, but it prints blank sheets. Copy that same content into Word (from TBird), and prints perfect. Open that same page in Chrome, and prints perfect.

So basically, it's not a Network Printing error, and it's not a system-wide issue - it's Mozilla-specific.
(In reply to Blair McBride [:Unfocused] from comment #9)
> (In reply to :Gijs Kruitbosch from comment #7)
> > It sounds like (network?) printing on Windows 10 is just dead in the water.
> > 
> > Blair, didn't you have windows 10 set up? Do you have a
> > tree-destroying-machine, err, I mean printer - and does it work? :-)
> 
> Yes and yes and yes (and its even a network printer). However, I dismantled
> my office today and I'm at a conference tomorrow. So I'll look into this
> next week.

It now sounds like this is a recent regression (see also: bug 1100156) - maybe you have a build that still worked?
Confirmed on Windows 10 Build 9879.  This is not just a network printer issue: even printing to a file results in blank pages.
I have same issue, only blank pages when printing from firefox using windows 10.

I have tried both network and usb printer from two different computers and two different model printers.
Everything prints fine from internet explorer. 
I reinstalled firefox.
I removed all old firefox components.
I reset firefox printer settings.
No matter what, I cannot print from firefox anything but blank pages.  everything works fine from other browsers.
Also reported on Microsoft website 

http://answers.microsoft.com/en-us/windows/forum/windows_tp-performance/anyone-having-a-problem-printing-from-firefox-in/b05be085-d36f-426f-9224-fe36f8f55af0
Confirmed on build 9879 with Thunderbird 31.2.0.  I tried troubleshooting blank pages from previous builds that had this issue, no avail.  I tried reinstalling, making a new profile, no dice.  Printing from Thunderbird to Adobe Acrobat Pro XI also builds blank PDF.
I can confirm this issue also with Windows 10 build 9879 with Firefox and Thunderbird. I tried printing to physical printers (network - IP, network - Windows printer server, and direct attached), virtual XPS and PDF printers (Microsoft XPS, PDF Forge printer, and Infix PDF) - every printer prints blank pages.
Hi, same here ^^. Firefox & Thunderbird. Please all vote upstair for the importance of the bug !
Windows 10 hasn't been released yet, so don't expect a bugfix before the final release in a few months.
Duplicate of this bug: 1089372
(In reply to Loic from comment #19)
> Windows 10 hasn't been released yet, so don't expect a bugfix before the
> final release in a few months.

It is not an excuse I reported two months ago and it is a fairly large problem.
Rumor has it that Microsoft modified something in the spooler and is refusing to provide information on what that change is.  Since it's not yet a commercial release, there is no anti-trust action that can occur.  Anyone doing Tech Preview isn't going to be dumb enough to downgrade to MSIE - but clearly MS and Google are in bed together, since Chrome printing DOES work.

This whole thing is just really shady.
Blocks: windows-10
I just want to remind, that exact same problem existed in FF on Windows 8, while all other browsers worked properly. You gonna keep telling us, that this is Windows problem?
(In reply to Monkeyman from comment #26)
> I just want to remind, that exact same problem existed in FF on Windows 8

Can you provide more details? Printing on Windows 8 works. Do you know the bug number where the windows 8 issue was tracked?


More generally: please let's keep the discussion here civil and constructive.

Yes, we should fix this issue once we know what the problem is, and that it's Firefox's issue rather than Windows'.

Right now, we don't know what (or in whose code) the problem is, because nobody in this bug has actually debugged this or figured out why it's working for some people and not others.

Windows 10 does not have a public consumer release date that I can find, and the best we have are rumours for 2015Q2. We should obviously ensure this issue is fixed before then, but that requires figuring out what the problem is first, which requires looking at it, which nobody has done yet.

So unless you have additional data to provide regarding what exactly is going wrong here (ie, can answer some of the questions implied by the above), please refrain from commenting on this bug.
Duplicate of this bug: 1108375
I just finished installing Windows 10 Tech Preview 64-bit, build 9841 (which is what http://windows.microsoft.com/en-us/windows/preview-iso gave me) in a VM, and printing to my networked printer as well as Windows' XPS document writer works without a hitch (tried on the Firefox getting started page because that was the first thing that came up). :-\

Going through windows update now to see if that gets me a newer build that does break printing.
(In reply to :Gijs Kruitbosch from comment #33)
> I just finished installing Windows 10 Tech Preview 64-bit, build 9841 (which
> is what http://windows.microsoft.com/en-us/windows/preview-iso gave me) in a
> VM, and printing to my networked printer as well as Windows' XPS document
> writer works without a hitch (tried on the Firefox getting started page
> because that was the first thing that came up). :-\
> 
> Going through windows update now to see if that gets me a newer build that
> does break printing.

When I did manage to update to 9879 (by downloading the iso that http://windows.microsoft.com/en-us/windows/preview-iso-update?os=win10 gives you, because ugh...), that did indeed break printing, "even" using the Windows' XPS document writer. I will try to investigate this more in the near future, but considering a windows preview update broke the same copy of Firefox that was on both builds, I'm not sure how far I'll get.

(In reply to Monkeyman from comment #31)
> (In reply to Gijs Kruitbosch from comment #30)
> > Can you provide more details? Printing on Windows 8 works. Do you know the
> > bug number where the windows 8 issue was tracked?
> 
> If course, not. I just saw several bug reports, while looking for solution
> in Google. Exact same problem existed in Windows 8, but was fixed. Maybe the
> source of it was different, but the issue itself was the same.

There was an issue a while back with PDFs that printed blank pages, which was a Firefox bug (unrelated to OSes). Did you see other reports (especially in bugzilla), and if so, can you point to them?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(bmcbride)
Summary: Printing blank pages on Windows 10 → Printing on Windows 10 prints blank pages on tech preview 9860 and later
Does this the bug I reported in October will be looked, we could have told that update to preview kills printing if you just asked.
I can confirm that Firefox Nightly has been printing blank pages on Windows 10 build 9879 for months.
So I've spent all morning looking at this, without getting much of anywhere.

No errors/warnings/assertions about this are reported on debug builds that I can see.
No errors are reported internally when stepping through the code in a debugger - internally, everything seems to work just as it should.
The Windows Print Service and other Windows logs in the event viewer show no errors at all, and exactly the same information logs that show up for printing the same web page from e.g. IE (minus minor details like the job number and the size of the job - the resulting XPS files are much smaller on Firefox because they're blank, but that's all I got out of that).
Earlier versions, even up to Firefox 4, have exactly the same issue, so I can't narrow down where the problem is by finding a regression range with Firefox itself.

Separately, I just spent a good half hour looking for any documentation at all about what changed API/developer-wise in Windows 10, and came back with "it will ship with directx 12, and the console window will be better, and the IE UA string will have 10.0 instead of 6.4" - all from assorted separate blogposts. There is no overview of API changes, and no other clue as to what broke, that I can find. There's even this hilarious Windows community thread where someone raises pretty much this question, and gets told "It has a start button again!" - http://answers.microsoft.com/en-us/windows/forum/windows_tp-winipp/windows-10-api-whats-new-whats-changed/58529426-5752-4b5b-8838-e6e0c407780e

So I'm running out of ideas on what to try at least until MS provides more info about what changed in Win10 as compared to Win8. When our input to their APIs is exactly what it always was, and there's no documentation about any of the APIs changing, it's essentially impossible to figure out what broke save by reverse engineering what MS is doing (which is probably, you know, against the terms of the preview program, and will take forever, etc.)

Jim, do you know if we have contacts at MS who can help here?
Flags: needinfo?(jmathies)
Until a release preview is out I wouldn't worry about win10 bugs. Nine times out of ten issues get fixed by the final. If not we can deal with it then.

> Jim, do you know if we have contacts at MS who can help here?

Not related to printing. We can open up a support request once the os hits final release if necessary.
Flags: needinfo?(jmathies)
Duplicate of this bug: 1100156
Well, an additional data point:

printing appears to be working again on Win10 TP Build 9926. My FF is Nightly 38.0a1 (2015-01-23). I think the API guess is the right one.

And another one: RDPing from the win10 machine to a win7 machine which is running nightly is also somehow strange. This started happening about a month ago... when nightly was already running on opening up the RDP connection, it behaved normally. When restarted, it crashed (but this went away after a few nightly updates). But when started anew in the RDP session, it simply won't render anything to the screen. Huh? Well whatever is the cause for this, it has to do with the combination of Win10 (build 9879 and 9926, both show it), and Nightly running on the remote machine. 

But good thing that printing now works again. I propose to close this bug.

with best regards

Jens
Success for me as well.  It looks like the Cortana update was good for something after all (instead of just adding another feature to disable ;)
Thanks guys!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
I think that what this does prove is that MS was clearly at fault here - whether malicious or "innocent".
Summary: Printing on Windows 10 prints blank pages on tech preview 9860 and later → Printing on Windows 10 prints blank pages between tech preview 9860 and 9926
You need to log in before you can comment on or make changes to this bug.