crash in java.lang.IllegalStateException: at android.media.MediaCodec.dequeueInputBuffer(Native Method)

VERIFIED FIXED in Firefox 34

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: snorp)

Tracking

({crash})

36 Branch
Firefox 36
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox34 verified, firefox35 verified, firefox36 verified, fennec35+)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-faf177c8-006c-4b74-86d5-628672141025.
=============================================================

java.lang.IllegalStateException
	at android.media.MediaCodec.dequeueInputBuffer(Native Method)
	at dalvik.system.NativeStart.run(Native Method)
	at dalvik.system.NativeStart.run(Native Method)
Android CPU ABI
Created attachment 8512148 [details] [diff] [review]
Catch MediaCodec exceptions

This is kind of a band aid until we start using generated JNI bindings which will hopefully make all of this a little nicer.
Attachment #8512148 - Flags: review?(gpascutto)
Comment on attachment 8512148 [details] [diff] [review]
Catch MediaCodec exceptions

Review of attachment 8512148 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/android/GeneratedSDKWrappers.cpp
@@ +163,5 @@
>      int32_t temp = env->CallIntMethod(wrapped_obj, jDequeueInputBuffer, a0);
> +    if (env->ExceptionCheck()) {
> +        env->ExceptionClear();
> +        env->PopLocalFrame(nullptr);
> +        return -255;

magic numbers
Attachment #8512148 - Flags: review?(gpascutto) → review+
(In reply to Gian-Carlo Pascutto [:gcp] from comment #2)
> Comment on attachment 8512148 [details] [diff] [review]
> Catch MediaCodec exceptions
> 
> Review of attachment 8512148 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: widget/android/GeneratedSDKWrappers.cpp
> @@ +163,5 @@
> >      int32_t temp = env->CallIntMethod(wrapped_obj, jDequeueInputBuffer, a0);
> > +    if (env->ExceptionCheck()) {
> > +        env->ExceptionClear();
> > +        env->PopLocalFrame(nullptr);
> > +        return -255;
> 
> magic numbers

Yeah, I'll fix, thanks.
https://hg.mozilla.org/integration/mozilla-inbound/rev/bbc43d1d8691
Duplicate of this bug: 1089654
Duplicate of this bug: 1089262
Duplicate of this bug: 1089261
The patch fixes exception handling for several calls, so I marked the others as dups of this one.
https://hg.mozilla.org/mozilla-central/rev/bbc43d1d8691
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
tracking-fennec: ? → 35+
Comment on attachment 8512148 [details] [diff] [review]
Catch MediaCodec exceptions

Approval Request Comment
[Feature/regressing bug #]: bug 1014614
[User impact if declined]: Crashes, assuming bug 1014614 is uplifted
[Describe test coverage new/current, TBPL]: Nightly for a week
[Risks and why]: Low, only catches exceptions
[String/UUID change made/needed]: None
Attachment #8512148 - Flags: approval-mozilla-beta?
Attachment #8512148 - Flags: approval-mozilla-aurora?
Attachment #8512148 - Flags: approval-mozilla-beta?
Attachment #8512148 - Flags: approval-mozilla-beta+
Attachment #8512148 - Flags: approval-mozilla-aurora?
Attachment #8512148 - Flags: approval-mozilla-aurora+
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: affected → fixed
Looks like snorp landed this on Aurora and forgot to mark the bug.

https://hg.mozilla.org/releases/mozilla-aurora/rev/ce9444649361
status-firefox35: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?changeset=5811de401315
status-firefox34: affected → fixed
status-firefox34: fixed → affected
Relanded on beta
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?changeset=53692e16c248
status-firefox34: affected → fixed
As mentioned in bug 1089261 comment 3, there's been 0 crashes reported in the last week. Marking this bug verified fixed based on crash-stats.
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
status-firefox36: fixed → verified
You need to log in before you can comment on or make changes to this bug.