Closed Bug 1089811 Opened 5 years ago Closed 5 years ago

nsIDOMGlobalObjectConstructor is dead code

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: dzbarsky, Assigned: dzbarsky)

References

Details

(Keywords: addon-compat, dev-doc-complete)

Attachments

(1 file)

Attached patch Remove itSplinter Review
No description provided.
Attachment #8512191 - Flags: review?(bzbarsky)
Comment on attachment 8512191 [details] [diff] [review]
Remove it

r=yay
Attachment #8512191 - Flags: review?(bzbarsky) → review+
This was once landed and backed out due to SeaMonkey breakage. See bug 898136.
But we can land this anyway and let c-c developers fix bug 900243 because it is not a hard requirement to keep c-c green.
Duplicate of this bug: 898136
Neil, are you ok with this change landing?
Flags: needinfo?(neil)
Sorry, I thought I was still waiting for attachment 8413156 [details] [diff] [review] for some reason.
I'm OK assuming we can arrange for the patches to land reasonably closely together.
Flags: needinfo?(neil)
Depends on: 900243
https://hg.mozilla.org/mozilla-central/rev/d4cf01ce854b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
https://developer.mozilla.org/en-US/Firefox/Releases/36
> The non-standard GlobalObjectConstructor interface has been removed ({{bug(898136)}}).

This is wrong. the GlobalObjectConstructor was removed since Firefox 25:
https://developer.mozilla.org/en-US/Firefox/Releases/25/Site_Compatibility
(Hm, someone already removed based on the wrong information.)
Bug 898136 (and the backout thereof) is not related with the exposure on the global object. Bug 898817 is.

Changes to site compatibility docs for 25 and 36 should be reverted. Flagging dev-doc-needed again so that we don't forget.
So, if the changes I made weren't correct, what does need to be documented here? Clearly I don't understand what impact this has, if any.

I've moved the menution of this removal from Firefox 36 for developers to Firefox 25 for developers, here:

https://developer.mozilla.org/en-US/Firefox/Releases/25#Interfaces.2FAPIs.2FDOM
nsIDOMGlobalObjectConstructor was used to add arguments to constructors of APIs that add-ons exposed on the global object. It will not work anymore. We have no immediate alternatives.
It will affect only add-ons; no website impact (hence only addon-compat keyword was added).
(In reply to Masatoshi Kimura [:emk] from comment #12)
> nsIDOMGlobalObjectConstructor was used to add arguments to constructors of
> APIs that add-ons exposed on the global object. It will not work anymore. We
> have no immediate alternatives.
> It will affect only add-ons; no website impact (hence only addon-compat
> keyword was added).

Well, this also affects documentation, since we document add-on authoring. But sounds like I don't need to go into any further detail to speak of, so I'll call this doc-complete (although I did add a touch of explanation of what the interface used to do.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.