Last Comment Bug 898817 - Stop exposing nsIDOM* interfaces on the global automatically
: Stop exposing nsIDOM* interfaces on the global automatically
Status: RESOLVED FIXED
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla25
Assigned To: Masatoshi Kimura [:emk]
:
Mentors:
Depends on:
Blocks: 898687 899388
  Show dependency treegraph
 
Reported: 2013-07-27 23:02 PDT by Masatoshi Kimura [:emk]
Modified: 2013-08-03 12:29 PDT (History)
7 users (show)
VYV03354: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (14.08 KB, patch)
2013-07-27 23:02 PDT, Masatoshi Kimura [:emk]
bzbarsky: review+
Details | Diff | Splinter Review
test_interfaces.html updatebug898817_test (7.61 KB, patch)
2013-07-28 15:31 PDT, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
test_interfaces.html update (7.68 KB, patch)
2013-07-28 15:38 PDT, Masatoshi Kimura [:emk]
bzbarsky: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] 2013-07-27 23:02:32 PDT
Created attachment 782221 [details] [diff] [review]
patch

This will cleanup useless junks on the global.
Comment 1 Masatoshi Kimura [:emk] 2013-07-27 23:02:51 PDT
https://tbpl.mozilla.org/?tree=Try&rev=30a286f813f0
Comment 2 Olli Pettay [:smaug] 2013-07-28 10:11:41 PDT
Comment on attachment 782221 [details] [diff] [review]
patch

I think we should do this, but also think that peterv or bz should review this change.

Could you provide a list of things this removes from global.
Comment 3 Andrew McCreight [:mccr8] 2013-07-28 10:16:20 PDT
Does dom/tests/mochitest/general/test_interfaces.html need to be updated to remove the interfaces that that are no longer exposed?  That would prevent regressions.
Comment 4 Andrew McCreight [:mccr8] 2013-07-28 10:18:30 PDT
Also, at a minimum the comment in there should be update.
Comment 5 Olli Pettay [:smaug] 2013-07-28 10:19:17 PDT
Yes, it should be updated.
Comment 6 Masatoshi Kimura [:emk] 2013-07-28 15:31:26 PDT
Created attachment 782316 [details] [diff] [review]
test_interfaces.html updatebug898817_test

This patch will serve a purpose of unexposed interface list.
Comment 7 Masatoshi Kimura [:emk] 2013-07-28 15:38:42 PDT
Created attachment 782318 [details] [diff] [review]
test_interfaces.html update

The previous patch failed to resolve conflict with bug 898687.
Comment 8 Mounir Lamouri (:mounir) 2013-07-29 03:32:25 PDT
I switched the review to bz because peterv is currently on vacation.
Comment 9 Olli Pettay [:smaug] 2013-07-29 04:33:08 PDT
Ah, indeed. I thought he was coming back sooner.
Comment 10 Olli Pettay [:smaug] 2013-07-29 04:37:35 PDT
Comment on attachment 782318 [details] [diff] [review]
test_interfaces.html update

Don't we want CSSUnknownRule.
Comment 11 Masatoshi Kimura [:emk] 2013-07-29 07:55:38 PDT
(In reply to Olli Pettay [:smaug] from comment #10)
> Comment on attachment 782318 [details] [diff] [review]
> test_interfaces.html update
> 
> Don't we want CSSUnknownRule.

CSSOM does not define CSSUnknownRule anymore.
http://dev.w3.org/csswg/cssom/
Also, neither IE11 nor Chrome define CSSUnknownRule. Web do not require the interface.
Comment 12 Boris Zbarsky [:bz] 2013-07-29 16:47:34 PDT
Comment on attachment 782221 [details] [diff] [review]
patch

r=me
Comment 13 Boris Zbarsky [:bz] 2013-07-29 16:49:41 PDT
Comment on attachment 782318 [details] [diff] [review]
test_interfaces.html update

"ParserJS" can go away too, right?
Comment 14 Masatoshi Kimura [:emk] 2013-07-29 21:24:46 PDT
(In reply to Boris Zbarsky (:bz) from comment #13)
> Comment on attachment 782318 [details] [diff] [review]
> test_interfaces.html update
> 
> "ParserJS" can go away too, right?

"ParserJS" was already removed by bug 816410, but I'll remove it while I'm here.
Comment 17 Kohei Yoshino [:kohei] 2013-08-03 12:29:29 PDT
Added to the site compatibility doc just in case:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/25/Site_Compatibility

Note You need to log in before you can comment on or make changes to this bug.