Only broken Windows slaves running at too small a resolution hit test_acceleration.html | Acceleration enabled on Windows XP or newer - didn't expect 0, but got it

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
28 days ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Details

(Whiteboard: [stockwell unknown})

Comment hidden (empty)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Component: Graphics → General Automation
Product: Core → Release Engineering
QA Contact: catlee
Summary: Intermittent test_acceleration.html | Acceleration enabled on Windows XP or newer - didn't expect 0, but got it → Only broken Windows slaves running at too small a resolution hit test_acceleration.html | Acceleration enabled on Windows XP or newer - didn't expect 0, but got it
Version: 36 Branch → unspecified
Comment hidden (Treeherder Robot)
Component: General Automation → Platform Support
QA Contact: catlee → coop
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please leave this open so we can find it the next time a slave gets messed up.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(tmp)-bash-4.1$ ./diagnose_intermittent_bug.py 1090643
{'builders': [('Windows 8 64-bit mozilla-central debug test mochitest-4', 2),
              ('Windows 8 64-bit b2g-inbound pgo test mochitest-4', 2),
              ('Windows 8 64-bit mozilla-central opt test mochitest-4', 2),
              ('Windows 8 64-bit fx-team debug test mochitest-4', 1),
              ('WINNT 6.2 mozilla-aurora pgo test mochitest-4', 1),
              ('Windows 8 64-bit mozilla-inbound debug test mochitest-4', 1),
              ('Windows 8 64-bit mozilla-inbound pgo test mochitest-4', 1),
              ('Windows 8 64-bit fx-team opt test mochitest-4', 1)],
 'repos': [('mozilla-central', 4),
           ('fx-team', 2),
           ('mozilla-inbound', 2),
           ('b2g-inbound', 2),
           ('mozilla-aurora', 1)],
 'slaves': [('t-w864-ix-131', 1),
            ('t-w864-ix-137', 1),
            ('t-w864-ix-148', 1),
            ('t-w864-ix-149', 1),
            ('t-w864-ix-164', 1),
            ('t-w864-ix-165', 1),
            ('t-w864-ix-117', 1),
            ('t-w864-ix-170', 1),
            ('t-w864-ix-156', 1),
            ('t-w864-ix-152', 1),
            ('t-w864-ix-091', 1)],
 'times': {'2014-10-28': 7, '2014-11-25': 4}}


I'd WFM this, Ryan?
Flags: needinfo?(ryanvm)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #12)
> Please leave this open so we can find it the next time a slave gets messed
> up.
Flags: needinfo?(ryanvm)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 1190868
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 15

Platform breakdown:
* windows7-32: 9
* linux32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-17&endday=2016-05-17&tree=all
Keywords: leave-open
79 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 78
* mozilla-inbound: 1

Platform breakdown:
* windows7-32: 78
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-18&endday=2016-05-18&tree=all
63 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 63

Platform breakdown:
* windows7-32: 63

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-19&endday=2016-05-19&tree=all
203 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 202
* mozilla-inbound: 1

Platform breakdown:
* windows7-32: 190
* linux32: 7
* linux64: 3
* windows8-64: 2
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-16&endday=2016-05-22&tree=all
26 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 26

Platform breakdown:
* windows7-32: 26

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-23&endday=2016-05-29&tree=all
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 16

Platform breakdown:
* windows7-32: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-03&endday=2016-06-03&tree=all
49 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 49

Platform breakdown:
* windows7-32: 49

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-05-30&endday=2016-06-05&tree=all
21 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 21

Platform breakdown:
* windows7-32: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-07&endday=2016-06-07&tree=all
Uh, something seems to have changed in the last month to make this failure real bad. We're hitting tens of failures per day, on Try at least.  This test failed on 5/8 Win7 "gpu" test runs, on an intern's Try push earlier today: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b5b5b786e40d

Coop, do you know what needs doing here? Per comment 12, it sounds like we were waiting for this to happen reliably so we could investigate. It seems to be happening pretty reliably now.
Flags: needinfo?(coop)
Bug 1274328 needs to hit treeherder production. Those are misstars which have nothing to do with this bug, and everything to do with an ill-considered way of rolling out Win7 tests on AWS instances which are not actually capable of running tests.
Flags: needinfo?(coop)
23 automation job failures were associated with this bug yesterday.

Repository breakdown:
* try: 23

Platform breakdown:
* windows7-32: 23

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-08&endday=2016-06-08&tree=all
99 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 99

Platform breakdown:
* windows7-32: 99

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-06&endday=2016-06-12&tree=all
How do we know when bug 1274328 has hit treeherder production?
(Reporter)

Comment 32

2 years ago
(In reply to Jonathan Watt [:jwatt] from comment #31)
> How do we know when bug 1274328 has hit treeherder production?

Bug 1280496 needs to be resolved so that a new push to treeherder-production can happen.
Depends on: 1280496
14 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 14

Platform breakdown:
* windows7-32: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-13&endday=2016-06-19&tree=all
28 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 28

Platform breakdown:
* windows7-32: 15
* windows7-32-vm: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2016-06-20&endday=2016-06-26&tree=all
Duplicate of this bug: 1319280
1 failures in 949 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-08-14&endday=2017-08-20&tree=all
2 failures in 939 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 2

Platform breakdown:
* windows7-32-stylo: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-08-28&endday=2017-09-03&tree=all
1 failures in 924 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-09-04&endday=2017-09-10&tree=all

Updated

11 months ago
Duplicate of this bug: 1400002
In the spectacularly unlikely event that anyone looks at the upcoming explosion in this, it's bug 1400071.
30 failures in 1032 pushes (0.029 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-inbound: 11
* autoland: 11
* mozilla-central: 8

Platform breakdown:
* windows10-64: 30

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-09-11&endday=2017-09-17&tree=all
1 failures in 943 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-09-18&endday=2017-09-24&tree=all
2 failures in 824 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2

Platform breakdown:
* windows7-32: 1
* windows10-64-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-10-02&endday=2017-10-08&tree=all
1 failures in 947 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows10-64-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-10-09&endday=2017-10-15&tree=all
2 failures in 912 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* windows7-32-stylo-disabled: 1
* windows10-64-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-10-23&endday=2017-10-29&tree=all
1 failures in 857 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* windows10-64-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-10-30&endday=2017-11-05&tree=all
There have been 30 total failures in the last 7 days.
This started occurring again on December 17th. 
It had a peak on 21 Decembe and from that moment on, it seems the failure number was reduced to 0


Occurrences per platform:
15 - Windows 7
15 - windows10-64


Occurrences per build type:
10 - debug
10 - opt
10 - pgo


Here is a recent relevant log file: https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=153054678&lineNumber=2001
And a snippet with the failure:

00:14:45     INFO -  1 INFO TEST-START | gfx/tests/mochitest/test_acceleration.html
1999
00:14:46     INFO -  TEST-INFO | started process screenshot
2000
00:14:46     INFO -  TEST-INFO | screenshot: exit 0
2001
00:14:46    ERROR -  2 INFO TEST-UNEXPECTED-FAIL | gfx/tests/mochitest/test_acceleration.html | Acceleration enabled on Windows XP or newer - didn't expect +0, but got it
2002
00:14:46     INFO -      SimpleTest.isnot@SimpleTest/SimpleTest.js:324:5
2003
00:14:46     INFO -      runTest@gfx/tests/mochitest/test_acceleration.html:99:9
2004
00:14:46     INFO -      EventListener.handleEvent*@gfx/tests/mochitest/test_acceleration.html:25:1
2005
00:14:46     INFO -  Not taking screenshot here: see the one that was previously logged
2006
00:14:46    ERROR -  3 INFO TEST-UNEXPECTED-FAIL | gfx/tests/mochitest/test_acceleration.html | Direct2D enabled on Windows 8 or newer
2007
00:14:46     INFO -      runTest@gfx/tests/mochitest/test_acceleration.html:111:9
2008
00:14:46     INFO -      EventListener.handleEvent*@gfx/tests/mochitest/test_acceleration.html:25:1
2009
00:14:46     INFO -  4 INFO TEST-PASS | gfx/tests/mochitest/test_acceleration.html | DirectWrite enabled on Windows 7 or newer
2010
00:14:46     INFO -  Not taking screenshot here: see the one that was previously logged
2011
00:14:46    ERROR -  5 INFO TEST-UNEXPECTED-FAIL | gfx/tests/mochitest/test_acceleration.html | Advanced Layers enabled on Windows; Basic:false - didn't expect +0, but got it
2012
00:14:46     INFO -      SimpleTest.isnot@SimpleTest/SimpleTest.js:324:5
2013
00:14:46     INFO -      runTest@gfx/tests/mochitest/test_acceleration.html:135:9
2014
00:14:46     INFO -      EventListener.handleEvent*@gfx/tests/mochitest/test_acceleration.html:25:1
2015
00:14:46     INFO -  6 INFO TEST-PASS | gfx/tests/mochitest/test_acceleration.html | WebRender disabled on Windows
2016
00:14:46     INFO -  GECKO(2824) | MEMORY STAT | vsize 1447MB | vsizeMaxContiguous 132383225MB | residentFast 82MB | heapAllocated 20MB
2017
00:14:46     INFO -  7 INFO TEST-OK | gfx/tests/mochitest/test_acceleration.html | took 1
Whiteboard: [stockwell unknown}
35 failures in 590 pushes (0.059 failures/push) were associated with this bug in the last 7 days. 

This is the #32 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-central: 12
* mozilla-inbound: 11
* mozilla-beta: 6
* autoland: 6

Platform breakdown:
* windows10-64: 16
* windows7-32: 15
* windows7-32-nightly: 1
* windows7-32-devedition: 1
* windows10-64-nightly: 1
* windows10-64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2017-12-18&endday=2017-12-24&tree=all
1 failures in 747 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1090643&startday=2018-03-05&endday=2018-03-11&tree=all
(Assignee)

Updated

3 months ago
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago28 days ago
Resolution: --- → WORKSFORME
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.