Closed Bug 109180 Opened 23 years ago Closed 23 years ago

First icon in classic doesn't render correctly

Categories

(SeaMonkey :: Themes, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: neil, Assigned: gregvalure)

References

Details

(Keywords: classic)

Attachments

(3 files, 5 obsolete files)

When the first button is enabled in the classic skin, only the top portion of
the image is rendering.

2001110703... it's been happening ever since the link toolbar was placed in the
nightlies.
what do you mean with "first button" ?
Can you attach a screenshot to this bug ?
Attached image The rendering error.
If you mouse over it, the icon dissapears alltogether.
themes
Assignee: blakeross → hewitt
Component: XP Apps: GUI Features → Themes
QA Contact: sairuh → pmac
i see this win98 2001110803 2001110903 - NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
first.gif and first-hover.gif in chrome/classic.jar are broken, they have just a
couple of lines at the top
link toolbar bugs -> nobody
Assignee: hewitt → nobody
*** Bug 110601 has been marked as a duplicate of this bug. ***
Attached image Non-Corrupt first.gif (obsolete) —
Attached image Non-Corrupt first-hover.gif (obsolete) —
These are the non-corrupt versions of the buttons I made for the link toolbar.
Blocks: 103053
Argh, you beat me to it.  However, looking at them I see that the vertical line
is one pixel too wide, they're not positioned the same within the image, and
hover doesn't look exactly like the others.

I made these two by filling in the pixels from first-disabled and by comparison
to next, previous, and last.  They're the right size, right color depth,
positioned correctly, and use the same palette as their equivalents for other
buttons.  As far as I know, they're ready to go as is.

Now can somebody finish this off by integrating them into the Classic theme?
Attached image Better first.gif (obsolete) —
Attached image Better first-hover.gif (obsolete) —
Your hover state looks different than the others.

(I made the origional icons for the link bar before it was included by default.  
Someone may have changed them along the lines since then)
Attached image last-hover.gif for comparison (obsolete) —
I based the hover icon on these files:

chrome://navigator/skin/first-disabled.gif - for the positioning
chrome://navigator/skin/previous-hover.gif - for the hover arrow
chrome://navigator/skin/last-hover.gif - for the hover line

Attaching how last-hover.gif appears on 2001111603 Win32.
Found the original uncorrupted icons among the attachments to bug 87428.  I was
only off by a couple of pixels.
CCing Gerv.  Maybe he can finish this off.
To get this checked in, you theoretically need review and super-review; I'm not
sure how this applies to image files. Good people would be ben or hewitt. CCing
hewitt for comment.

Please mark as obsolete all the wrong versions attached to this patch. To do
multiple ones at once, the best way is to attach a new, dummy, patch and make
them obsolete on that screen.

Gerv
Okay, being as I don't have the privileges to mark attachments obsolete, hewitt
hasn't commented in a week, and hewitt has previously disowned the bug because
it's part of the links bar, now what?

The two attachments named Final are the correct ones, as they've been poached
from the original bug.  The rest are obsolete.
Attachment #58247 - Attachment is obsolete: true
Attachment #58230 - Attachment is obsolete: true
Attachment #58229 - Attachment is obsolete: true
Attachment #58225 - Attachment is obsolete: true
Attachment #58224 - Attachment is obsolete: true
He hasn't disowned the bug, he's just said he's not going to fix it. But there
is a patch. Send him mail and ask him to approve the icons - I'm sure he will.

Gerv
ok some questions:
what are these images really called in the skin, and
is this something that will work in both mac and windows  classic. (I 
assume so).
If you tell me those items I'll r=
I thought they were called first.gif and first-hover.gif... I'll double check.  
Yup that's what it's called.  And they go in the skin\classic\navigator 
directory in the classic.jar file.

Yes they will work on a mac, linux too :)

r=andreww on the images.
sr=hewitt
ok who's checking this in?  Any takers? 
Keywords: classic
OS: Windows 2000 → All
Hardware: PC → All
fix checked into trunk
Being as we have a=, can we get this into the 0.9.7 branch as well?
Thanks, Joe. I was trying to get around to this but the tree was always closed.

Gerv
Blocks: 114455
Assigning
Assignee: nobody → gregvalure
Accepting on Greg's behalf since he fixed it (thanks Greg)
Status: NEW → ASSIGNED
This is fixed :-)

Gerv
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Verified (2001-12-21-04-trunk)
Status: RESOLVED → VERIFIED
No longer blocks: 114455
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: