Closed Bug 1092164 Opened 5 years ago Closed 3 years ago

Consider using the VisualElements_*.png files on Windows 8+ for the start screen/menu tile

Categories

(Firefox :: General, defect)

All
Windows 8
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1232679

People

(Reporter: ntim, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

It'd be nice if we could use the metro tile images for the Windows 8+ start screen/menu tile.
Jim, would that be possible ? Opera uses a metro image for their windows 8+ tile, and it still launches the desktop opera. It'd be nice if Firefox could do that as well.
Flags: needinfo?(jmathies)
Sure, love the idea but you need to figure out who's in charge of UX and ask them.

Gavin, who should Tim ping about this on the Fx team?
Flags: needinfo?(jmathies) → needinfo?(gavin.sharp)
I'm not sure what "start screen/menu tile" is referring to. Maybe shorlander knows.
Flags: needinfo?(gavin.sharp)
In 8 and up we have an application start screen tile that shows up when we create conventional desktop shortcuts. It currently displays the old desktop icon.
"Menu tile" is probably a win10 thing. I haven't had a chance to look muxh at 10, but from what I understand the new tile based shortcuts are everywhere, including the new start menu on the old desktop.
Oops, I meant to needinfo shorlander.
Flags: needinfo?(shorlander)
Attached image Windows 10 Start Menu
Even though I agree it would look nicer in that context I don't think it would be the right thing to do.

The distinction between apps that Microsoft is using in Windows 10 is still "Metro" apps with new tile style and "Classic" apps with the old application icon style.
Flags: needinfo?(shorlander)
(In reply to Stephen Horlander [:shorlander] from comment #7)
> Created attachment 8576859 [details]
> Windows 10 Start Menu
> 
> Even though I agree it would look nicer in that context I don't think it
> would be the right thing to do.
> 
> The distinction between apps that Microsoft is using in Windows 10 is still
> "Metro" apps with new tile style and "Classic" apps with the old application
> icon style.

The both type of apps are being unified in Windows 10. They currently have the same behaviour most of the time (Win 32 apps show full screen in touch mode, and modern apps show windowed in desktop mode). So I don't think those should be differenciated. I agree this would be confusing on Windows 8 though.

Stephen, what do you think ?
Flags: needinfo?(shorlander)
(In reply to Tim Nguyen [:ntim] from comment #8)
> (In reply to Stephen Horlander [:shorlander] from comment #7)
> > Created attachment 8576859 [details]
> > Windows 10 Start Menu
> > 
> > Even though I agree it would look nicer in that context I don't think it
> > would be the right thing to do.
> > 
> > The distinction between apps that Microsoft is using in Windows 10 is still
> > "Metro" apps with new tile style and "Classic" apps with the old application
> > icon style.
> 
> The both type of apps are being unified in Windows 10. They currently have
> the same behaviour most of the time (Win 32 apps show full screen in touch
> mode, and modern apps show windowed in desktop mode). So I don't think those
> should be differenciated. I agree this would be confusing on Windows 8
> though.
> 
> Stephen, what do you think ?

There's still the difference between touch centric and mouse/keyboard centric interfaces though.. aside from the start icon, how do you tell them apart?
(In reply to Jim Mathies [:jimm] from comment #9)
> (In reply to Tim Nguyen [:ntim] from comment #8)
> > (In reply to Stephen Horlander [:shorlander] from comment #7)
> > > Created attachment 8576859 [details]
> > > Windows 10 Start Menu
> > > 
> > > Even though I agree it would look nicer in that context I don't think it
> > > would be the right thing to do.
> > > 
> > > The distinction between apps that Microsoft is using in Windows 10 is still
> > > "Metro" apps with new tile style and "Classic" apps with the old application
> > > icon style.
> > 
> > The both type of apps are being unified in Windows 10. They currently have
> > the same behaviour most of the time (Win 32 apps show full screen in touch
> > mode, and modern apps show windowed in desktop mode). So I don't think those
> > should be differenciated. I agree this would be confusing on Windows 8
> > though.
> > 
> > Stephen, what do you think ?
> 
> There's still the difference between touch centric and mouse/keyboard
> centric interfaces though.. aside from the start icon, how do you tell them
> apart?

The windows 10 universal apps aren't really touch centric, and I think that's intentional at least for desktop users. You can tell them apart with their metro look, and their titlebar (they have a full screen button, and a slightly different style, but MS aims consistency)
Duplicate of this bug: 1172911
Blocks: windows-10
Flags: needinfo?(philipp)
(In reply to Jim Mathies [:jimm] from comment #9)
> There's still the difference between touch centric and mouse/keyboard
> centric interfaces though.. aside from the start icon, how do you tell them
> apart?

Definitely not the case anymore now that I've had a chance to look at this frankenos.
I think what we should do is look into specifying a consistent background color but continue using the full color Firefox icon, e.g. http://cl.ly/image/3U1Z3t260r05/o
Flags: needinfo?(shorlander)
Seems like Steven's screenshot in comment 13 is what's already working today (although one must manually right click & Pin To Start to get it there). So closing as WFM.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(philipp)
Resolution: --- → WORKSFORME
(In reply to Justin Dolske [:Dolske] from comment #14)
> Seems like Steven's screenshot in comment 13 is what's already working today
> (although one must manually right click & Pin To Start to get it there). So
> closing as WFM.

Not really, the firefox tile has a hardcoded blue in the mockup instead of following the system accent color.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Duplicate of this bug: 1226010
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232679
You need to log in before you can comment on or make changes to this bug.