Closed Bug 1092931 Opened 7 years ago Closed 7 years ago

[Dialer] Call log shows wrong header when locale changes

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- verified
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: chens, Assigned: chens)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1070481 +++

Precondition: 
Having at least 1 call log in dialer app, default locale is en-US

STR: 
1. Open dialer app and click call log tab
2. Click edit button, header should be 'Edit'
3. Select one call log item, header should be '1 selected'
4. Open settings app and change locale to fr
5. Go back to dialer app and observer header

Expected:
6. Dialer app header should be '1 sélectionné'

Actual: 
6. Dialer app header shows 'Modifier'

Device info:
Gaia-Rev        36d9f52883b420f90b759303609b2d27d6f94f2c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/97fd482ec87a
Build-ID        20141102161201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Duplicate of this bug: 1092928
Attached file Pull request to master (obsolete) —
Hi :drs, 

This patch takes the same approach as bug 1070481 to fix call log header count when locale changes, would you review this patch for master? thanks!
Assignee: nobody → shchen
Attachment #8515908 - Flags: review?(drs.bugzilla)
Comment on attachment 8515908 [details] [review]
Pull request to master

This fix is unsuitable for master and v2.1 because they both have the new l10n API which allows us to use data attributes to perform localization, requiring no JS to run when locales change. Could you investigate why these data attributes are being clobbered on locale changes?
Flags: needinfo?(shchen)
Attachment #8515908 - Flags: review?(drs.bugzilla) → review-
Correct myself, this issue does not reproduce on master, it only happens on 2.1.
Will take a look for what's happening on locale change.
Flags: needinfo?(shchen)
Bug 1052136 had cleanup mozL10n API usage in dialer app, it works fine with new l10n API so we don't have this issue on master. I've applied the patch from bug 1052136 to 2.1 branch and it works fine, should we uplift that patch directly or create another PR and wait for test result?
Flags: needinfo?(drs.bugzilla)
See Also: → 1052136
Ok, thanks for investigating. If someone wants to uplift bug 1052136 to 2.1, they can request it.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(drs.bugzilla)
Resolution: --- → WONTFIX
Attachment #8515908 - Attachment is obsolete: true
Attachment #8515908 - Flags: review-
Blocks: Woodduck
Verify passed, this issue can't be repro on  Woodduck 2.0.
Attachment:Verify_Woodduck_FR.MP4
Reproducing rate: 0/5

Woodduck 2.0 build:
Gaia-Rev        60146ec47cd38a8be8ed22e0116902eceb9ac067
Gecko-Rev       cdfbe9866cf0b71b33454926638ce0cd8bb1fb00
Build-ID        20141117050313
Version         32.0
Attached video Verify_Woodduck_FM.MP4
You need to log in before you can comment on or make changes to this bug.