remove impl for connect and close of MozNFCTag.

RESOLVED FIXED in Firefox 38, Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: allstars.chh, Unassigned)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [p=1])

Attachments

(2 attachments)

This is a follow-up bug for Bug 963541,
now we plan to do the connect to different RF interface in nfcd side, so we'd like to remove the remaining implementation of tag.connect and close.
(Assignee)

Updated

4 years ago
Assignee: nobody → allstars.chh
Created attachment 8549422 [details] [diff] [review]
Patch.
Attachment #8549422 - Flags: review?(dlee)
Created attachment 8549423 [details] [review]
nfcd Pull Request
Attachment #8549423 - Flags: review?(dlee)

Updated

4 years ago
Attachment #8549422 - Flags: review?(dlee) → review+

Updated

4 years ago
Attachment #8549423 - Flags: review?(dlee) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/181a72bbc0d1
Whiteboard: [p=1]
Target Milestone: --- → 2.2 S4 (23jan)
Comment on attachment 8549422 [details] [diff] [review]
Patch.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1109456

User impact if declined: 
Increasing dead code size.
Those code will not be run at all, we kept this because we thought Bug 1109456 will need them, but given that Bug 1109456 is landed and didn't use those API, we should remove them to prevent increasing code size.

Testing completed:
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
uuid in nsINfcContentHelper.idl is changed, however this is an internal interface.
Attachment #8549422 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/181a72bbc0d1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Attachment #8549422 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
v2.2: https://github.com/mozilla-b2g/platform_system_nfcd/commit/89fa29016f90f8aa111f6ee8dbfe11e6c2db5e80

https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/016ef62fa791
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox36: --- → wontfix
status-firefox37: --- → wontfix
status-firefox38: --- → fixed
(Assignee)

Updated

4 years ago
Blocks: 1131508
You need to log in before you can comment on or make changes to this bug.