Status

defect
RESOLVED DUPLICATE of bug 1092543
5 years ago
5 years ago

People

(Reporter: drs, Unassigned)

Tracking

unspecified
2.1 S8 (7Nov)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

The SIM selection buttons are missing from the SIM picker. The interesting thing about this is that they show up when taking a screenshot from software, but not on the actual device display. This leads me to believe that it's some kind of graphics issue.

This was originally unveiled by bug 1039631. I'm not sure what's causing the underlying platform issue, though. I don't think that bug 1039631 actually broke it at the time since it landed several months ago. This bug only showed up recently, within the last few days, IIRC. So I suspect that it's caused by some regression in Gecko.

Bug 1094374 is similar. I posted a patch there which fixes the issue but doesn't really make sense. There may be some kind of alpha channel, or layers issue going on here.
Milan, could you have someone on graphics take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(milan)
According to Johan, this only occurs on master.
Flags: needinfo?(milan) → needinfo?(bgirard)
BenWa, when you have a chance, can you take a look?
Alright let's rule out the common pitfalls first.

:drs can you try to reproduce with hardware composer disable from the developer menu? We have a few patches coming in that could fix this kind of issues.

Can you also get us a display list? You have to build with B2G_DUMP_PAINTING in your .userconfig sadly. We will be able to confirm that it's a graphics bug (or display list bug) if the items are in the display list.
Flags: needinfo?(drs.bugzilla)
I believe this issue was possibly fixed by bug 1092543

My buttons appear properly on the "Dial Voicemail via" SIM picker screen on the Flame 2.2(KK)(319mb)(Shallow Flash)

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107040206
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 64f4392d0bdc
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
(In reply to KTucker [:KTucker] from comment #5)
> I believe this issue was possibly fixed by bug 1092543

Yes, it is. Thanks for checking!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(drs.bugzilla)
Flags: needinfo?(bgirard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1092543
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.