Closed Bug 1095017 Opened 5 years ago Closed 5 years ago

Impossible to change the device name with the new in-content preferences

Categories

(Firefox :: Preferences, defect)

defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- wontfix
firefox38 --- verified
firefox39 --- verified

People

(Reporter: st3fan, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

Filed with today's Nightly, but has been there for a while.

Steps to reproduce:

* Select Nightly -> Preferences, go to the Sync tab.
* Change the device name
* Close the preferences tab
* Select Nightly -> Preferences, go to the Sync tab.

Expected: Device name has changed

Actual: Device name has not changed

Changing via about:config works. Seems to be primarily a UI issue.
I seem to recall that Ryan (maybe Mark?) hit this recently.
Yeah Ryan hit it when I was standing next to him and I promised to file a bug :-)
(In reply to Richard Newman [:rnewman] from comment #1)
> I seem to recall that Ryan (maybe Mark?) hit this recently.

I hit this for a couple of other fields in bug 1091320.
I can repro this, but we won't block on it.
Blocks: 718011
No longer blocks: ship-incontent-prefs
This is because we pass the wrong param in sync.js .
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Points: --- → 1
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
Iteration: --- → 39.1 - 9 Mar
Attachment #8572619 - Flags: review?(mhammond) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/cb689f6c881e
Component: Firefox Sync: UI → Preferences
Keywords: regression
OS: Mac OS X → All
Product: Mozilla Services → Firefox
Hardware: x86 → All
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/cb689f6c881e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
Comment on attachment 8572619 [details] [diff] [review]
pass the element instead of the pane object to gSyncUtils.changeName,

Approval Request Comment
[Feature/regressing bug #]: bug 1016300
[User impact if declined]: broken preference field in in-content prefs
[Describe test coverage new/current, TreeHerder]: nope :-(
[Risks and why]: very low, very simple change that fixes only the event handler that deals with this preference field
[String/UUID change made/needed]: nope
Attachment #8572619 - Flags: approval-mozilla-beta?
Attachment #8572619 - Flags: approval-mozilla-aurora?
(FWIW, 37 is only affected until the in-content prefs are turned off for LATE_BETA - so the last few betas + release won't be affected - but I would prefer to get as much testing as possible)
Comment on attachment 8572619 [details] [diff] [review]
pass the element instead of the pane object to gSyncUtils.changeName,

In-content prefs will be disabled in Beta 4 so there's no need to take this fix on m-b. Beta-
Attachment #8572619 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Attachment #8572619 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 39.0a1 (buildID: 20150317030206) and latest Aurora 38.0a2 (buildID: 20150316004007).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.