Remove PlacesUtils.getMostRecentBookmarkForURI

RESOLVED DUPLICATE of bug 1095406

Status

()

P4
normal
RESOLVED DUPLICATE of bug 1095406
4 years ago
9 months ago

People

(Reporter: mak, Unassigned)

Tracking

(Blocks: 3 bugs, {perf})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reserve-photon-performance] [qf-])

(Reporter)

Description

4 years ago
We must deprecate this pseudo-api and make its consumers use Bookmarks.jsm API.

Unfortunately here we are going sync->async so consumers won't be ready.
Flags: qe-verify-
Flags: firefox-backlog+
(Reporter)

Updated

4 years ago
Depends on: 979280, 951651
(Reporter)

Updated

4 years ago
No longer depends on: 979280
(Reporter)

Updated

4 years ago
Depends on: 979280
(Reporter)

Updated

4 years ago
No longer blocks: 1141547
(Reporter)

Updated

3 years ago
Priority: -- → P1
(Reporter)

Updated

3 years ago
Keywords: perf
Whiteboard: [qf]

Updated

2 years ago
Points: 5 → ---
Flags: firefox-backlog+
Priority: P1 → P2
Whiteboard: [qf] → [photon-performance] [qf]
Whiteboard: [photon-performance] [qf] → [photon-performance] [qf-]
Priority: P2 → P3
Whiteboard: [photon-performance] [qf-] → [reserve-photon-performance] [qf-]
(Reporter)

Updated

a year ago
Summary: Deprecate PlacesUtils.getMostRecentBookmarkForURI → Remove PlacesUtils.getMostRecentBookmarkForURI
Priority: P3 → P4
(Reporter)

Updated

a year ago
Depends on: 1131491
(Reporter)

Updated

a year ago
No longer depends on: 979280
(Reporter)

Updated

a year ago
Blocks: 1083465
(Reporter)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1095406
You need to log in before you can comment on or make changes to this bug.