Intermittent test_keyboard.py TestKeyboard.test_keyboard_basic | AssertionError: u'aG1 2Ds3~!=@.# ^a\u015bZ\xeed\xc6' != u'AG1 2Ds3~!=@.# ^a\u015bZ\xeed\xc6'

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: cbook, Assigned: zcampbell)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(4 attachments)

Reporter

Description

5 years ago
b2g_macosx64 mozilla-central opt test gaia-ui-test-functional-3

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=596469&repo=mozilla-central

19:48:13 ERROR - TEST-UNEXPECTED-FAIL | test_keyboard.py TestKeyboard.test_keyboard_basic | AssertionError: u'aG1 2Ds3~!=@.# ^a\u015bZ\xeed\xc6' != u'AG1 2Ds3~!=@.# ^a\u015bZ\xeed\xc6'
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Flags: needinfo?(zcampbell)
Flags: needinfo?(kgrandon)
Comment hidden (Legacy TBPL/Treeherder Robot)
Depends on: 1092195
This should now be resolved by backing out bug 1092195.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → FIXED
Assignee

Comment 6

5 years ago
Thanks Kgrandon. We'll fix it proper in the other bug.
Flags: needinfo?(zcampbell)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Looks like this first failed in https://treeherder.mozilla.org/ui/index.html#/jobs?repo=b2g-inbound&revision=1d8c71a4d1b6

Which contained Bug 1088706 - Accented characters like ñ are not highlighted after doing a search with them 

I think that bug introduce a regression in our tests
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 21

5 years ago
I'll work on this.
Assignee: nobody → zcampbell
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 30

5 years ago
Dave is going to have a look at this as he has a mac.

Dave, what I have found is that occasionally the keyboard opens and does not have the shift key on by default (that's the feature that makes the first key you type capitalised). I'm not sure if it sticks in this state or whether it's a slight race.
I've tried a sleep(1) after switch to keybframe in `switch_to_keyboard` in keyboard.app to see whether the keyboard is sometimes slow to load. Intermittency seemed to go down but not entirely.

On device I have seen the shift key change its style with a kind of outlined shift arrow, but on device at least this does not correlate with a test failure. It's also a state that you can't get the shift key into manually - the shift icon can only be solid grey, white or blue.
Flags: needinfo?(dave.hunt)
Comment hidden (Legacy TBPL/Treeherder Robot)
I'm unable to reproduce the failure, however I did notice something strange. Because the phone number is not entered via the on-screen keyboard, when the comments input is tapped, the keyboard is first shown with the telephone input type before switching to alphanumeric. I wonder if entering the phone number via the on-screen keyboard might help with the intermittents.

That said, this is a test for the keyboard, so do we really need to depend on the Contacts app? Could we just use the UI Tests app instead, and then there's no need to first enter a phone number?
Flags: needinfo?(dave.hunt)
I just tested changing this to the UI Tests app, and it seems to work well. My patch is attached.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 51

5 years ago
Posted file github pr
Attachment #8529077 - Flags: review?(florin.strugariu)
Assignee

Comment 52

5 years ago
Oh I didn't even notice that Dave had already filed a patch :/
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Attachment #8529077 - Flags: review?(florin.strugariu) → review+
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Looks like this was fixed
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Test test_keyboard.py is failing intermittently on v2.1 because number keyboard remains displayed when trying to type a string in the comment field. 
This patch is fixing the issue because the test waits for number keyboard to be dismissed before typing on comment field. 
I opened a PR with the uplift, and also started an adhoc run here: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/402/console
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
PR for v2.1
Attachment #8532521 - Flags: review?(robert.chira)
Attachment #8532521 - Flags: review?(florin.strugariu)
Attachment #8532521 - Flags: review?(robert.chira) → review+
QA Whiteboard: [fxosqa-auto-backlog+]
Attachment #8532521 - Flags: review?(florin.strugariu) → review+
merged on V2.1 https://github.com/mozilla-b2g/gaia/commit/e81d3e7590ad63113baaffd154fcfa73fc297499
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This test was fixed in the previous commit.

I can't find any reason why this started to fail again on macosx64.

From what it looks like the first letter is for some reason Upper case. This should not happen.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This intermittent failure and its dupe were MacOS specific. Bug 1139029 disabled Gip on this platform.
Blocks: 1139029
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.